最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把MACD公式中出现橙色柱体改为选股

把MACD公式中出现橙色柱体改为选股

来源:网络 点击: 时间:2019-03-24

编写要求:

请老师把以下公式中MACD在0轴上出现橙色柱体时改为选股指标,谢谢,辛苦了。 DIF:(EMA(C,5)-EMA(C,21))/EMA(C,21)*100,ColorF0F0F0; DEA:EMA(DIF,8),COLOR00DCDC; MACD:2*(DIF-DEA),COLOR0000DC,LINETHICK0; STICKLINE(MACD>0,MACD,0,8,1),COLOR0000DC; STICKLINE(MACD>0 AND MACDREF(MACD,1),MACD,0,8,1),COLORC800C8; X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0)); X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));{回} X2:=COUNT(MACDREF(MACD,1) AND C>O AND C>REF(C,1); STICKLINE(X1=0 AND MACD>0,MACD,0,8,0),ColorDCDC00; STICKLINE(X3,MACD,0,8,0),Color0854FF; POLYLINE(C>0,DIF),ColorF0F0F0; POLYLINE(C>0,DEA),COLOR00DCDC; PARTLINE(DIF,DIF>REF(DIF,1)),COLORRED,LAYER0; ER:=VOL/CAPITAL*100; ZD:=C/REF(C,1)*100-100; A0:=BARSLAST(CROSS(0.5,COUNT(MACD<0,3)>=3) AND (MACD>=1 OR DIF>=2)); A1:=CROSS(0.5,COUNT(MACD>REF(MACD,1),A0+1)=A0+1); A2:=REF(HHV(ER,A0+1),1)>=3 AND REF(HHV(ZD,A0+3),1)>=5; B0:=BARSLAST(A1 AND A2); B1:=COUNT(MACD=1); B3:=B1 AND B2; B4:=REF(B3,1) AND MACD>REF(MACD,1) AND C>O AND ZD>0; DRAWTEXT(B4,ABS(MACD)+1.5,'◆'),COLORYELLOW,align1;

解答:

?DIF:=(EMA(C,5)-EMA(C,21))/EMA(C,21)*100;

DEA:=EMA(DIF,8);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top