最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把大知慧“圆满启动”副图指标翻译成通达信副图源码

把大知慧“圆满启动”副图指标翻译成通达信副图源码

来源:网络 点击: 时间:2019-05-13

编写要求:

大知慧圆满启动副图源码: {秘密筹码} VAR22:=REF(LOW,1); VAR23:=((SMA(ABS((LOW - VAR22)),3,1) / SMA(MAX((LOW - VAR22),0),3,1)) * 100); VAR24:=EMA(IF((CLOSE * 1.2),(VAR23 * 10),(VAR23 / 10)),3); VAR25:=LLV(LOW,38); VAR26:=HHV(VAR24,38); VAR27:=IF(LLV(LOW,90),1,0); VAR28:=((EMA(IF((LOW <= VAR25),((VAR24 + (VAR26 * 2)) / 2),0),3) / 618) * VAR27); 主力秘密筹码:STICKLINE(VAR28,-50,VAR28/3-50,6,1),COLORred,LAYER7; {浮动筹码} VAR111:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100; VAR112:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; VAR113:=(SMA(VAR112,3,1)-18)*1.55; VAR114:=SMA(VAR113,3,1); VAR115:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100; VAR116:=SMA(VAR115,10,1); VAR117:=(EMA(SMA(VAR116,8,1),34)-25)*2.6; VAR118:=POW(MA(CLOSE,5),2)+MA(CLOSE,5); VAR119:=POW(MA(LOW,5),2)+MA(LOW,5); VAR11A:=POW(MA(HIGH,5),2)+MA(HIGH,5); VAR11B:=((VAR118-LLV(VAR119,64))/(HHV(VAR11A,64)-LLV(VAR119,64))*150+65-10)/2; VAR11C:=SMA(VAR11B,3,1)*1.5-46; VAR11D:=SMA(VAR11C,3,1); VAR11E:=3*VAR11C-2*VAR11D; VAR11F:=(VAR111+VAR112+VAR115)/3; VAR1110:=((VAR113+VAR113+VAR116+VAR11C)/4-15)*1.67; VAR1111:=((VAR114+VAR114+VAR117+VAR11D)/4-15)*1.67; VAR1112:=((VAR111+VAR115*2+VAR11F+VAR1110+VAR1111+VAR11B+VAR11C+VAR11D+VAR11E)/10-15)*1.67; VAR1113:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*(-1)+0.9; VAR1114:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*(-1)+0.92; VAR1115:=(HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.93; VAR1116:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*(-1)+0.94; VAR1117:=(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89))*(-1)+0.95; VAR1118:=(HHV(HIGH,120)-CLOSE)/(HHV(HIGH,120)-LLV(LOW,120))*(-1)+0.91; VAR1119:=(HHV(HIGH,180)-CLOSE)/(HHV(HIGH,180)-LLV(LOW,180))*(-1)+0.96; VAR111A:=((VAR1113*8+VAR1114*8+VAR1115*8+VAR1116+VAR1117+VAR1118+VAR1119)/28-0.1)*185; VAR111B:=SMA(VAR111A,3,1); VAR111C:=(SMA(VAR111B,8,1)-8)*1.18; 浮动筹码: (VAR1110+VAR1111+VAR1112+VAR11C+VAR11D+VAR11E+VAR111C+VAR117)/13,COLORWHITE,POINTDOT,LAYER7; 浮动筹码1: (VAR1110+VAR1111+VAR1112+VAR11C+VAR11D+VAR11E+VAR111C+VAR117)/21,COLORWHITE,POINTDOT,LAYER7; 浮动筹码2: (VAR1110+VAR1111+VAR1112+VAR11C+VAR11D+VAR11E+VAR111C+VAR117)/34,COLORWHITE,POINTDOT,LAYER7; {主要部分} VAR1AA:5,COLORGREEN; 止损:=CLOSE/(1.04); 逃命:=CLOSE/1.06; 趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORWHITE,LAYER0; 买警1: IF(趋势<=30,-30,0),LINETHICK1,COLORGREEN; 买警2: IF(趋势<=25,-25,0),LINETHICK1,COLORYELLOW; 买警3: IF(趋势<=15,-15,0),LINETHICK1,COLORMAGENTA; 买警4: IF(趋势<=10,-10,0),LINETHICK3,COLORRED; 卖5: IF(趋势>=105,96,105),LINETHICK2,COLORBLUE; 卖4: IF(趋势>=95,86,95),LINETHICK2,COLORRED; 卖3: IF(趋势>=88,79,88),LINETHICK2,COLORYELLOW; 卖2: IF(趋势>=81,66,81),LINETHICK2,COLORMAGENTA; 卖1: IF(趋势>=74,57,74),LINETHICK2,COLORBLUE; 准备启爆点:IF(CROSS(趋势,VAR1AA),0,-50),COLORMAGENTA,LINETHICK2; 神秘私募买点:IF((趋势<=3),-40,-50),COLORGREEN,LINETHICK2; 机构建增补仓:IF((趋势<5),-30,-50),COLORYELLOW,LINETHICK2; {中长趋势} RSV1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100; K1:=SMA(RSV1,6,1); D1:=SMA(K1,6,1); STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1) ,EMA(D1,3) ,REF(EMA(D1,3),1) ,3 ,0),COLORRED,LAYER1; STICKLINE(EMA(D1,3)REF(EMA(D2,6),1) ,EMA(D2,6) ,REF(EMA(D2,6),1) ,3 ,0),COLORMAGENTA,LAYER2; STICKLINE(EMA(D2,6)5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1; VARD:=散户>VAR4; VARE:=REF(LOW,1)*0.9; VARF:=LOW*0.9; VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL; VAR11:=EMA(VAR10,30); VAR12:=CLOSE-REF(CLOSE,1); VAR13:=MAX(VAR12,0); VAR14:=ABS(VAR12); VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100; VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100; VAR17:=BARSCOUNT(CLOSE); VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100; VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100; VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100; VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

解答:

?VAR22:=REF(LOW,1);

VAR23:=((SMA(ABS((LOW - VAR22)),3,1) / SMA(MAX((LOW - VAR22),0),3,1)) * 100);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top