最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 不错的RSI画线,并请股友给做一个途中底背离的选股

不错的RSI画线,并请股友给做一个途中底背离的选股

来源:网络 点击: 时间:2019-02-16

编写要求:

STICKLINE(C>0,0,30,10,0),COLOR353535; STICKLINE(C>0,30,50,10,0),COLOR454545; STICKLINE(C>0,50,80,10,0),COLOR555555; STICKLINE(C>0,80,95,10,0),COLOR757575; 强弱线:50,LINETHICK2,COLOR858585; 警示线:80,POINTDOT,COLORCYAN; 减仓线:90,COLOR00AA55,LINETHICK2; 清仓线:95,COLOR0000AA,LINETHICK2; LC:=REF(CLOSE,1); RSI5:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,NODRAW,COLORFFAAFF; RSI10:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100,NODRAW,COLORDDAADD; RSI20:SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100,NODRAW,COLORAA99AA; DRAWBAND(RSI5,RGB(195,125,195),RSI10,RGB(0,130,50)); DRAWBAND(RSI10,RGB(165,95,165),RSI20,RGB(0,100,20)); {金叉死叉} 金叉:CROSS(RSI5,RSI20) AND CROSS(RSI10,RSI20),COLORRED,NODRAW; DRAWTEXT(金叉,RSI5,'←'),COLORRED; 死叉:CROSS(RSI20,RSI10) AND CROSS(RSI20,RSI5),COLORGREEN,NODRAW; DRAWTEXT(死叉,RSI5,'←'),COLORGREEN; {RSI顶底背离} RS:=BARSLAST(REF(CROSS(RSI20,RSI5),1)); RS1:=REF(CLOSE,RS+1)RSI5 AND CROSS(RSI20,RSI5); 顶背离:IF(RS1,RSI5,DRAWNULL),CIRCLEDOT,COLORFFCC00; STICKLINE(RS1,RSI5,RSI5*0.9,0,0),COLORFFCC00; DRAWTEXT(RS1,RSI5*0.9,'顶背离'),COLORFFCC00; S1:=BARSLAST(REF(CROSS(RSI5,RSI20),1)); S1A:=REF(CLOSE,S1+1)>CLOSE AND RSI5>REF(RSI5,S1+1) AND CROSS(RSI5,RSI20); 底背离:IF(S1A,RSI5,DRAWNULL),CIRCLEDOT,COLOR6699FF; STICKLINE(S1A,RSI5,RSI5*1.1,0,0),COLOR6699FF; DRAWTEXT(S1A,RSI5*1.1,'底背离'),COLOR6699FF; {RSI划线} OB:=RSI5; A1:=REF(OB,P)=HHV(OB,2*P+1); B1:=FILTER(A1,P); C1:=BACKSET(B1,P+1); D1:=FILTER(C1,P);{高点} A2:=REF(OB,P)=LLV(OB,2*P+1); B2:=FILTER(A2,P); C2:=BACKSET(B2,P+1); D2:=FILTER(C2,P);{低点} R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1); 压力线:DRAWLINE(D1,OB,S11,OB,1),LINETHICK1,COLORCC33CC; T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1); 支撑线:DRAWLINE(D2,OB,U11,OB,1),COLOR00CCCC; DRAWTEXT(CURRBARSCOUNT=30,25,'强弱用来看趋势 背离用来看顶底'),COLORCC99FF; DRAWTEXT(CURRBARSCOUNT=30,15,'支撑压力辨起落 设定周期参数 P'),COLORCC99FF; N1:2,120,5;N2:2,250,10;N3:2,500,20;} {参数:P:1,20,3;}{支撑压力线的周期参数 P可调}

解答:

?N1:=5;N2:=10;N3:=20;

LC:=REF(CLOSE,1);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top