最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把杂烩信号里的紫色未来信号做个选股预警公式

把杂烩信号里的紫色未来信号做个选股预警公式

来源:网络 点击: 时间:2019-03-16

编写要求:

A7:=C-REF(C,1); A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6); SHORT:=7; LONG:=19; RMA:=EMA(CLOSE,SHORT); NMA:=EMA(CLOSE,LONG); UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),0); DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),0); MA20:=MA(C,20); MA30:=MA(C,30); QSXS:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1); ZF:=(C/REF(C,1)-1)*100; N1:=BARSLAST(CROSS(C,MA(C,5))); N2:=BARSLAST(CROSS(MA(C,5),C)); HM:=IF(N1=0 AND C>O AND QSXS; KX1:=ZF<=-3 AND C=3 AND C>O; JBY:=KX2 AND XDSJ<=2 AND C>=REF(O*0.99,XDSJ) AND ZF>ABS(REF(ZF,XDSJ)*0.99); Z3:=IF(FILTER(JBY,1) AND QSXS,5,0); VAR11:=EMA(HHV(HIGH,500),21); VAR2:=EMA(HHV(HIGH,250),21); VAR3:=EMA(HHV(HIGH,90),21); VAR4:=EMA(LLV(LOW,500),21); VAR5:=EMA(LLV(LOW,250),21); VAR6:=EMA(LLV(LOW,90),21); VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR11*0.558+VAR2*0.558+VAR3*0.558)/6,21); VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR11*0.55+VAR2*0.55+VAR3*0.65)/6,21); VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR11*0.68+VAR2*0.68+VAR3*0.68)/6,21); VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21); VARB:=REF(LOW,1); VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100; VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3); VARE:=LLV(LOW,30); VARF:=HHV(VARD,30); VAR10:=IF(MA(CLOSE,58),1,0); AA3:=( EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10); CC:=HHV(AA3,60); AR3:=(1-(MA(LOW,3))/(MA((HIGH+LOW+(2)*(CLOSE))/(4),20)))*(100)-(50)/(10); AVAR1:=MA(HHV(HIGH,485),17); AVAR2:=MA(HHV(HIGH,222),17); AVAR3:=MA(HHV(HIGH,96),17); AVAR4:=MA(LLV(LOW,485),17); AVAR5:=MA(LLV(LOW,222),17); AVAR6:=MA(LLV(LOW,96),17); AVAR7:=MA(((AVAR4)*(0.96)+(AVAR5)*(0.96)+(AVAR6)*(0.96)+(AVAR1)*(0.558)+(AVAR2)*(0.558)+(AVAR3)*(0.558))/(6),17); AVAR8:=MA(((AVAR4)*(1.25)+(AVAR5)*(1.23)+(AVAR6)*(1.2)+(AVAR1)*(0.55)+(AVAR2)*(0.55)+(AVAR3)*(0.65))/(6),17); AVAR9:=MA(((AVAR4)*(1.3)+(AVAR5)*(1.3)+(AVAR6)*(1.3)+(AVAR1)*(0.68)+(AVAR2)*(0.68)+(AVAR3)*(0.68))/(6),17); AVARA:=MA((((AVAR7)*(3)+(AVAR8)*(2)+AVAR9)/(6))*(1.738),17); AVARB:=IF((DATE<=1341231),AVARA,(AVARA)*(DAY)); AVARC:=LOW; AVARD:=REF(LOW,1); AVARE:=((SMA(ABS(AVARC-AVARD),3,1))/(SMA(MAX(AVARC-AVARD,0),3,1)))*(100); AVARF:=MA(IF(((CLOSE)*(1.35)<=AVARB),(AVARE)*(10),(AVARE)/(10)),3); AVAR10:=LLV(LOW,30); AVAR11:=HHV(AVARF,30); AVAR12:=1341231; 买进:=(LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2))) AND REF(DOWN,1)REF(DOWN,1); 捡钱了未来:IF(买进,0,1),COLORMAGENTA,LINETHICK2; 抢钱了:Z2 AND Z3,LINETHICK2,COLORYELLOW; 大底:=FILTER(AA3>10 ,1); 找钱了:大底>0 AND C0) AND (DATE>901231) AND (DATE<1341231), (((AR3)*(3000))*(REF((HIGH+LOW+(2)*(CLOSE))/(4),3)))/(CLOSE),0),COLORRED,NODRAW; 点钞机:IF((DATE<=AVAR12),MA(IF((LOW<=AVAR10),(AVARF+(AVAR11)*(2))/(2),0),3),100000000),COLORYELLOW,NODRAW; STICKLINE(大底>0 AND C0,0,0.1,3,0),COLORRED; STICKLINE(点钞机>0,0.1,0.2,3,0),COLORCYAN;

解答:

?A7:=C-REF(C,1);

?A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);

标签:信号

    上一篇:写连续缩量回调的选股公式 下一篇:均线公式

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top