最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把通达信副图“找低”指标改写成选股公式

把通达信副图“找低”指标改写成选股公式

来源:网络 点击: 时间:2019-05-17

编写要求:

请老师帮忙把通达信副图“找低”指标改写成选股公式。出现“低”的位置 SJV:=FINANCE(34);{1é×ê2ú} êDê:C/SJV,NODRAW,COLOR00FF00; 1é?°oóà?èó:=(FINANCE(1)/FINANCE(29)); êDóˉ?ê:C/FINANCE(33),NODRAW,COLORFFFF00; DIF:=EMA(CLOSE,10)-EMA(CLOSE,22); DE:=EMA(DIF,7.5); MACDA:=2*(DIF-DE),; HZL:=CROSS(MACDA,0); LZH:=CROSS(0,MACDA); BC:=BARSLAST(HZL OR LZH)+1; ZGHZ:=IF(MACDA>0,HHV(MACDA,BC),0); ZGLZ:=IF(MACDA<0,LLV(MACDA,BC),0); DRAWBAND(ZGHZ,RGB(105,77,77),0,RGB(77,77,77)); DRAWBAND(ZGLZ,RGB(80,0,0),0,RGB(66,88,66)); DIFF:EMA(CLOSE,10)-EMA(CLOSE,22),COLORFFFFFF; DEA:EMA(DIFF,7.5),COLOR00FFFF; MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK0; STICKLINE(MACD>0 AND MACD>REF(MACD,1),0,MACD,1.5,1),COLORRED; STICKLINE(MACD>0 AND MACDREF(MACD,1),0,MACD,1.5,0),COLORFFAAFF; ?ü:TROUGHBARS(3,3,1),COLOR0000FF,NODRAW; ?y:PEAKBARS(3,3,1),COLOR00FF00,NODRAW; μí:IF(?ü=0,DIFF,IF(?y0 AND DIFF>DEA,DIFF,0,0,0),COLOR00FF00; DRAWTEXT(?ü=0 AND DIFF<0 AND DIFF0 AND DIFF>DEA,DIFF,''),COLOR00FF00; μíe2?:=CROSS(DIFF,DEA) AND DIFF<-0.1; JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); ?t′e2?:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1; AA1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); μ×±3à?:=(REF(L,AA1+1)>L OR REF(C,AA1+1)>C) AND (L,DIFF)>REF((L,DIFF),AA1+1) AND CROSS(DIFF,DEA); DRAWLINE(AA1=0,DEA,μ×±3à?,DEA,0),COLOR0000FF,LINETHICK1; AA2:=BARSLAST(REF(CROSS(DEA,DIFF),1)); ?¥±3à?:=(REF(C,AA2+1)(H,DIFF) AND CROSS(DEA,DIFF); DRAWLINE(AA2=0,DEA,?¥±3à?,DEA,0),COLORGREEN,LINETHICK1; DRAWICON(CROSS(DIFF,DEA) AND DIFF>0,DEA,36); DRAWICON(CROSS(DEA,DIFF) AND DIFF>0,DEA,37); DRAWICON(CROSS(DIFF,DEA) AND DIFF<0,DEA,1); DRAWICON(?t′e2?,DEA*0.9,36) ; ?a?ì1:=CONST(IF(MACD>0,1,0)); ?a?ì2:=CONST(IF(MACD<0,1,0)); ?a?ìA:=IF(?a?ì1=1,'a8×? ?òDD?£í· μ±1éò?2¨±èò?2¨ê±£?·′oì?ùμ£? ò±èòD?£¤?÷2úéúᥱ3à?ó£?ó|°ê±3?', IF(?a?ì2=1,'a8×? ?òDD?£í· μ±1éò?2¨±èò?2¨μíê±£? ·′ì?ùμò±èòD?£¤?÷2úéúá?μ×±3à?£?ó|ò', DRAWNULL)); DRAWTEXT_FIX((?a?ì1=1 OR ?a?ì2=1),0.16,0,0,?a?ìA),COLORFFEE00;

解答:

?diff:=ema(c,10)-ema(c,22);

dea:=ema(diff,7.5);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top