最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将此大智慧L2出现“起飞”为选股

将此大智慧L2出现“起飞”为选股

来源:网络 点击: 时间:2018-08-29

编写要求:

{K30} DRAWGBK(CLOSE > 0,STRIP(RGB(10,10,30),RGB(10,10,10),0)); VAR0:=FINANCE2(37)/1000000 * 100; VAR1:=FINANCE2(12); VAR2:=FINANCE2(10); DRAWTEXTABS(10,10,'流通盘大小:' + VAR0 + '亿手 '),COLORWHITE; DRAWTEXTABS(150,10,'销售毛利率:' + VAR1 + '% '),COLORWHITE; DRAWTEXTABS(280,10,'净利润同比增长:' + VAR2 + '% '),COLORWHITE; 当日换手率:SUM(100 * VOL/CAPITAL,1),LINETHICK0; DRAWTEXTABS(450,10,'当日换手率:' + NUMTOSTRN(SUM(100 * VOL/CAPITAL,1),2) + '%'),COLORWHITE; VAR3:=SUM(100 * VOL/CAPITAL,5); DRAWTEXTABS(570,10,'五日换手率:' + NUMTOSTRN(VAR3,2) + '%'),COLORWHITE; DRAWTEXTABS(10,30,'操盘纪律:『黄K买绿K卖紫K加仓』K线站上黄色能量线,突破并站稳紫线加仓,股价跌破能量线减仓,跌破生命线空仓,操作时间上午10点前,或者下午2点30后'),COLORYELLOW; VAR4:=EMA(LOW,3); VAR5:=EMA(LOW,10); VAR6:=EMA(LOW,20); VAR7:=EMA(LOW,30); VAR8:=EMA((VAR5 + VAR6 + VAR7) * 0.28,18); VAR9:=EMA(HIGH,10); VAR10:=EMA(HIGH,20); VAR11:=EMA(HIGH,30); VAR12:=EMA((VAR9 + VAR10 + VAR11) * 0.382,18); 黄金能量线:REF(EMA((2 * CLOSE + HIGH + LOW + OPEN)/5,5),1),LINETHICK2,COLORYELLOW; VAR13:=EMA((VAR9 + VAR10 + VAR11) * 0.382,10); VAR14:=EMA((VAR5 + VAR6 + VAR7) * 0.28,10); 生命线:(VAR13 + VAR14)/2,LINETHICK2,LAYER1,COLORMAGENTA; VAR15:=100 * (CLOSE - REF(CLOSE,1))/REF(CLOSE,1); VAR16:=IF(CLOSE < REF(OPEN,1) AND VAR15 < 0,1,0); VAR17:=IF(CLOSE < REF(OPEN,2) AND VAR15 < 0,1,0); STICKLINE(VAR16=0 AND REF(VAR16,1)=1 AND VAR17=0 AND REF(VAR17,1)=1,HIGH,LOW,0,1),COLOR00BBFF; STICKLINE(VAR16=0 AND REF(VAR16,1)=1 AND VAR17=0 AND REF(VAR17,1)=1,OPEN,CLOSE,8,0),COLOR00AAFF; STICKLINE(VAR16=0 AND REF(VAR16,1)=1 AND VAR17=0 AND REF(VAR17,1)=1,OPEN,CLOSE,6.6,0),COLOR00BBFF; STICKLINE(VAR16=0 AND REF(VAR16,1)=1 AND VAR17=0 AND REF(VAR17,1)=1,OPEN,CLOSE,4.4,0),COLOR00CCFF; STICKLINE(VAR16=0 AND REF(VAR16,1)=1 AND VAR17=0 AND REF(VAR17,1)=1,OPEN,CLOSE,3.3,0),COLOR00DDFF; STICKLINE(VAR16=0 AND REF(VAR16,1)=1 AND VAR17=0 AND REF(VAR17,1)=1,OPEN,CLOSE,2,0),COLOR00EEFF; STICKLINE(VAR16=0 AND REF(VAR16,1)=1 AND VAR17=0 AND REF(VAR17,1)=1,OPEN,CLOSE,0.8,0),COLORYELLOW; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,HIGH,LOW,0,1),COLORGREEN; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,8,0),COLOR008800; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,7,0),COLOR009900; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,6,0),COLOR00AA00; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,5,0),COLOR00BB00; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,4,0),COLOR00CC00; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,3,0),COLOR00DD00; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,2,0),COLOR00EE00; STICKLINE(VAR16=1 AND REF(VAR16,1)=0 AND VAR17=1 AND REF(VAR17,1)=0,OPEN,CLOSE,1,0),COLORGREEN; VAR18:=(HIGH + LOW + CLOSE + OPEN)/4; VAR19:=MA(VAR18,5); VAR20:=(VAR18/VAR19 - 1) * 100; VAR21:=VAR20 <= -12; VAR22:=(HIGH + LOW + CLOSE)/3; VAR23:=(VAR22 - MA(VAR22,14))/(0.015 * AVEDEV(VAR22,14)); VAR24:=SMA(MAX(CLOSE - REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE - REF(CLOSE,1)),6,1) * 100; VAR25:=(CLOSE/MA(CLOSE,5) - 1) * 100 < -10; VAR26:=(CLOSE/MA(CLOSE,13) - 1) * 100 < -10; VAR27:=(CLOSE/MA(CLOSE,34) - 1) * 100 < -15; VAR28:=VAR24 < 18; VAR29:=VAR23 < -120; VAR30:=(CLOSE - CYC(13))/CYC(13) * 100 < -20; VAR31:=COUNT(ABS(CLOSE/REF(CLOSE,1) - 1) * 100 >= 6,30) >= 1; VAR32:=VAR25 AND VAR26 AND VAR27 AND VAR28 AND VAR29 AND VAR31 AND VAR30; DRAWTEXT(VAR32 AND VAR21,LOW * 0.95,'超跌'),ALIGN1,VALIGN1,COLORYELLOW; VAR33:=REF(CLOSE,1)/REF(CLOSE,2) <= 0.93 AND BETWEEN(CLOSE/REF(CLOSE,1),1.03,0.97) AND CLOSE/REF(CLOSE,8) <= 0.8 AND BETWEEN(REF(CLOSE,2)/REF(CLOSE,3),1.04,0.96) AND BETWEEN(REF(CLOSE,3)/REF(CLOSE,4),1.04,0.96); STICKLINE(VAR33,HIGH,LOW,0,1),COLORF5A963; STICKLINE(VAR33,OPEN,CLOSE,8,0),COLORCF6E10; STICKLINE(VAR33,OPEN,CLOSE,7,0),COLOREF7B12; STICKLINE(VAR33,OPEN,CLOSE,4,0),COLORF08728; STICKLINE(VAR33,OPEN,CLOSE,2,0),COLORF29540; STICKLINE(VAR33,OPEN,CLOSE,1,0),COLORF5A963; DRAWTEXT(VAR33,LOW * 0.95,'抓涨停'),ALIGN1,VALIGN1,COLORRED; VAR34:=MA(LOW,5) * (1 - 5/100); VAR35:=(HHV(VAR34,5) + LLV(VAR34,5))/2; DRAWTEXT(CROSS(VAR35,LOW) AND VAR35 > REF(VAR35,1),LOW * 0.98,'洗盘'),ALIGN1,VALIGN1,COLORYELLOW; VAR43:=((CLOSE - REF(MA(CLOSE,18),1))/18 + MA(CLOSE,18)) * 1.004; VAR44:=CROSS(CLOSE,VAR43) AND VAR43 > REF(VAR43,1); VAR45:=7 * SMA((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)) * 30,4,1) - 3 * SMA(SMA((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)) * 30,4,1),3,1) - SMA(SMA(SMA((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)) * 30,4,1),3,1),2,1); VAR46:=EMA(MA(VAR45,5),7); VAR47:=EMA(IF(LOW <= LLV(LOW,40),SMA(ABS(LOW - REF(LOW,1)),40,1)/SMA(MAX(LOW - REF(LOW,1),0),40,1),0),3) * 10; VAR48:=VAR47 AND CROSS(VAR45,VAR46) AND VAR45 < 20 AND VAR23 < 0; VAR49:=MA(HIGH,5) * (1 + 5/100); VAR36:=MA(CLOSE,5); VAR37:=MA(CLOSE,10); VAR38:=MA(CLOSE,30); VAR39:=(MA(CLOSE,5) - MA(CLOSE,30))/MA(CLOSE,5) * 100; VAR40:=CLOSE > MA(CLOSE,5) AND OPEN < MA(CLOSE,5); VAR41:=CLOSE > MA(CLOSE,10) AND OPEN < MA(CLOSE,10); VAR42:=CLOSE > MA(CLOSE,30) AND OPEN < MA(CLOSE,30); DRAWTEXT(VAR40 AND VAR42 AND VAR41,LOW - 0.1,'←蛟龙'),COLORRED; 逃顶:CROSS(80,VAR24),LINETHICK0,POINTDOT,COLORYELLOW; DRAWICON(CROSS(80,VAR24),HIGH,2),ALIGN1,VALIGN1; STICKLINE(VAR44,HIGH,LOW,0.5,1),COLORFFBBFF; STICKLINE(VAR44,OPEN,CLOSE,8,0),COLORFF22FF; STICKLINE(VAR44,OPEN,CLOSE,7,0),COLORFF44FF; STICKLINE(VAR44,OPEN,CLOSE,6,0),COLORFF66FF; STICKLINE(VAR44,OPEN,CLOSE,5,0),COLORFF88FF; STICKLINE(VAR44,OPEN,CLOSE,4,0),COLORFF99FF; STICKLINE(VAR44,OPEN,CLOSE,3,0),COLORFFAAFF; STICKLINE(VAR44,OPEN,CLOSE,2,0),COLORFFBBFF; STICKLINE(VAR44,OPEN,CLOSE,1,0),COLORFFBBFF; DRAWTEXT(VAR44,LOW * 0.975,'加仓'),ALIGN1,VALIGN1,COLORYELLOW; VAR36:=MA(CLOSE,5); VAR37:=MA(CLOSE,10); VAR38:=MA(CLOSE,30); VAR39:=(MA(CLOSE,5) - MA(CLOSE,30))/MA(CLOSE,5) * 100; VAR40:=CLOSE > MA(CLOSE,5) AND OPEN < MA(CLOSE,5); VAR41:=CLOSE > MA(CLOSE,10) AND OPEN < MA(CLOSE,10); VAR42:=CLOSE > MA(CLOSE,30) AND OPEN < MA(CLOSE,30); DRAWTEXT(VAR40 AND VAR42 AND VAR41,LOW - 0.1,'←蛟龙'),COLORRED; DRAWTEXT(VAR48,LOW - 0.1,'起飞'),ALIGN1,VALIGN1,COLORWHITE; XS:MA(LOW,5) * (1 - 5/100),LINETHICK0; DRAWTEXT(CROSS(VAR49,CLOSE),HIGH * 1.005,'逃'),ALIGN1,VALIGN1,COLORGREEN;

解答:

?VAR22:=(HIGH + LOW + CLOSE)/3;

VAR23:=(VAR22 - MA(VAR22,14))/(0.015 * AVEDEV(VAR22,14));

标签:

    上一篇:MACD凹口预警公式 下一篇:缺口选股公式

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top