最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把机会难得副图写一选股公式

把机会难得副图写一选股公式

来源:网络 点击: 时间:2018-08-15

编写要求:

N. 2 50 6 LH. 5 100 80 VAR1:=REF(CLOSE,1); VAR2:=SMA(MAX(CLOSE-VAR1,0),18,1)/SMA(ABS(CLOSE-VAR1),13,1)*100; VAR3:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),20,1)*100; VAR4:=BARSLAST(VAR3<48)<=3 AND CROSS(VAR2,VAR3); VAR5:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,20)*100<-12.5; VAR6:=LLV(LOW,5); VAR7:=HHV(HIGH,10); VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4); VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2); VARA:=1011131; VARB:=IF(DATE<=VARA,VAR5,0) OR IF(DATE<=VARA,LH,0); 低吸: 0-(-1)*VAR4 AND VAR5 AND CROSS(VAR8,VAR9) AND VAR8<=25; DRAWTEXT(低吸>0,0.9,'★低吸'), , ; VARC:=REF(CLOSE,1); VARD:=SMA(MAX(CLOSE-VARC,0),7,1)/SMA(ABS(CLOSE-VARC),7,1)*100; VARE:=SMA(MAX(CLOSE-VARC,0),13,1)/SMA(ABS(CLOSE-VARC),13,1)*100; VARF:=BARSLAST(VARE<43)<=3 AND CROSS(VARD,VARE); VAR10:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<-12.5; VAR11:=LLV(LOW,5); VAR12:=HHV(HIGH,10); VAR13:=EMA((CLOSE-VAR11)/(VAR12-VAR11)*100,4); VAR14:=EMA(0.667*REF(VAR13,1)+0.333*VAR13,2); VAR15:=1011131; VAR16:=IF(DATE<=VAR15,VAR10,0) OR IF(DATE<=VAR15,LH,0); 机会难得: 0-(-1)*VARF AND VAR10 AND CROSS(VAR13,VAR14) AND VAR13<=25,COLORFFFF00; DRAWTEXT(机会难得>0,0.7,'★机会难得'), , ; VAR17:=REF(CLOSE,1); VAR18:=SMA(MAX(CLOSE-VAR17,0),7,1)/SMA(ABS(CLOSE-VAR17),7,1)*100; VAR19:=SMA(MAX(CLOSE-VAR17,0),13,1)/SMA(ABS(CLOSE-VAR17),13,1)*100; VAR1A:=BARSLAST(VAR19<33)<=3 AND CROSS(VAR18,VAR19); VAR1B:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<-12.5; VAR1C:=LLV(LOW,5); VAR1D:=HHV(HIGH,10); VAR1E:=EMA((CLOSE-VAR1C)/(VAR1D-VAR1C)*100,4); VAR1F:=EMA(0.667*REF(VAR1E,1)+0.333*VAR1E,2); VAR20:=1011131; VAR21:=IF(DATE<=VAR20,VAR1B,0) OR IF(DATE<=VAR20,LH,0); 难得一见: 0-(-1)*VAR1A AND VAR1B AND CROSS(VAR1E,VAR1F) AND VAR1E<=25,COLORMAGENTA , ; DRAWTEXT(难得一见>0,0.5,'★难得一见'), , ; VAR22:=REF(CLOSE,1); VAR23:=SMA(MAX(CLOSE-VAR22,0),7,1)/SMA(ABS(CLOSE-VAR22),7,1)*100; VAR24:=SMA(MAX(CLOSE-VAR22,0),13,1)/SMA(ABS(CLOSE-VAR22),13,1)*100; VAR25:=BARSLAST(VAR24<23)<=3 AND CROSS(VAR23,VAR24); VAR26:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<-12.5; VAR27:=LLV(LOW,5); VAR28:=HHV(HIGH,10); VAR29:=EMA((CLOSE-VAR27)/(VAR28-VAR27)*100,4); VAR2A:=EMA(0.667*REF(VAR29,1)+0.333*VAR29,2); VAR2B:=1011131; VAR2C:=IF(DATE<=VAR2B,VAR26,0) OR IF(DATE<=VAR2B,LH,0); 满仓买入: 0-(-1)*VAR25 AND VAR26 AND CROSS(VAR29,VAR2A) AND VAR29<=25,COLORGREEN ,; DRAWTEXT(满仓买入>0,0.3,'★满仓买入');

解答:

?VAR1:=REF(CLOSE,1);

VAR2:=SMA(MAX(CLOSE-VAR1,0),18,1)/SMA(ABS(CLOSE-VAR1),13,1)*100;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top