最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将主升浪源码中出现小手做选股

将主升浪源码中出现小手做选股

来源:网络 点击: 时间:2019-03-20

编写要求:

VAR3:=LLV(HIGH,240); VAR4:=((100 * (CLOSE - VAR3)) / VAR3); VAR5:=REF(LLV(CLOSE,480),1); VAR6:=REF(HHV(CLOSE,480),1); VAR7:=((100 * (CLOSE - VAR5)) / (VAR6 - VAR5)); VAR8:=(((CLOSE - LLV(CLOSE,981)) / (HHV(CLOSE,981) - LLV(CLOSE,981))) * 100); VAR9:=(((CLOSE - LLV(CLOSE,393)) / (HHV(CLOSE,393) - LLV(CLOSE,393))) * 100); VARA:=(((CLOSE - LLV(LOW,981)) / (HHV(HIGH,981) - LLV(LOW,981))) * 100); VARB:=(((CLOSE - LLV(LOW,393)) / (HHV(HIGH,393) - LLV(LOW,393))) * 100); VARC:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),5) / 4); VARD:=IF((DATE < 1031231),IF((VARC > 23.16),VARC,0),0); VARE:=(VARC < 1); VARF:=VARD; VAR10:=((VAR4 < 0) AND (VAR7 < 0)); VAR11:=1; VAR12:=((((HIGH + LOW) + (CLOSE * 2)) / 4) * VAR11); VAR13:=EMA(VAR12,21); VAR14:=STD(VAR12,21); VAR15:=((((((VAR12 - VAR13) / VAR14) * 100) + 200) / 4) * VAR11); VAR16:=(((EMA(VAR15,89) - 25) * 1.56) * VAR11); VAR17:=((EMA(VAR16,5) * 1.22) * VAR11); VAR18:=(EMA(VAR17,3) * VAR11); VAR19:=((3 * VAR17) - ((2 * VAR18) * VAR11)); VAR1A:=IF(((CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18)) AND CROSS(VAR17,VAR18)),1,0); VAR1B:=IF(((CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19)) AND CROSS(VAR18,VAR17)),1,0); 买点:=IF((FILTER(((((VAR8 = 0) AND VARE) AND VAR10) AND VAR1A),5) = 1),10,0),COLORRED; 卖点:=IF((FILTER((((VAR8 = 100) AND VARF) AND VAR1B),5) = 1),10,0),COLORGREEN; VAR1C:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),13) / 4); VAR1D:=(EMA(CLOSE,2) - EMA(CLOSE,89)); VAR1E:=EMA(VAR1D,30); VAR1F:=((2 * (VAR1D - VAR1E)) * 10); VAR20:=((POW(VAR1F,3) * 0.1) + POW(VAR1F,2)); VAR21:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE))); VAR22:=EMA((VAR21 * 0.97),3); VAR23:=(((HIGH + LOW) + CLOSE) / 3); VAR24:=((VAR23 - MA(VAR23,14)) / (0.015 * AVEDEV(VAR23,14))); VAR25:=(IF(((YEAR < 2008) AND (VAR1F > 0.015)),VAR20,0) / 45); 庄拉线:=VAR25,COLORYELLOW; VAR26:=(EMA(CLOSE,2) - EMA(CLOSE,150)); VAR27:=EMA(VAR26,100); VAR28:=(2 * (VAR26 - VAR27)); VAR29:=((POW(VAR28,3) * 0.1) + POW(VAR28,1)); VAR2A:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE))); VAR2B:=EMA((VAR2A * 0.97),3); VAR2C:=(((HIGH + LOW) + CLOSE) / 3); VAR2D:=((VAR2C - MA(VAR2C,14)) / (0.015 * AVEDEV(VAR2C,14))); 黑马线:(IF((VAR28 > 0.1),VAR29,0) * 5),COLORRED; {比例:IF((BETWEEN((黑马线/庄拉线),0.9,1.05) AND 黑马线>25),50,0 );} 量价线:(((CLOSE - MA(CLOSE,21)) / MA(CLOSE,21)) * 100),COLORFFFFFF; VAR2E:=IF((FILTER(((量价线 > 0) AND (量价线 < 3)),5) = 1),12,0); 涨幅前兆:=IF((FILTER(((((庄拉线 > 0) AND (庄拉线 < 0.5)) AND VAR2E) AND (VAR1C < 3)),10) = 1),10,0),COLORFFFFFF; 选股利器:=IF((FILTER((((((((VAR2E > 0) AND (VAR1C < 2)) AND (庄拉线 > 0)) AND (庄拉线 < 1)) AND (黑马线 > 0)) AND (黑马线 < 1.5)) AND (VAR2E > 0)),5) = 1),10,0),COLORFF00FF; DRAWICON((买点 > 0),10,1); DRAWICON((卖点 > 0),10,2); DRAWICON((涨幅前兆 > 0),10,1); DRAWICON((选股利器 > 0),10,1); 量价先行:(10 * CROSS(量价线,0)),COLORFFFF00; DRAWICON((量价先行 > 0),10,11); 庄拉主升浪:(30 * ((CROSS(庄拉线,黑马线) AND (黑马线 > 0)) AND (量价线 > 0))),LINETHICK3,COLORFF00FF; DRAWICON((庄拉主升浪 > 0),30,8);

解答:

?量价线:=(((CLOSE - MA(CLOSE,21)) / MA(CLOSE,21)) * 100),COLORFFFFFF;

(10 * CROSS(量价线,0)),COLORFFFF00;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top