最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将底和顶指标改为选股公式

将底和顶指标改为选股公式

来源:网络 点击: 时间:2019-02-22

编写要求:

底和顶指标: (请老师将出现绿色箭头指标改为选股公式) BIAS1:(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100; OBV:=BIAS1; P:=5; A1:=REF(OBV,P)=HHV(OBV,2*P+1); B1:=FILTER(A1,P); C1:=BACKSET(B1,P+1); D1:=FILTER(C1,P);{高点} A2:=REF(OBV,P)=LLV(OBV,2*P+1); B2:=FILTER(A2,P); C2:=BACKSET(B2,P+1); D2:=FILTER(C2,P);{低点} 上:REF(OBV,BARSLAST(D1)),COLORFF00FF,NODRAW; 下:REF(OBV,BARSLAST(D2)),COLOR00FF00,NODRAW; 向上:CROSS(OBV,上*1.01),NODRAW; 相对能量:(OBV-下)/(上-下)*100,COLORYELLOW,NODRAW; R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1); DRAWLINE(D1,OBV,S11,OBV,1),COLORYELLOW; T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1); DRAWLINE(D2,OBV,U11,OBV,1),COLOR00FF00; STICKLINE(C>0,下,下,1,0),COLOR00FF00; STICKLINE(C>0,上,上,1,0),COLORFF00FF; DRAWTEXT(CROSS(OBV,上*1.01),上,'上'),COLORYELLOW; DRAWTEXT(CROSS(下*0.99,OBV),下,'下'),COLORYELLOW; DRAWICON(D1,OBV,1); DRAWICON(D2,OBV,2); {向上突破高点连线,向下突破低点连线往往是转折点。};

解答:

?BIAS1:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

?OBV:=BIAS1;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top