最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把下面公式出现“买底”字样,改成选股公式

把下面公式出现“买底”字样,改成选股公式

来源:网络 点击: 时间:2019-02-12

编写要求:

求助:请老师把下面公式出现“买底”字样后第3天股价站在出现”买底“字样的当天收盘价上,改成选股公式。。公式源码: {N1:=5;N2:=10;N3:=20;N4:=30;P:=2;M:=20;N:=250;M1:=55; W:=21;P3:=500;} DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'14',0); 生命线:=MA(C,60); 牛熊线:=MA(C,120); DRAWBAND(生命线,RGB(200,50,55),牛熊线,RGB(0,100,50)); DRAWKLINE(H,O,L,C); MA1:EMA(CLOSE,N1),COLOR00FFFF; MA2:EMA(CLOSE,N2),COLORFF00FF; MA3:EMA(CLOSE,N3),COLORFFFFFF,LINETHICK2; MA4:=EMA(CLOSE,N4),COLOR00FF00; HR:=HHV(HIGH,M1); HRY:=LLV(LOW,M1); HRY11:=HR*HRY; HRY33:=SQRT(HRY11),COLORGREEN,LINETHICK2; TJ1:=CROSS(MA1,MA2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 OR CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 OR CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018; TJ2:=(MAX(MA1,MAX(MA2,MA3))-MIN(MA1,MIN(MA2,MA3)))/ MIN(MA1,MIN(MA2,MA3))*100<=P; XG:=TJ1 AND TJ2; STICKLINE(FILTER(TJ1,3),O,(C+O)/2,3,0),COLOR0000FF; DRAWICON(FILTER(XG,3),L*0.985,23); RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:=SMA(RSV,3,1); D:=SMA(K,3,1); DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26); DEA :=EMA(DIFF,9); MACD:=2*(DIFF-DEA); 做多:=IF(K>D AND MACD>0 AND V>1,2,0),COLORRED; 做空:=IF(K1,-2,0),COLOR00FF00; 强洗:=IF(MACD>0 AND K1,1,0),COLOR0099FF; 弱升:=IF(MACD<0 AND K>D AND V>1,-1,0),COLORFFFF00; STICKLINE(做多 AND C=O,C,O,3,1),COLOR00FF00; STICKLINE(强洗 AND CREF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3); EX1:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3); PL10:=ZIG(3,10); EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3); EX2:=ZIG(3,10)=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3); PL20:=ZIG(3,20); EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3); EX3:=ZIG(3,20)=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3); PL40:=ZIG(3,40); 走强1:=BARSLAST(PL5REF(PL5,1)); 走强2:=BARSLAST(PL10REF(PL10,1)); 走强3:=BARSLAST(PL20REF(PL20,1)); ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0); ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0); DTJZ5:=IF(PL10REF(PL20,1),COUNT(EN2,走强3),0); ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0); DTJZ10:=IF(PL20REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLORFF0000; DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF; DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR00FF00; DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLORFF00FF; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR00FF00; DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'〖Ⅰ〗'),COLORFF00FF; DRAWTEXT(EX2 AND DTJD10=2,H*1.05,'〖Ⅱ〗'),COLOR00FF00; DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,'〖Ⅲ〗'),COLOR0000FF; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'①'),LINETHICK3,COLORFFFF00; DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,'②'),LINETHICK3,COLOR00FFFF; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.03,'③'),LINETHICK3,COLOR00FF00; DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'④'),LINETHICK3,COLOR00FFFF; WLA:=EN1 AND DTJZ5=1; WLC:=EN2 AND ZTJZ5=1; WLⅠ:=EN2 AND DTJZ10=1; WLⅢ:=EN3 AND ZTJZ10=1; WL⑵:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2; WL⑷:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3; WL②:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2; WL④:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3; WLT01:=(WLA OR WLC) AND (WLⅠOR WLⅢ); WLT02:=(WLA OR WLC) AND (WL⑵ OR WL⑷ OR WL② OR WL④); WLT03:=(WLⅠOR WLⅢ) AND (WL⑵ OR WL⑷ OR WL② OR WL④); WLT:=WLT01 OR WLT03 OR WLT02; DRAWTEXT(WLT,LOW*0.90,'买底'),COLORYELLOW; TJ11:=EN2 AND ZTJZ5=1; TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2; TJ33:=EN2 AND DTJZ10=1; TJ44:=EN3 AND ZTJZ10=1; TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2; XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55; X1:=REF(C,1)/HHV(H,20)<0.82; X2:=(MIN(C,O)-L)/(H-L)>0.67; X3:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)<0.33; X4:=ABS(C-O)/C<0.01; DOWN:=O>C; X5:=COUNT(DOWN,7)>=5; XG8:=X1 AND X2 AND X3 AND X4 AND X5; DRAWTEXT(XG8,L*0.98,'←螺'),COLOR00FFFF; AA:=REF(C,1)/REF(O,1)<0.96; BB:=C/O>1.03; CC:=C>REF(O,1); TJ81:=AA AND BB AND CC; X81:=REF(C,1)/HHV(H,20)<0.82; DN:=O>C; X82:=COUNT(DN,7)>=5; X83:=C=HHV(C,3); XG81:=TJ81 AND X81 AND X82; XG82:=X81 AND X82 AND X83; XG88:=XG81 OR XG82; DRAWTEXT(XG88,L*0.96,'反'),COLOR00FFFF; IF(生命线>=牛熊线,生命线,DRAWNULL),COLORRED; IF(牛熊线>=生命线,牛熊线,DRAWNULL),COLORFF9900; IF(生命线>=牛熊线,牛熊线,DRAWNULL),COLOR00FFFF; IF(牛熊线>=生命线,生命线,DRAWNULL),COLOR00FF00; S1:=REF(C,1)/LLV(L,W)>1.30; S2:=(H-MAX(C,O))/(H-L)>0.60; S3:=ABS(C-O)/C<0.03; S4:=(H-O)/C>0.05 AND C0.05 AND C0.67 AND CCLOSE AND RSI>80),7); 红买:=FILTER(CROSS(RSI,11),7); 红卖:=FILTER(CROSS(89,RSI),7); 绿买:=FILTER(CROSS(RSI,20),7); 绿卖:=FILTER(CROSS(80,RSI),7); SL1:=红卖 AND 绿卖; SL2:=红卖 AND 绿卖 AND 黄卖; BU:=红买 AND 绿买; SS1:=CROSS(MA(C,5),C); SS2:=(REF(C,1)-C)/REF(C,1)>0.04; SS3:=O= XB1))); M11:=REF(M,1); N9:=BARSLAST(((CLOSE > ET) AND (C1 <= ET1))); N1:=REF(N9,1); M21:=(BARSLAST((((M - N9) > 0) AND (M11 <= N1))) + 1); N2:=(BARSLAST((((N9 - M) > 0) AND (N1 <= M11))) + 1); ET2:=HHV(ET,M21); XB2:=LLV(XB,N2); A:=IF((((M - N9) > 0) AND (M11 <= N1)),1,IF((((N9 - M) > 0) AND (N1 <= M11)),0,2)); H1:=IF(((M - N9) > 0),CLOSE,ET2); H2:=IF((A = 1),CLOSE,C2); H3:=IF(((M - N9) < 0),CLOSE,XB2); H4:=IF((A = 1),CLOSE,XB2); H5:=IF((((M - N9) > 0) OR (A = 1)),CLOSE,H3); H6:=REF(H5,1); H7:=REF(H5,2); H8:=(H5 > H6); H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) < REF(H4,2))) AND (H5 > REF(H5,2))); H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2))); W:=((H8 OR H9) OR H10); T9:=((H5 < H6) AND (H5 < REF(H5,2))); T10:=((H4 = REF(H4,1)) AND (H5 < REF(H5,2))); T11:=((H3 > REF(H3,1)) AND (H5 < REF(H5,1))); T12:=((H5 = REF(H5,1)) AND (H3 = H4)); T13:=((H2 = REF(H2,1)) AND (H2 = H5)); TW:=((((T9 OR T10) OR T11) OR T12) OR T13); PK:=((AMOUNT * (((OPEN + CLOSE) + HIGH) + LOW)) / 4); PK1:=IF((VOL > 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4)); BBP:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100); DRAWTEXT((ISLASTBAR AND (BBP >= 96.5)),(H5 * 1.033),'明见短高,龙头除外'),COLOR00FF00; DRAWTEXT((ISLASTBAR AND (BBP < 1)),((H5 + H4) / 1.96),'明见短低,跌停除外'),COLOR0000FF; DRAWTEXT(((ISLASTBAR AND W) AND (BBP < 96.5)),(H5 * 1.033),'看涨'),COLOR0015FF; DRAWTEXT(((ISLASTBAR AND TW) AND (BBP > 1)),((H5 + H4) / 2),'看跌'),COLOR00FF00; DRAWTEXT_FIX(1,0.0,0.00,0,EXTERNSTR(0,1))COLOR0077FF; DRAWTEXT_FIX(1,0.0,0.98,0,'★五里理念★:严守纪律, 趋势为先,波段操作, 坚决止损! '),COLOR0078FF; ZF:=(C-REF(C,1))/REF(C,1)*100>9.8; DRAWTEXT(ZF,L-0.55,'板...'),LINETHICK9;

解答:

?EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

PL10:=ZIG(3,10);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top