最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 诊断、修改一下信号共振选股公式不能放在条件选股里面用

诊断、修改一下信号共振选股公式不能放在条件选股里面用

来源:网络 点击: 时间:2019-02-14

编写要求:

这个公式已经是选股公式,想把它作为预警,可是在条件选股编辑器里通不过。公式测试时出现如下问题: 当前公式 : 信号共振 (条件选股公式) 错误句 : 三宝:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,COLORGREEN,NODRAW 详细信息 : 不是指标画线公式,不能指定画线类型! 错误起始位置 : 580 ; 长度: 3 原码如下: {金兰三宝} N:=9; N1:=6; M:=14; AAATYP := (HIGH + LOW + CLOSE)/3; AAA1:=(AAATYP-MA(AAATYP,M))/(0.015*AVEDEV(AAATYP,M)); C1:=SMA(AAA1,3,1); C2:=SMA(C1,3,1); C3:=3*C1-2*C2; CB1:=EMA(C3,5); CB2:=REF(CB1,1); LC := REF(CLOSE,1); RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100; RSI:=(RSI1-50)*5; R1:=SMA(RSI,3,1); D1:=SMA(R1,3,1); J1:=3*R1-2*D1; RR1:=EMA(J1,5); RR2:=REF(RR1,1); RR:=RR1>RR2; RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100; K:=SMA(RSV,3,1); K1:=(K-50)*5; K2:=SMA(K1,3,1); D2:=SMA(K2,3,1); J2:=3*K2-2*D2; BB1:=EMA(J2,5); BB2:=REF(BB1,1); 三宝:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,COLORGREEN,NODRAW; {极地上涨} VA1:=HHV(HIGH,9)-LLV(LOW,9); VA2:=HHV(HIGH,9)-CLOSE; VA3:=CLOSE-LLV(LOW,9); VA4:=VA2/VA1*100-70; VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100; VA6:=(CLOSE+HIGH+LOW)/3; VA7:=SMA(VA3/VA1*100,3,1); VA8:=LLV(LOW,34); VA9:=SMA(VA7,3,1)-SMA(VA4,9,1); VARA:=IF(VA9>100,VA9-100,0); VARB:=HHV(HIGH,34); VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13); VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2); VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25; VARF:=MA(VARE,3); VAR1:=HHV(HIGH,9)-LLV(LOW,9); VAR2:=HHV(HIGH,9)-CLOSE; VAR3:=CLOSE-LLV(LOW,9); VAR4:=((VAR2)/(VAR1))*(100)-70; VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100); VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4); VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1); VAR8:=LLV(LOW,34); VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1); VAR10:=IF((VAR9>100),VAR9-100,0); VAR11:=HHV(HIGH,34); B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8); 领先:=EMA(B1,5); 生命线:=EMA(VARD,1); V1:=MA(C,5)=HHV(MA(C,5),20); V2:=MA(C,5)>MA(C,10); V3:=MA(V,5)>MA(V,40)*1.01; V4:=COUNT(MA(C,1)>REF(C,1),2)=2; VV:=V1 AND V2 AND V3 AND V4; A1:=EMA(CLOSE,8); A2:=EMA(A1,20); A3:=CROSS(A1,A2); A4:=A1VARD AND VARC<55 AND C>O; A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100); 极地上涨:=A6; 极地:开始拉升>0 AND 开始拉升<400 OR 极地上涨>0 AND 极地上涨<400 OR (低位转强>0 AND 低位转强<400) OR (低位转强>0),COLORYELLOW,NODRAW; {好底} D:=EMA((C*3+H+L+O)/6,5); 买卖:=D,COLORGREEN,LINETHICK2; A线:=HHV(D,13)COLORYELLOW,LINETHICK2; B线:=LLV(D,13)COLORYELLOW,LINETHICK2;日平:="MACD.MACD#DAY"(12,26,9); 周平:="MACD.MACD#WEEK"(12,26,9); JC:=(A线-B线); 壹:=COUNT(JC>REF(JC,1)AND A线>REF(A线,1),5)=1 AND JC>REF(JC,1)AND A线>REF(A线,1)AND D>=REF(D,1); G1:=FILTER(壹=1,10); G2:=BARSLAST(G1>0); G3:=IFF(G2>0 AND G2<=10,1,0)=1 AND ((C-REF(C,G2))/REF(C,G2))*100>=5; 概壹:=(SUM(FILTER(G3,10),0)/SUM(G1>0,0))*100; 加1:=COUNT(日平>=0 AND 周平>=0,5)=1 AND 日平>=0 AND 周平>=0; 加2:=FILTER(D=A线 AND REF(D,1)0); ③:=IFF(②>0 AND ②<=10,1,0)=1 AND ((C-REF(C,②))/REF(C,②))*100>=5; 概加1:=(SUM(FILTER(③,10),0)/SUM(①>0,0))*100; 好底:FILTER(COUNT(D=B线,3)>=2 AND D>B线,5),COLORBLUE,NODRAW; {抄底} MMM:=1; SVOL:=INTPART(SUM(V,0)/CAPITAL); TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0; S1:=BARSLAST(TJ0)+1; TJJ2:=S11 AND EMA(X1,7)>REF(EMA(X1,7),1),10); MM:=WLT1>REF(WLT1,1) AND REF(WLT1,1)=3; WLT93:=CCI>WLT91; WLT96:=CROSS(CCI,100); TJ91:=WLT95 AND WLT96; JLP:=FILTER(TJ91,5); 超买:=MA(C,10)*IF(CAPITAL=0,1.04,1.1); 超卖:=MA(C,10)*IF(CAPITAL=0,0.95,0.9); TEND:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42); DD:=TEND>REF(TEND,1) AND REF(TEND,1) >REF(TEND,2); GG2:=CROSS(WLT1,TEND); HRY1:=LLV(LOW,55); HRY2:=HHV(HIGH,21); GG3:=CHRY33; JJ1:=C1; XG1:=XG AND XG2 AND C>HRY33 AND JLP; XG3:=XG AND CREF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3); EX1:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3); PL10:=ZIG(3,10); EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3); EX2:=ZIG(3,10)=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3); PL20:=ZIG(3,20); EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3); EX3:=ZIG(3,20)=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3); PL40:=ZIG(3,40); 走强1:=BARSLAST(PL5REF(PL5,1)); 走强2:=BARSLAST(PL10REF(PL10,1)); 走强3:=BARSLAST(PL20REF(PL20,1)); ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0); ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0); DTJZ5:=IF(PL10REF(PL20,1),COUNT(EN2,走强3),0); ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0); DTJZ10:=IF(PL20M4 AND SLOPE(M5,5)<0 AND SLOPE(M4,4)<0 AND SLOPE(MA3,3) AND REF(M4>MA3,1) AND CROSS(MA3,M4) AND VOL>VOL5,COLORRED,NODRAW; T1:=三宝+极地+好底+抄底+做牛有未来+雨青底; T2:=REF(T1,1); T3:=REF(T1,2); T4:=REF(T1,3); T5:=REF(T1,4); 选股综合:T1+T2+T3+T4+T5>=4;

解答:

?N:=9;

N1:=6;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top