最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将此交易护驾公式,按其过滤要求做一选股公式

将此交易护驾公式,按其过滤要求做一选股公式

来源:网络 点击: 时间:2019-05-20

编写要求:

解答:

?网友求助:

壹瓣杺埖老师改写的王照华老师的交易护驾通达信公式源码:
Z_1:=C-REF(C,1);
空:=EMA(EMA(Z_1,6),6)/EMA(EMA(ABS(Z_1),6),6)*20,LINETHICK0,COLOR00FF00;
多:=(空*2-FORCAST(空,9)),LINETHICK0,COLORFF59FF;
{警报}
J1:=IF(多<=空,多,DRAWNULL);
J2:=IF(多<=空,多,REF(J1,1));
J3:=IF(多<=空,多,REF(J2,1));
J4:=IF(多<=空,多,REF(J3,1));
J5:=IF(多<=空,多,REF(J4,1));
J6:=IF(多<=空,多,REF(J5,1));
J7:=IF(多<=空,多,REF(J6,1));
J8:=IF(多<=空,多,REF(J7,1));
J9:=IF(多<=空,多,REF(J8,1));
J10:=IF(多<=空,多,REF(J9,1));
J11:=IF(多<=空,多,REF(J10,1));
J12:=IF(多<=空,多,REF(J11,1));
J13:=IF(多<=空,多,REF(J12,1));
J14:=IF(多<=空,多,REF(J13,1));
J15:=IF(多<=空,多,REF(J14,1));
JJ_1:=IF(多<=空,多,REF(J15,1));

JJ1:=IF(多>空,空,DRAWNULL);
JJ2:=IF(多>空,空,REF(JJ1,1));
JJ3:=IF(多>空,空,REF(JJ2,1));
JJ4:=IF(多>空,空,REF(JJ3,1));
JJ5:=IF(多>空,空,REF(JJ4,1));
JJ6:=IF(多>空,空,REF(JJ5,1));
JJ7:=IF(多>空,空,REF(JJ6,1));
JJ8:=IF(多>空,空,REF(JJ7,1));
JJ9:=IF(多>空,空,REF(JJ8,1));
JJ10:=IF(多>空,空,REF(JJ9,1));
JJ11:=IF(多>空,空,REF(JJ10,1));
JJ12:=IF(多>空,空,REF(JJ11,1));
JJ13:=IF(多>空,空,REF(JJ12,1));
JJ14:=IF(多>空,空,REF(JJ13,1));
JJ15:=IF(多>空,空,REF(JJ14,1));
JJ_2:=IF(多>空,空,REF(JJ15,1));

K1:=IF(多>空,1,IF(多<空,-1,0));
KJ1:=IF(K1!=0,K1,DRAWNULL);
KJ2:=IF(K1!=0,K1,REF(KJ1,1));
KJ3:=IF(K1!=0,K1,REF(KJ2,1));
KJ4:=IF(K1!=0,K1,REF(KJ3,1));
KJ5:=IF(K1!=0,K1,REF(KJ4,1));
KJ6:=IF(K1!=0,K1,REF(KJ5,1));
KJ7:=IF(K1!=0,K1,REF(KJ6,1));
KJ8:=IF(K1!=0,K1,REF(KJ7,1));
KJ9:=IF(K1!=0,K1,REF(KJ8,1));
KJ10:=IF(K1!=0,K1,REF(KJ9,1));
KJ11:=IF(K1!=0,K1,REF(KJ10,1));
KJ12:=IF(K1!=0,K1,REF(KJ11,1));
KJ13:=IF(K1!=0,K1,REF(KJ12,1));
KJ14:=IF(K1!=0,K1,REF(KJ13,1));
KJ15:=IF(K1!=0,K1,REF(KJ14,1));
K2:=IF(K1!=0,K1,REF(KJ15,1));
警报:IF(K2>0,JJ_1,JJ_2),COLOR00B4FF;

{-----------------【图解模板】---------------------}
DRAWBAND(空,RGB(0,158,0),多,RGB(180,0,0));
RSV:=(C-LLV(L,3))/(HHV(H,3)-LLV(L,3))*100;
K:=SMA(RSV,2,1); D:=SMA(K,2,1); J:=3*K-2*D;
引力:SMA(J,2,1)-SMA(J,3,1),COLORSTICK;
{画各线}
空头:空,COLOR00FF00;
多头:多,COLORFF59FF;

{近台比}
JT_B1:=(O+L+H+C*3)/6;
WMA:=(5*JT_B1+4*REF(JT_B1,1)+3*REF(JT_B1,2)+2*REF(JT_B1,3)+1*REF(JT_B1,4))/(5+4+3+2+1);
JT_B2:=REVERSE(JT_B1)+2*WMA;
JT_B3:=3*JT_B2-2*SMA(JT_B2,2,1);
JTB4:=IF(BARSLAST(C>JT_B3),JT_B3,DRAWNULL);
JT_B4:=IF(BARSLAST(C>JT_B3),JT_B3,REF(JTB4,1));
JTB5:=IF(BARSLAST(C<=JT_B3),JT_B3,DRAWNULL);
JT_B5:=IF(BARSLAST(C<=JT_B3),JT_B3,REF(JTB5,1));
JT_B6:=IF(C<=JT_B3,JT_B4,JT_B5);
近台比:(C-JT_B6)/JT_B6*100,NODRAW,COLORYELLOW;

王照华老师交易护驾过滤要求:
三条件满足买进
A).近台比值 -- 转为正且向上;
B).多线大于等于空线;
C).(引力线值为正向上) -- 引力柱初见红色;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top