最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 牛象条件选股公式有错误

牛象条件选股公式有错误

来源:网络 点击: 时间:2019-03-31

编写要求:

解答:

?网友求助:

请高手帮忙修改下面这个通达信的公式为条件选股公式
示图在附件里面:
1:请选出附图301里当日出现牛象提示的股票.如附图302.
2:请选出附图303里当日出现买点一的股票。如附图304.
请分开写出二个条件选股公式。

公式源码:

MA20:MA(C,20),COLORWHITE,LINETHICK2;
MA120:MA(C,120),COLORFFCCCC,LINETHICK2;
MA250:MA(C,250),COLORFFCC66,LINETHICK2;
乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;
TT1:=CROSS(MA20,MA120) AND CROSS(MA20,MA250) AND V>REF(V,1);
TT2:=MA20>REF(MA20,2) AND V>REF(V,1) AND CROSS(C,MA20);
STICKLINE(TT1,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT1,L-0.13,'金叉'),COLORYELLOW;
STICKLINE(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L-0.13,'并线开花'),COLORYELLOW;
STICKLINE(TT2,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT2,L-0.13,'买点1'),COLORYELLOW;
STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),COLOR00FF00;
DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'卖点'),COLOR00FF00;
STICKLINE(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L,L-0.09,4,0),COLORFFCC66;
DRAWTEXT(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L-0.13,'牛象'),COLORFFCC66;
STICKLINE(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L,L-0.09,4,0),COLORFF00FF;
DRAWTEXT(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L-0.13,'买点2'),COLORFF00FF ;
A1:=SUM(AMOUNT,3)/SUM(VOL,3)/100;
A2:=SUM(AMOUNT,8)/SUM(VOL,8)/100;
A3:=SUM(AMOUNT,21)/SUM(VOL,21)/100;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
V1:=C-(A1+MA(C,3))/2;
V2:=C-(A2+MA(C,8))/2;
V3:=C-(A3+MA(C,21))/2;
VA1:=(C+V3-V1+MACD);
VA4:=(C+V2-V1+MACD);
短线:EMA(VA1,6),LINETHICK2,COLORYELLOW;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top