最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 日线.MACD.成交量金叉

日线.MACD.成交量金叉

来源:网络 点击: 时间:2019-03-27

编写要求:

解答:

?网友求助:

向老师和同学请教一个问题,经常碰到一个现象,在做选股公式时,要求同时满足3个条件时出信号,有时,只满足一个或2个条件时也出信号了,(但有时也有同时满足3个条件的)。下面一个案例,烦请大家帮我看看编写错在哪里?
选股要求:1.日线5日线上穿10日线。
2.MACD指标中,DIF线上穿DEA线。
3.成交量指标中5日成交量线上穿10日成交量线。
同时满足以上3个条件时为选股信号。
我是这样编写的;
MA1:=MA(CLOSE,5) ;
MA2:=MA(CLOSE,10);

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;

VOLUME:=VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);

K1:=DRAWICON(CROSS(MA1,MA2),MA1,1);
K2:=DRAWICON(CROSS(DIF,DEA),DIF,1);
K3:=DRAWICON(CROSS(MAVOL1,MAVOL2),MAVOL1,1);
XG:=K1 AND K2 AND K3 ;
选股:CROSS(XG,0.8);
-----------------------------------------------
不知上面的公式错在哪里?真心的渴求得到教诲!以上只是一个例子,平时在写类似的选股指标时经常会遇到这样的问题,请老师、同学指点。谢谢大家了!
?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top