最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把(精确分时)公式改成通达信盘中预警

把(精确分时)公式改成通达信盘中预警

来源:网络 点击: 时间:2019-02-10

编写要求:

解答:

?网友求助:

原码;要求把黄线上穿绿线行成金叉时发出预警信号(出13号图标)谢了.
BG:=IF(DATE<=1150530,1,0);
GH:=BETWEEN((DCLOSE*BG)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*BG)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BG)))),1.05,0.95);
VB:=IF(GH=0,MA((DCLOSE*BG),BARSCOUNT((DCLOSE*BG))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*BG)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BG)))));
强弱分水岭:1,COLORBLUE,LINETHICK2;
黄快趋势线:EXPMA((DCLOSE/VB),21),COLORYELLOW,,LINETHICK1;
绿慢趋势线:EXPMA((DCLOSE/VB),54),COLORGREEN,LINETHICK1;
DRAWICON(CROSS(黄快趋势线,强弱分水岭),黄快趋势线,1);
DRAWICON(CROSS(绿慢趋势线,强弱分水岭) AND (黄快趋势线>强弱分水岭),强弱分水岭-0.002,15);
DRAWTEXT(CROSS(EXPMA((DCLOSE/VB),20),1),黄快趋势线-0.0025,'涨'),COLORRED;

DRAWICON(CROSS(黄快趋势线,绿慢趋势线),绿慢趋势线,13);
STICKLINE(黄快趋势线>强弱分水岭 AND 黄快趋势线>REF(黄快趋势线,1) AND 黄快趋势线>绿慢趋势线,黄快趋势线,黄快趋势线+0.0015,1,0),COLORMAGENTA;
DRAWTEXT(CROSS(强弱分水岭,黄快趋势线),强弱分水岭,'注意'),COLORWHITE;
DRAWICON(CROSS(绿慢趋势线,黄快趋势线),绿慢趋势线,2);
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:= EMA(V11,3);
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
BB:= (趋势线<=13 AND V12>13) AND FILTER((趋势线<=13 AND V12>13),10);
CCC:=(趋势线>=90 AND V12) AND FILTER((趋势线>=90 AND V12),10);
见顶清仓:= STICKLINE(趋势线>=90 AND V12,强弱分水岭,黄快趋势线,2,0),COLORCYAN;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top