最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把“趋势顶底”公式改成通达信的

把“趋势顶底”公式改成通达信的

来源:网络 点击: 时间:2019-05-21

编写要求:

解答:

?网友求助:

老师:请把这个公式改成通达信用的!
趋势顶底
S1:80,COLOR996699,PRECIS0;
B1:20,COLORGREEN,PRECIS0;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK1;
长期线:A+100,COLOR9900FF,COLORRED,LINETHICK1;
短期线:B+100,COLOR888888,LINETHICK1;
中期线:D+100,COLORYELLOW,LINETHICK1;
见顶:(REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线),PRECIS0;
顶部区域:(中期线80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5 AND 短期线<中期线 AND 短期线<长期线+4,PRECIS0;
顶部:=FILTER(顶部区域,4);
底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1))) OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1),PRECIS0;
STICKLINE(顶部,98,103,20,1),COLORRED;
STICKLINE(底部区域,-4,0,22,0),COLORGREEN;
STICKLINE(底部区域,40,44,22,0),COLORGREEN;
低位金叉:长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线 AND (REF(短期线,1)<5 OR REF(短期线,2)<5) AND (中期线>=长期线 OR REF(短期线,1)<1),PRECIS0;
PARTLINE(中期线>REF(中期线,1),中期线),COLORMAGENTA,LINETHICK1;
PARTLINE(长期线<=REF(长期线,1),长期线),COLORFFFF00,COLORGREEN,LINETHICK1;
STICKLINE(低位金叉,0,4,11,0 ),COLORRED;
S0:10,COLORCC6633,LINETHICK2,PRECIS0;
B0:90,COLOR9966BB,LINETHICK2,PRECIS0;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top