最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把我的MACD选股公式给优化一下

把我的MACD选股公式给优化一下

来源:网络 点击: 时间:2019-05-10

编写要求:

解答:

?网友求助:

老师 我说一下要求啊 多空对比首先是 长线 中期线 中短期线 短线 都是100(必须都是100) 还有量力而为 是DX1一下上穿DX2 DX3 穿一条线的不算(必须是一次上穿两条线) 这四个公式是同时发生的 不要延时的 也就是同时符合这四个条件才出票 在此谢谢休闲人2010老师 给我改此公式(但是不理想 ) 因为我快没有理想币了只有重新发帖了 谢谢老师们了


这是 选股公式
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=MA(RSV,3);
D:=MA(K,3);
xg1:=cross(k,d);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
XG2:=MACD>REF(MACD,1) AND REF(MACD,1)0;
短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
中长期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A1:=H-L;
B1:=C-O;
C1:=(B1/A1);
DX:=V*C1/10000;
DX1:=EMA(EMA(DX,20),3);
DX2:=MA(DX1,5);

xg1 and xg2 and 短期>ref(短期,1) and 中期>ref(中期,1) and 中长期>ref(中长期,1) and 长期>ref(长期,1) and cross(dx1,dx2);


这是量力而为公式
A1:=H-L;
B1:=C-O;
C1:=(B1/A1);
DX:=V*C1/10000;
DX1:EMA(EMA(DX,20),3)*20,COLORYELLOW;
DX2:MA(DX1,5),COLORFF00FF;
DX3:MA(DX1,10),COLORCYAN;
STICKLINE(DX>0,0,DX,2,0),COLORRED;
STICKLINE(DX<0,0,DX,2,0),COLORGREEN;


这是多空对比公式

短期:100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLORWHITE;
中期:100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),COLORYELLOW;
中长期:100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),COLORMAGENTA;
长期:100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLORRED,LINETHICK2;
20,POINTDOT;
50,POINTDOT;
80,POINTDOT;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top