最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 写一个选股公式,出现符号即买入

写一个选股公式,出现符号即买入

来源:网络 点击: 时间:2019-03-25

编写要求:

解答:

?网友求助:

B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1) ;
SMA2:=MA(B2,3) ;
停损下限:IF(LLV(MA(B2,7),3) FILLRGN(b2,sma2,b2>sma2,RGB(255,255,0),b2 snakeA:HHV(MA(B2,1),13),Coloryellow;
Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=MA(Var1,7);
Var3:=Var2-MA(Var1,7/2)<0;
Var4:=Var2-MA(Var1,7/2)>0;
Var5:=BARSLAST(Var3);
Var6:=0-BARSLAST(Var4);
Var7:=IF(Var3<=0,Var5,Var6);
STICKLINE(snakea>b2 AND b2>SMA2,snakea,b2,1,1),colorwhite;
STICKLINE(snakea>SMA2 AND b2 Var11:=(CLOSE*2+HIGH+LOW)/4;
Var21:=EMA(Var11,13)-EMA(Var11,34);
Var31:=EMA(Var21,5;
STICKLINE((C>=O),OPEN,LOW,1,0),color0726CA;
STICKLINE((C>=O),CLOSE,HIGH,1,0),color0726CA;
STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C STICKLINE((C>O),CLOSE,OPEN,8,0),color070084;
STICKLINE((C>O),CLOSE,OPEN,10,0),color000000;
STICKLINE((C>O),CLOSE,OPEN,7,0),color0000A3;
STICKLINE((C>O),CLOSE,OPEN,6,0),color0000B7;
STICKLINE((C>O),CLOSE,OPEN,5,0),color0000CD;
STICKLINE((C>O),CLOSE,OPEN,4,0),color0000E9;
STICKLINE((C>O),CLOSE,OPEN,2,0),color0754E9;
STICKLINE((C>O),CLOSE,OPEN,1.5,0),color076EF3;
STICKLINE((C>O),CLOSE,OPEN,1,0),color077BF3;
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2))) ;
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1A:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
STICKLINE(var1a,O,O+(C-O)/3,8,0),color0000ff;
STICKLINE(var1a,O,O+(C-O)/3,7,0),color1029ff;
STICKLINE(var1a,O,O+(C-O)/3,6,0),color1040ff;
STICKLINE(var1a,O,O+(C-O)/3,5,0),color1083ff;
STICKLINE(var1a,O,O+(C-O)/3,4,0),color10abff;
STICKLINE(var1a,O,O+(C-O)/3,3,0),color10d0ff;
STICKLINE(var1a,O,O+(C-O)/3,2,0),color10ffff;
STICKLINE(var1a,O,O+(C-O)/3,1,0),color00ffff;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);

STICKLINE(aa,O,O+(C-O)/3,8,0),color008800;
STICKLINE(aa,O,O+(C-O)/3,7,0),color009900;
STICKLINE(aa,O,O+(C-O)/3,6,0),color00aa00;
STICKLINE(aa,O,O+(C-O)/3,5,0),color00bb00;
STICKLINE(aa,O,O+(C-O)/3,4,0),color00cc00;
STICKLINE(aa,O,O+(C-O)/3,3,0),color00dd00;
STICKLINE(aa,O,O+(C-O)/3,2,0),color00ee00;
STICKLINE(aa,O,O+(C-O)/3,1,0),color00ff00;

a13:=EMA(CLOSE,55);
a14:=MA(CLOSE,75);
a15:=EMA(a14,3);
a16:=EMA(a15,3);
a17:=(HIGH + LOW) / 5;
a18:=(MA(a17,4)) - (MA(a17,34));
a19:=CROSS(a18,0);
a20:=CROSS(0,a18);
a21:=BARSLAST(a19);
a22:=BARSLAST(a20);
a23:=REF(a19,1);
a24:=REF(a20,1);
a25:=BARSLAST(a23);
a26:=BARSLAST(a24);
a27:=IF((a25 < a26),(REF((HHV(HIGH,2)),a25)),(REF((LLV(LOW,2)),a26)));
a28:=(((REF(CLOSE,1)) <= (REF(a27,1))) AND (CLOSE > a27)) AND (a21 < a22);
a29:=(((REF(CLOSE,1)) >= (REF(a27,1))) AND (CLOSE < a27)) AND (a22 < a21);
a30:=a28 AND ((COUNT(a28,a21)) = 1);
a31:=a29 AND ((COUNT(a29,a22)) = 1);
a32:=a30 AND ((REF(BARSLAST(a31),1)) < (REF(BARSLAST(a30),1))) ;
a33:=a31 AND ((REF(BARSLAST(a31),1)) > (REF(BARSLAST(a30),1)));
DRAWTEXT(a32,SMA2*0.99,'←═╬∝'),coloryellow;
ac:=amount/(VOL);
yy:=MA(ac,13);
lll:=(C-yy)/yy*100;
MIDc := MA(CLOSE,22);
UPPERc:= MIDc + 2*STD(C,22);
LOWERc:= MIDc - 2*STD(C,22);
bba:=(C-lowerc)/(upperc-lowerc);
bbc:=FORCAST(bba,3);
LIFENGcyc:=(REF(lll,1)<-15 AND REF(bba,1)<0 AND lll>REF(lll,1)) ;
STICKLINE(lifengcyc>0,C,O,8,0),colorred;
STICKLINE(lifengcyc>0,C,O,7,0),color1029FF;
STICKLINE(lifengcyc>0,C,O,6,0),color1040FF;
STICKLINE(lifengcyc>0,C,O,4,0),color1083FF;
STICKLINE(lifengcyc>0,C,O,2,0),color10ABFF;
STICKLINE(lifengcyc>0,C,O,1.5,0),color10D0FF;
STICKLINE(lifengcyc>0,C,O,1,0),color10FFFF;
DRAWTEXT(LIFENGcyc>0,LOW*0.99,'☆'),colordd00dd

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top