最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把合必涨,逢低买入的红心信号,迫击反转三个指标合成一个选股公

把合必涨,逢低买入的红心信号,迫击反转三个指标合成一个选股公

来源:网络 点击: 时间:2019-05-13

编写要求:

解答:

?网友求助:

请求老师和高手把请求老师把合必涨,逢低买入的红心信号,迫击反转三个指标做成一个选股公式,并可用于30分钟到日线的选股。
指标均来自理想论坛,在这里对原创作者表示最衷心的感谢。

合必涨
Var0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var3:=SMA(Var0,3,1);
Var1:=SMA(Var3,4,1)-10;
Var4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var5:=SMA(Var4,3,1);
Var2:=SMA(Var5,4,1)-90;
STICKLINE(REF(Var1,1) 0, CIRCLEDOT;
STICKLINE(REF(Var1,1)>Var1,Var1,REF(Var1,1),5,0),COLOR00ff00;
STICKLINE(REF(Var2,1)>Var2,Var2,REF(Var2,1),10,0),COLOR0000FF;
STICKLINE(REF(Var2,1) 0,COLOR0000FF;
Var0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var3:=SMA(Var0,3,1);
Var1:=SMA(Var3,4,1)-10;
Var4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var5:=SMA(Var4,3,1);
Var2:=SMA(Var5,4,1)-90;
STICKLINE(REF(Var1,1) 0, CIRCLEDOT;
STICKLINE(REF(Var1,1)>Var1,Var1,REF(Var1,1),5,0),COLOR00ff00;
STICKLINE(REF(Var2,1)>Var2,Var2,REF(Var2,1),10,0),COLOR0000FF;
STICKLINE(REF(Var2,1) 0,COLOR0000FF;

逢低买入的红星信号
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
趋势:3*Q3-2*Q4,COLORWHITE,LINETHICK3;
趋势线:EMA(Q3, 3),COLORRED,LINETHICK3;
DRAWTEXT(CROSS(趋势线, 长趋势) AND REF(长趋势,1)>80, REF(长趋势,3), '顶'),COLORRED,LINETHICK5;
逢低买: DRAWTEXT(REF(CROSS(趋势线,长趋势),82) AND 趋势线>1.3*长趋势,长趋势,'逢低买'),LINETHICK1;
买: DRAWTEXT(REF(CROSS(长趋势,趋势线),1) AND 长趋势>1.3*趋势线,趋势线,'买'),COLORRED,LINETHICK1;
VAR3:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;
DRAWTEXT(顶A=50,45,'快逃'),COLOR00FF00;
金叉: CROSS(长趋势,趋势线);
DRAWTEXT(金叉,趋势线,'★'),COLORRED;
迫击反转
AA1:=filter(low=llv(low,13),8);
AA2:=if(LLV(low,3)=llv(low,13) and close AA3:=ema(AA2,3)*3;
AA4:=sumbars(AA3>0,21);
AA5:=sum(AA3,AA4)/21;
AA6:=ref(AA3,1)=hhv(AA3,3) and ref(AA3,1)>AA5*3 and count(close/ref(close,1)<0.9025,8)=0 and isup and llv(low,3)/hhv(high,18)<0.88;
AA7:=(count("ddx.ddx">0,5)>0 or not("ddx.ddx1"<"ddx.ddx2" and "ddx.ddx2"<"ddx.ddx3")) and count("ddx.ddx">ref("ddx.ddx",1),10)>=4;
反转:filter(AA6 and AA7,5),colorblack;

stickline(close,0,AA3,8,1),coloryellow;
stickline(反转,0,AA3,8,0),colorred;
?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top