最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 给无敌中的抄底和黑马t改通达信预警公式

给无敌中的抄底和黑马t改通达信预警公式

来源:网络 点击: 时间:2019-03-15

编写要求:

解答:

?网友求助:

Q1:=((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100);
Q2:=((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18)))*(100);
Q3:=SMA(Q2,9,1);
Q4:=SMA(Q3,3,1);
WAA:=(3)*(Q3)-(2)*(Q4);
Q5:=(WAA>(1)*(REF(WAA,1)));
Q6:=LLVBARS(LOW,50);
Q7:=SUM(VOL,Q6);
Q8:=HHVBARS(HIGH,50);
Q9:=SUM(VOL,Q8);
Q10:=((CLOSE-REF(OPEN,Q8))/(REF(OPEN,Q8)))*(100);
Q11:=HHV(WAA,5);
WA1:=EMA(Q3,3);
WA2:=EMA(WA1,3);
A3:=EMA(WA2,3);
A4:=EMA(A3,3);
A5:=EMA(A4,3);
A6:=EMA(A5,3);
WA:=EMA(A4,3);
拉:=FILTER((CROSS(WAA,WA1) AND Q5 AND (WA1<20) AND (Q1>9) or (WA1>(1)*(REF(WA1,1))) AND (Q1>4) AND (WA1<60)),5);
N1:=6;
N2:=12;
N3:=26;
MA6:=MA(CLOSE,6);
MA18:=MA(CLOSE,18);
A:=((3)*(CLOSE)+LOW+OPEN+HIGH)/(6);
XX:=((20)*(A)+(19)*(REF(A,1))+(18)*(REF(A,2))+(17)*(REF(A,3))+(16)*(REF(A,4))+(15)*(REF(A,5))+(14)*(REF(A,6))+(13)*(REF(A,7))+(12)*(REF(A,8))+(11)*(REF(A,9))+(10)*(REF(A,10))+(9)*(REF(A,11))+(8)*(REF(A,12))+(7)*(REF(A,13))+(6)*(REF(A,14))+(5)*(REF(A,15))+(4)*(REF(A,16))+(3)*(REF(A,17))+(2)*(REF(A,18))+REF(A,20))/(210);
庄成本:=EMA(XX,13);
MTM:=CLOSE-REF(CLOSE,1);
DX:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
卖卖:=IF((HHV(DX,2)=HHV(DX,7)) AND COUNT((DX>50),2) AND CROSS(MA(DX,2),DX),1,0);
多多:=EMA(CLOSE,3);
空空:=EMA(CLOSE,5);
均衡:=EMA(空空,5);
VARF1:=(COUNT(CROSS(多多,均衡),2)=1);
VARF2:=(COUNT(CROSS(空空,均衡),2)=1);
ZAI:=FILTER(VARF1 AND VARF2,2);
VV2:=REF(CLOSE,1);
VV3:=((SMA(CLOSE-VV2,6,1))/(SMA(ABS(CLOSE-VV2),6,1)))*(100);
VF1:=MA(CLOSE,60)-(MA(CLOSE,5))/(3.2);
VAR4431:=((CLOSE-REF(OPEN,29))/(REF(OPEN,29)))*(100);
VAR4432:=EMA((0.667)*(REF(VAR4431,1))+(0.333)*(VAR4431),5);
VARR1:=((SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)))*(100);
VAR441:=(HIGH+LOW+OPEN+(2)*(CLOSE))/(5);
VAR442:=REF(VAR441,1);
VAR443:=((SMA(MAX(VAR441-VAR442,0),10,1))/(SMA(ABS(VAR441-VAR442),10,1)))*(100);
HY3:=IF((COUNT((VAR443<20),5)>=1) AND (COUNT((VAR441=LLV(VAR441,10)),10)>=1) AND (CLOSE>=(OPEN)*(1.038)) AND (VOL>(MA(VOL,5))*(1.2)),1,0);
SS:=(MA(VOL,5))/(MA(VOL,60));
AA:=MA(SS,5);
BIASS:=((CLOSE-MA(CLOSE,5))/(MA(CLOSE,5)))*(100);
F:=MA(SS,121);
RSV1:=((CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45)))*(100);
K1:=SMA(RSV1,15,1);
D1:=SMA(K1,15,1);
J1:=(3)*(K1)-(2)*(D1);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1)))*(100);
VAR21:=(((CLOSE-MA(CLOSE,6))/(MA(CLOSE,6)))*(100)+((CLOSE-MA(CLOSE,24))/(MA(CLOSE,24)))*(100)+((CLOSE-MA(CLOSE,32))/(MA(CLOSE,32)))*(100))/(3);
持币区域:=VAR21;
持股区域:=IF((VAR21>0),VAR21,0);
短顶:=FILTER((VAR21>9) AND FILTER((VAR21 大顶:=FILTER((VAR21>20) AND FILTER((VAR21 VAR22:=HHV((VAR21>20),10);
危险:=FILTER(VAR22 AND CROSS((REF(HIGH,1)+REF(LOW,1))/(2),MA(CLOSE,20)+(2)*(STD(CLOSE,20))),5);
注意止损:=FILTER(VAR22 AND FILTER((VAR21 短底1:=FILTER((VAR21<(-9)) AND (VAR21>REF(VAR21,1)),5);
VAR11:=(LLV(LOW,5)=LLV(LOW,45)) AND (CLOSE>=(OPEN)*(1.04));
VAR12:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR13:=VAR11 AND VAR12;
VAR16:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR17:=LLV(LOW,13);
VAR18:=HHV(HIGH,13);
VAR19:=EMA(((VAR16-VAR17)/(VAR18-VAR17))*(100),13);
VARA:=EMA((0.667)*(REF(VAR19,1))+(0.333)*(VAR19),2);
多:=VAR19;
空:=EMA((0.382)*(REF(VAR19,2))+(0.618)*(VAR19),12);
A1:=(VOL=HHV(VOL,120));
A2:=((CLOSE)/(OPEN)>1.05);
TJ:=A1 AND A2;
屠龙剑:=VAR13;
底部吸筹指标:=(((CLOSE-MA(CLOSE,40))/(MA(CLOSE,40)))*(100))*(VAR11);
VA1:=IF((YEAR>=2033) AND (MONTH>=1),0,1);
VA2:=(REF(LOW,1))*(VAR11);
VA3:=(((SMA(ABS(LOW-VAR12),3,1))/(SMA(MAX(LOW-VA2,0),3,1)))*(100))*(VA1);
VA4:=(EMA(IF((CLOSE)*(1.3),(VAR13)*(10),(VAR13)/(10)),3))*(VA1);
VA5:=(LLV(LOW,30))*(VA1);
VA6:=(HHV(VA4,30))*(VA1);
VA7:=(IF(MA(CLOSE,58),1,0))*(VA1);
VA8:=(((EMA(IF((LOW<=VA5),(VA4+(VA6)*(2))/(2),0),3))/(618))*(VA7))*(VA1);
VA9:=(IF((VAR18>100),100,VA8))*(VA1);
底吸筹指标:=(((CLOSE-MA(CLOSE,40))/(MA(CLOSE,40)))*(100))*(VAR11);
VAR4:=(LLV(LOW,1)=LLV(LOW,35)) AND (CLOSE>=(OPEN)*(1.04));
VAR5:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR6:=REF(CLOSE,1);
VAR7:=((SMA(MAX(CLOSE-VAR6,0),6,1))/(SMA(ABS(CLOSE-VAR6),6,1)))*(100);
买4:=VAR4;
减仓:=FILTER(CROSS(80,VAR7),5);
AA1:=(AMOUNT)/(VOL);
BB1:=(LOW<(AA1)*(0.9));
CC1:=(((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100)>1.2);
DD1:=(LOW<(MA(CLOSE,5))*(0.921));
EE1:=(VOL<(MA(VOL,5))*(1.5));
FF1:=BB1 AND CC1 AND DD1 AND EE1;
买3:=FILTER(FF1,3) AND (DATE<=99991230);
VAR1:=100-((90)*(HHV(HIGH,20)-CLOSE))/(HHV(HIGH,20)-LLV(LOW,20));
VAR2:=100-((90)*(HHV(HIGH,20)-CLOSE))/(HHV(HIGH,20)-LLV(LOW,20));
VAR3:=100-MA(((100)*(HHV(HIGH,6)-CLOSE))/(HHV(HIGH,6)-LLV(LOW,6)),28);
买入线:=IF((VAR2 卖出线:=IF((VAR1>MA(VAR3,6)) AND (DATE<=99991230),MA(VAR3,6),VAR1);
强弱线:=MA(VAR3,6);
买入:=(买入线>强弱线) AND (REF(买入线,1)=REF(强弱线,1)) AND (DATE<=99991230);
卖出:=(卖出线<强弱线) AND (REF(卖出线,1)=REF(强弱线,1)) AND (DATE<=99991230);
二十天最低跌幅:=(HHV(CLOSE,20))/(LLV(CLOSE,20));
RSV:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=(3)*(K)-(2)*(D);
X:=(LLV(J,2)=LLV(J,8));
买1:=CROSS(J,REF(J+0.01,1)) AND X AND (J<20) AND (二十天最低跌幅>=1.3) AND (DATE<=99991231);
AA10:=MA(CLOSE,8);
BB10:=((ATAN(AA10-REF(AA10,1)))*(3.1416))*(10);
VAR1Q:=(OPEN+LOW+HIGH+CLOSE)/(4);
MAN:=(SMA(HIGH,21,2))*(1.05);
短底2:=EMA(VAR1Q,5);
支撑:=HHV(短底2,60);
超跌位二:=MA(CLOSE,15);
压力二:=(SMA(HIGH,21,2))*(1.035);
长期底部:=LLV(HIGH,30);
上:=(SMA(LOW,5,2))*(0.96);
VAR4M:=((HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36)))*(100);
VAR5M:=SMA(VAR4M,5,1);
VAR6M:=SMA(VAR5M,8,1);
VAR7M:=CROSS(VAR5M,VAR6M) AND (VAR6M<5);
VAR8M:=(CLOSE>LLV(CLOSE,60)+(0.3)*(LLV(CLOSE,60))) AND VAR7M;
VAR9M:=IF((CLOSE>1000),VAR7M,VAR8M);
黑马起步:=VAR9M;
短期底部:=(LLV(HIGH,30))*(0.93);
压力一:=HHV(LOW,20);
阻挡:=(SMA(LOW,21,2))*(0.94);
买2:=FILTER(((CLOSE)/(OPEN)>1.03) AND (超跌位二-REF(超跌位二,1)>0) AND (CLOSE-REF(CLOSE,1)>0) AND (HIGH<压力一) AND (CLOSE<压力一) AND (压力二-REF(压力二,1)>0) AND (CLOSE 波底:=FILTER((IF(CROSS(底部吸筹指标,(-24)),0,30))*(VAR11),3) AND (DATE<=99991231);
短底:=短底1 AND 短底2 AND (DATE<=99991231);
大底:=FILTER((VAR21<(-20)) AND FILTER((VAR21>REF(VAR21,1)),5),5) AND (DATE<=99991231);
黑马:FILTER(TJ AND ((REF(BARSLAST(TJ),1)>80) or (BARSSINCE(TJ)=0)),10) AND (DATE<=99991231),CoLorFF0000;
卖:=(卖出 or 减仓) AND (DATE<=99991231);
逃:=FILTER((HIGH>支撑) AND (CLOSE<支撑) AND ((CLOSE)/(OPEN)>0-1.06) AND (CLOSE 逃命:=(黑马起步>0) AND (DATE<=99991231);
关注:=FILTER(((买2 or 买入) or 拉),3) AND (DATE<=1080531);
选买:FILTER((((买1 or 买4) or 买3) or 屠龙剑),3) AND (DATE<=99991231),CoLor0000FF;
抄底:FILTER((LOW<=上) AND (HIGH>=短期底部) AND (CLOSE>=长期底部) AND ((CLOSE)/(OPEN)>1.03),3) AND (DATE<=99991231),CoLor0000FF;
选卖:=FILTER((减仓 or 卖卖),3) AND (DATE<=99991231);
选底:FILTER(((大底 or 短底) or 波底),3) AND (DATE<=99991231);
选险:=FILTER((危险 or CROSS(82,VARR1)),3) AND (DATE<=99991231);
选逃:=FILTER((((逃命 or 逃) or CROSS(84,RSI)) or 大顶),3) AND (DATE<=99991231);
选超级:FILTER((买1+买4+买3+屠龙剑>=1) AND (COUNT(波底+短底+大底+抄底+黑马,3)>=1) AND (DATE<=99991231),3),CoLor00FFFF;
选黄金:FILTER((买1+买4+买3+屠龙剑>=2) AND (COUNT(波底+短底+大底+黑马,3)>=1) AND 抄底 AND (DATE<=99991231),3),CoLor00FFFF;
选钻石:FILTER((买1+买4+买3+屠龙剑>=3) AND (COUNT(波底+短底+大底+黑马,3)>=1) AND 抄底 AND (DATE<=99991231),3),CoLor00FFFF;
趋势线1:IF((DATE<=999912531),EMA(EMA(EMA(EMA(CLOSE,3),3),3),3),0),Linethick2,CoLor0000FF;
趋势线2:IF((DATE<=99991231),EMA(REF(趋势线1,1),3),0),Linethick2,CoLor00FFFF;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,(9)*(0.5),0),CoLorFF5B00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,(8)*(0.5),0),CoLorFF6C00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,(7)*(0.5),0),CoLorFF7B00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,(6)*(0.5),0),CoLorFF9C00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,(5)*(0.5),0),CoLorFFBE00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,(3.5)*(0.5),0),CoLorFFCC00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,(1.5)*(0.5),0),CoLorFFFF00;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(9)*(0.5),0),CoLor070084;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(8)*(0.5),0),CoLor0000A3;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(7)*(0.5),0),CoLor0000B7;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(6)*(0.5),0),CoLor0000CD;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(5)*(0.5),0),CoLor0000E9;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(3)*(0.5),0),CoLor0754E9;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(1.5)*(0.5),0),CoLor076EF3;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,(1)*(0.5),0),CoLor077BF3;
STICKLINE((CLOSE>OPEN),OPEN,LOW,(1)*(0.5),0),CoLor0726CA;
STICKLINE((CLOSE>OPEN),CLOSE,HIGH,(1)*(0.5),0),CoLor0726CA;
STICKLINE((OPEN>CLOSE),CLOSE,LOW,(1)*(0.5),0),CoLorDE9100;
STICKLINE((OPEN>CLOSE),OPEN,HIGH,(1)*(0.5),0),CoLorDE9100;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,9,0),CoLor070084;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,8,0),CoLor0000A3;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,7,0),CoLor0000B7;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,6,0),CoLor0000CD;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,5,0),CoLor0000E9;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,3,0),CoLor0754E9;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,1.5,0),CoLor076EF3;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,OPEN,1,0),CoLor077BF3;
STICKLINE(((选超级 or 选黄金) or 选钻石),OPEN,LOW,1,0),CoLor0726CA;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,HIGH,1,0),CoLor0726CA;
STICKLINE(((选超级 or 选黄金) or 选钻石),CLOSE,LOW,1,0),CoLorDE9100;
STICKLINE(((选超级 or 选黄金) or 选钻石),OPEN,HIGH,1,0),CoLorDE9100;
DRAWTEXT(选超级,(HIGH)*(1.02),'超级'),CoLor00FFFF;
DRAWTEXT(选超级,(HIGH)*(1.02),'◆'),CoLor00FFFF;
DRAWTEXT(选黄金,(HIGH)*(1.05),'黄金'),CoLor00FFFF;
DRAWTEXT(选黄金,(HIGH)*(1.05),'◆'),CoLor00FFFF;
DRAWTEXT(选钻石,(HIGH)*(1.08),'钻石'),CoLor00FFFF;
DRAWTEXT(选钻石,(HIGH)*(1.08),'◆'),CoLor00FFFF;
DRAWTEXT(抄底,(LOW)*(0.94),'抄底'),CoLor0000FF;
DRAWTEXT(选买,(LOW)*(0.96),'买'),CoLor0000FF;
DRAWTEXT(黑马,(LOW)*(0.93),'黑马'),CoLorFF0000;
DRAWTEXT(选底,(LOW)*(0.99),'底'),CoLor0000FF;
DRAWTEXT(关注,(LOW)*(0.99),'关'),CoLor0000FF;
DRAWTEXT(关注,(LOW)*(0.97),'注'),CoLor0000FF;
DRAWTEXT((选卖 or 卖出 AND 选卖),(HIGH)*(1.01),'卖'),CoLor00FFFF;
DRAWTEXT(选逃,(HIGH)*(1.03),'逃'),CoLor00FFFF;
DRAWTEXT(选险,(HIGH)*(1.05),'险'),CoLor00FFFF;
VAR30:=(DATE>99991231) AND ((DAY=1) or (DAY=16));
位置:=(CLOSE+REF(CLOSE,105))/(2);

请老师给所向无敌中的抄底和黑马改通达信预警公式,谢谢
?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top