最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把夏老师的CS主图公式中的启动和B点做成选股

把夏老师的CS主图公式中的启动和B点做成选股

来源:网络 点击: 时间:2019-03-22

编写要求:

解答:

?网友求助:

源码为:

平均成本:COST(50),PRECIS1,Linethick1;
partline(平均成本,平均成本>=ref(平均成本,1),rgb(250,0,250),平均成本 VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);
VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);
VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);
VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));
JJ:=(3*C+H+L+O)/6;
VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,5);
STICKLINE(C,REF(L,BARSLAST(LJL)),REF(L,BARSLAST(LJL)),6,0),COLORred;
STICKLINE(C,REF(C,BARSLAST(LJL)),REF(C,BARSLAST(LJL)),6,0),COLORyellow;
快:=COUNT(CLOSE>REF(CLOSE,2),4)/4*100;
慢:=COUNT(CLOSE>REF(CLOSE,2),6)/6*100;
JC:=(CROSS(快,1) AND 慢<=40) OR (CROSS(慢,20) AND 快<=50);
进场:=IF(FILTER(JC,10),20,0);
锁仓:(WINNER(CLOSE*1.2)-WINNER(CLOSE*0.8))/WINNER(HHV(HIGH,0))*100,LINETHICK0,Color9DFFFF;
浮筹:100-锁仓,LINETHICK0,Color33FF99;
穿透率:(WINNER(CLOSE)-WINNER(REF(CLOSE,1)))/VOL*(SELFDATA('流通盘')*100),LINETHICK0,ColorFFCC66;
获利:MA(WINNER(1*CLOSE)*100-WINNER(COST(0))*100,1),LINETHICK0,color4444ff;
套牢:100-获利,LINETHICK0,ColorABFF46;
浮动:(锁仓/浮筹),LINETHICK0,Color66CCFF;
集中度70:(COST(86)-COST(14))/(COST(86)+COST(14))*100,colorfaabec,LINETHICK0;
集中度90:(COST(95)-COST(5))/(COST(95)+COST(5))*100,LINETHICK0,ColorCCCCFF;
增减1:=获利;
增减2:=EMA(获利,5);
增减3:=EMA(获利,10);
S1:=LAST(增减1<增减2);
S2:=LAST(增减1>=增减2);
drawtext(S1>0,H*1.02,STR(S1)),colorgreen,LINETHICK1,align1,valign0;
drawtext(S2>0,L*1,STR(S2)),color4444ff,LINETHICK1,align1,valign0;
DLX:=(EMA(CLOSE,17)-REF(EMA(CLOSE,17),1));
DLX1:=SUM(DLX,3);
DLX2:=MA(DLX1,5);
涨幅:=(c-ref(c,1))/ref(c,1)*100>0;
XG:=进场 AND (DLX1-REF(DLX1,1))>0 AND 涨幅;
LX:=DYNAINFO(7)=CLOSE and DYNAINFO(10)=AMOUNT AND TIME0<55800;
内盘:=IF(LX,DYNAINFO(22),SELFDATA('内盘'));
外盘:=IF(LX,DYNAINFO(23),SELFDATA('外盘'));

买单数:=ORDER(1);
卖单数:=ORDER(2);
总买均手:=外盘/买单数;
总卖均手:=内盘/卖单数;
主单买:=bigorder(1,2)*外盘;
主单卖:=bigorder(2,2)*内盘;
主占比:=(主单买-主单卖)/capital*100;
均手差:=(总买均手-总卖均手);
XG1:=主占比>0.5 AND 均手差>5 AND DLX>0;

STICKLINE(LJL>=1.5,C,O,15,0),COLOR004444;
STICKLINE(LJL>=1,C,O,13,0),COLOR004444;
STICKLINE(LJL>=0.5,C,O,11,0),COLOR004444;
STICKLINE(LJL>=0.3,C,O,10,0),COLOR005555;
STICKLINE(LJL>=0.2,C,O,7,0),COLOR005555;
STICKLINE(LJL>=0.2,C,O,6,0),COLOR006666;
STICKLINE(LJL>=0.2,C,O,5,0),COLOR007777;
STICKLINE(LJL>=0.2,C,O,4,0),COLOR009999;
STICKLINE(LJL>=0.2,C,O,3,0),COLOR00bbbb;
STICKLINE(LJL>=0.2,C,O,2,0),COLOR00dddd;
STICKLINE(LJL>=0.2,C,O,1,0),COLOR00ffff;
STICKLINE(LJL>=0.1,C,O,1,0),COLOR00ffff;

DRAWTEXT(XG>0,LOW,'↖启动'),COLOR00FFFF;

不胜感激!!!
?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top