最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 做个在出底买入时的选股预警

做个在出底买入时的选股预警

来源:网络 点击: 时间:2019-03-31

编写要求:

解答:

?网友求助:

源码:
a1:=((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100;
a2:=SMA(a1,9,1);
a3:=SMA(a2,5,1);
a4:=SMA(a3,3,1);
a5:=(3 * a3) - (2 * a4);
a6:=(((MA(CLOSE,68)) - ((MA(CLOSE,68)) / 3)));
a7:=((CLOSE / a6) - 1) * 100;
a8:=BETWEEN(a7,1,-10);
a9:=IF((a8 > 1),5,88);
a10:=(MA(WINNER(CLOSE),9)) * 100;
a11:=(CROSS(a2,2.5)) * 85;
出击:IF((a11 > 0),100,0),linethick3, colorred;
DRAWTEXT((出击 > 0),80,'出击'),colorred;
a12:=IF(((a11 > 0) OR (出击 > 0)),2,20);
a13:=(2);
a6:=(((3 * (SMA(a1,5,1))) - (2 * (SMA((SMA(a1,5,1)),3,1)))));
a14:=((REF(((((LOW + OPEN) + CLOSE) + HIGH) / 4),1)));
a15:=(SMA(ABS((LOW - a14)),13,1)) / (SMA((MAX((LOW - a14),0)),10,1));
a16:=EMA(a15,10);
a19:=((((HHV(HIGH,9)) - CLOSE) / ((HHV(HIGH,9)) - (LLV(LOW,9)))) * 100) - 70;
a20:=(SMA(a19,9,1)) + 100;
a21:=((CLOSE - (LLV(LOW,9))) / ((HHV(HIGH,9)) - (LLV(LOW,9)))) * 100;
a22:=SMA(a21,3,1);
a23:=(SMA(a22,3,1)) + 100;
a24:=a23 - a20;
a25:=(IF((a24 > 100),(a24 - 100),0)) * 1.2;
a26:=MA(a25,2);
a27:=((CLOSE - (REF(CLOSE,1))) / (REF(CLOSE,1))) * 100;
a28:=((EMA(CLOSE,12)) - (EMA(CLOSE,26))) * 100;
a29:=EMA(a28,9);
a30:=2 * (a28 - a29);
DRAWTEXT((((a28 < -50) AND (a27 > 7)) AND (a28 < a29)),28,'底'),linethick2,colorred;
DRAWTEXT((((a28 < -50) AND (a27 > 7)) AND (a28 >= a29)),5,'追'),linethick2,colorwhite;
STICKLINE(((a28 < -50) AND (a27 > 7)),0,10,3,0),ColorFFFF66;
a14:=((ZIG(3,34)));
进入:(((REF(a14,2)) > (REF(a14,1))) AND (a14 > (REF(a14,1)))) * 80;
出货:(((REF(a14,2)) < (REF(a14,1))) AND (a14 < (REF(a14,1)))) * 108,linethick1,Color2F4F2F;
DRAWTEXT((出货 > 28),88,'顶'),linethick1, Color238E68;
DRAWTEXT((进入 > 28),39,'底'),linethick1,coloryellow;
a31:=((HIGH + LOW) + (3 * CLOSE)) / 5;
a32:=EMA(a31,5);
a33:=EMA(a31,21);
a34:=MA(CLOSE,60);
a35:=(COUNT((CLOSE < a34),33)) > 31;
a36:=CROSS(CLOSE,a34);
a37:=(CLOSE / (REF(CLOSE,1))) > 1.045;
a38:=IF((((((CLOSE / (REF(CLOSE,1))) - 1) * 100) >= 5) AND (CLOSE > (OPEN * 1.04))),20,0);
a39:=BARSLAST(a38);
a40:=IF((((a39 <= 13) AND (LOW < (REF(OPEN,a39)))) AND ((CLOSE / (REF(CLOSE,1))) <= 0.98)),10,0);
a41:=(((COUNT((CLOSE < (REF(CLOSE,1))),4)) >= 3) OR ((COUNT((CLOSE < (REF(CLOSE,1))),5)) >= 4)) OR ((COUNT((CLOSE < (REF(CLOSE,1))),6)) >= 5);
a42:=(((((HHV(HIGH,5)) / LOW) - 1) * 100) > 18) OR (((((HHV(HIGH,7)) / LOW) - 1) * 100) > 18);
超跌:IF((((a41 AND (a26 < 0.3)) AND a42) AND (CLOSE <= (REF(CLOSE,1)))),50,0),linethick2,colorwhite;
a43:=(100 * ((HHV(HIGH,5)) - CLOSE)) / ((HHV(HIGH,5)) - (LLV(LOW,5)));
a44:=(100 * ((HHV(HIGH,6)) - CLOSE)) / ((HHV(HIGH,6)) - (LLV(LOW,6)));
a45:=80 - (((a43 * 3) + (a44 * 2)) / 5);
低吸:IF((((超跌 OR a40) AND (a26 < 0.3)) AND (a45 < -18)),65,0),linethick2,ColorFFFF99;
a47:=REF(CLOSE,2);
a48:=((SMA((MAX((CLOSE - a47),0)),7,1)) / (SMA(ABS((CLOSE - a47)),7,1))) * 100;
超卖1:IF((a48 < 12),25,0),linethick3,colorred;
a49:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),7,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),7,1))) * 100;
超卖2:IF((a49 < 12),30,0),linethick3,colorblue;
派发:STICKLINE((a48 > 90),(a48 + 1),(a48 - 1),38,0),ColorBC8F8F;
闪:IF(((a48 < (REF(a48,1))) AND (a48 > 88)),a48,0),Color2F4F2F;
DRAWTEXT((闪 > 88),68,'闪'), Color238E68;
a50:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),5,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),5,1))) * 100;
a51:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),10,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),10,1))) * 100;
a52:=a50 AND (a50 > a51);
a53:=LLV(LOW,10);
a54:=HHV(HIGH,25);
a55:=EMA((((CLOSE - a53) / (a54 - a53)) * 4),4);
{DRAWTEXT((CROSS(a55,0.3)),25,'买'),ColorFFFFCC;}
DRAWTEXT((CROSS(3.6,a55)),95,'卖'), Color238E68;
a56:=(MA(HIGH,30)) * (1 + (22 / 100));
a57:=(MA(LOW,30)) * (1 - (22 / 100));
a58:=CLOSE < (REF(CLOSE,3));
a59:=COUNT((a58 = 1),30);
STICKLINE((a59 > 25),38,20,3,1),coloryellow;
a60:=CLOSE > (REF(CLOSE,3));
a61:=COUNT((a60 = 1),30);
STICKLINE((a61 > 22),38,20,3,1),colorgreen;
a62:=((CLOSE - (LLV(LOW,36))) / ((HHV(HIGH,36)) - (LLV(LOW,36)))) * 100;
a63:=SMA(a62,3,1);
a64:=SMA(a63,3,1);
a65:=SMA(a64,3,1);
波:(a64),colorred;
段:(a65),colorgreen;
a66:=(CROSS(a64,a65)) AND (a64 < 12);
DRAWTEXT(((FILTER(a66,10)) = 1),20,'#'),linethick4,coloryellow;
STICKLINE(((FILTER(a66,10)) = 1),0,50,2,0),coloryellow;
a67:=(CROSS(a65,a64)) AND (a64 > 90);
STICKLINE(((FILTER(a67,5)) = 1),100,60,2,0),coloryellow;
DRAWTEXT(((FILTER(a67,5)) = 1),78,'顶'),linethick3, Color2F4F2F;
a68:=((CROSS(a63,a64)) AND (a64 > 82)) AND (a64 > a65);
STICKLINE(a68,100,68,3,0),ColorF00FF0;
a69:=((CLOSE - (LLV(CLOSE,124))) / ((HHV(CLOSE,124)) - (LLV(CLOSE,124)))) * 100;
a70:=a69 = 0;
a71:=IF(((CLOSE / COST(5)) < 0.7),1,0);
a72:=LLV(HIGH,240);
a73:=(100 * (CLOSE - a72)) / a72;
a74:=a73 < 0;
a75:=IF(((CLOSE / COST(26)) < 0.7),1,0);
a76:=((a71 OR a75) AND a70) AND a74;
a77:=((CLOSE - (MA(CLOSE,13))) / (MA(CLOSE,13))) * -100;
a78:=((CLOSE - (LLV(LOW,13))) / ((HHV(HIGH,13)) - (LLV(LOW,13)))) * 100;
a79:=SMA(a78,3,2);
a80:=SMA(a79,3,2);
a81:=SMA(a80,5,1);
a82:=IF(((CLOSE / COST(10)) < 0.65),1,0);
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top