最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 快乐手4月29号发表的帖子中的选股公式

快乐手4月29号发表的帖子中的选股公式

来源:网络 点击: 时间:2018-08-22

编写要求:

解答:

?网友求助:

1.主图公式={上轨与下轨渐收口:股价在上升通道中、成交量缩量盘整}。

2.自编附图选股公式1={上轨与下轨的价格比例:强势=上轨大于下轨1.04%,中势=上轨大于下轨1.07.(上轨大于下轨的比例可自行喜欢调整)}。

3.自编附图选股公式2={当日价格大于中轨,中轨上升角度大于13度(角度可行喜欢调整)}。

公式:

1.主图源码

BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK2;
UPR:BBI+P*STD(BBI,N);
DWN:BBI-P*STD(BBI,N);
EMA5:EMA(CLOSE,5);
W:=BARSLAST(DISPSTATUS=1);
天:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXTREL(10,150,'■目前可见K线:'+NUMTOSTRN(W+1,0)+'天'),colorwhite;
低涨:(C/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;DRAWTEXTREL(10,100,'■低点至今上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天,0)+'天'),COLOR0000FF;
DRAWTEXTREL(10,200,'■建议查阅K线:短线30天,中长线120天!'),COLORFF8899;
BEGIN DRAWTEXTREL(10,50,'所属板块:'+BKNAME),LINETHICK1,color00FFFF;end;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);

STICKLINE(ZT,REF(O,BH),REF(C,BH),7,0),COLORYELLOW;
TY:=C;
A1:=REF(TY,5)=HHV(TY,2*5+1); B1:=FILTER(A1,5); C1:=BACKSET(B1,5+1); HD:=FILTER(C1,5);
A2:=REF(TY,5)=LLV(TY,2*5+1); B2:=FILTER(A2,4); C2:=BACKSET(B2,4+1); LD:=FILTER(C2,5);
压力线:REF(C,BARSLAST(HD)),COLORRED{红色},POINTDOT;
STICKLINE(C,压力线,压力线,8,2),COLORMAGENTA{红色},linethick1;

参数设置:N,10\1\100\1; P,3\0.1\20\1

2. 选股公式源码1
力:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORRED,linethick0;
角度力:=atan((力/ref(力,1)-1)*100)*180/3.1416;
选股:if(角度力>13 AND ma(c,30)>ref(ma(c,30),1),
1,0),colorMAGENTA;
角度周期:IF(选股,BARSLAST(CROSS(选股,0.1))+1,0),COLORFF00FF,POINTDOT,LINETHICK0;
现价:c>ma(c,力),COLORYELLOW;
价周期:IF(现价,BARSLAST(CROSS(现价,1))+1,0),COLORYELLOW,POINTDOT,LINETHICK0;

3. 选股公式源码2:参数设置同主图

BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK0;
UPR:BBI+P*STD(BBI,N),LINETHICK0;
DWN:BBI-P*STD(BBI,N),LINETHICK0;
选股1:UPR 选股2:UPR 第一个选股公式和第2个选股公式都显示“条件选股只能有一条输出语句”的提示。不知道是什么原因,请老师帮帮忙看怎么改才能通过
?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top