最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把dmi弄成一个选股指标

把dmi弄成一个选股指标

来源:网络 点击: 时间:2019-05-19

编写要求:

解答:

?网友求助:

飘带变红为买点
INPUT:N(21),M(6),M1(20);
TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N);
DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N);
PDI:= DMP*100/TR1;
MDI:= DMM*100/TR1;
ADX: EMA((PDI-MDI)/(MDI+PDI)*100,M)*2,LINETHICK1,COLOR000099;
ADXR:EMA(ADX,M),LINETHICK0,Color008000;
ADMA:EMA(ADX,M1),LINETHICK1,COLORCCCCCC,LAYER0;
OMD:(ADX-2*ADMA+ADXR)/2,LINETHICK0;
PARTLINE(110,1),ColorA6A600,LAYER0;
PARTLINE(0,1),Color008080,LAYER0;
PARTLINE(-110,1),ColorA6A600,LAYER0;
FILLRGN(ADX,ADXR,ADX>=ADXR),Color000044;
FILLRGN(ADX,ADXR,ADX STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,4,0),COLOR4444FF;
STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,4,0),COLORFF33FF;
STICKLINE(OMD PARTLINE(ADX,ADX>=ADXR),COLOR0000CC,LINETHICK1;
PARTLINE(ADX,ADX标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top