最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 同舟共舞改成飞狐的公式

同舟共舞改成飞狐的公式

来源:网络 点击: 时间:2019-02-11

编写要求:

解答:

?网友求助:

这是一个唐仁政老师的公式,麻烦老师改成飞狐的!!

同舟共舞

DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
MACD :=1000* (2*(DIFF-DEA))/EMA(C,30);
VARA:=EMA(REF(CLOSE,1),4);
色彩峰:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);
准备:=色彩峰<3.5,COLORDBDBDB;
出航:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND 色彩峰<20,5), COLORBROWN;
飞燕:=CROSS(色彩峰,90),COLOR00FF00;
回归:=CROSS(色彩峰,90),COLORDBDBDB;
STICKLINE(色彩峰,0,130,10,0),COLORFFFF20;
STICKLINE(色彩峰,0,120,10,0),COLORFFFF00;
STICKLINE(色彩峰,0,90,10,0),COLORFFEE00;
STICKLINE(色彩峰,0,75,10,0),COLORFFD600;
STICKLINE(色彩峰,0,60,10,0),COLORFFB500;
STICKLINE(色彩峰,0,50,10,0),COLORFFB300;
STICKLINE(色彩峰,0,40,10,0),COLORFFB200;
STICKLINE(色彩峰,0,35,10,0),COLORFFB200;
STICKLINE(色彩峰,0,25,10,0),COLORFFAF00;
STICKLINE(色彩峰,0,15,10,0),COLORFF9500;
STICKLINE(色彩峰,0,-50,10,0),COLOR8BA424;
STICKLINE(色彩峰,0,-30,10,0),COLOR8BA42B;
STICKLINE(色彩峰,0,-10,10,0),COLOR8BA455;
STICKLINE(色彩峰,0,-5,10,0),COLOR8BA466;
STICKLINE(色彩峰>0,0,色彩峰,10,0),COLOR66FF00;
STICKLINE(色彩峰>0,0,色彩峰*0.9,10,0),COLOR66EE00;
STICKLINE(色彩峰>0,0,色彩峰*0.8,10,0),COLOR66CC00;
STICKLINE(色彩峰>0,0,色彩峰*0.7,10,0),COLOR66AA00;
STICKLINE(色彩峰>0,0,色彩峰*0.6,10,0),COLOR669900;
STICKLINE(色彩峰>0,0,色彩峰*0.5,10,0),COLOR668800;
STICKLINE(色彩峰>0,0,色彩峰*0.4,10,0),COLOR667700;
STICKLINE(色彩峰>0,0,色彩峰*0.3,10,0),COLOR666600;
STICKLINE(色彩峰,0,-色彩峰*0.2,10,0),COLOR324D00;

RSV:= (CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
FASTK:=SMA(RSV,3,1);
龙K:=SMA(FASTK,2,1);
龙D:=SMA(龙K,5,1);
狗:=LLV(LOW,10);
年:=HHV(H,25);
到来:=EMA((C-狗)/(年-狗)*4,4);
恭喜:STICKLINE(CROSS(到来,0.3),-50,-30,3,0), COLOR00AAFF,LINETHICK1;
STICKLINE(CROSS(到来,0.3),-40,-30,3,0),COLORRED,LINETHICK1;
发财:STICKLINE(CROSS(3.5,到来),100,120,2,0), COLORRED,LINETHICK2;
STICKLINE(CROSS(3.5,到来),110,120,2,0),COLORYELLOW,LINETHICK2;

DD:=IF(MACD>=0,MACD,DRAWNULL);
LL:=IF(MACD<0,-MACD,DRAWNULL);
STICKLINE(DD,0,DD,3.8,0),COLOREAEAEA;
STICKLINE(DD ANDDD>REF(DD,1),DD*0.1,DD*0.9,2.5.0,0),COLOR0080FF;
STICKLINE(DD AND DD>=15 ANDDD>REF(DD,1),DD*0.7,DD*0.7,2.5,1),COLOR00FFFF;
STICKLINE(DD AND DD>=15 ANDDD>REF(DD,1),DD*0.5,DD*0.5,2.5,1),COLOR00FFFF;
STICKLINE(DD AND DD>=15 ANDDD>REF(DD,1),DD*0.3,DD*0.3,2.5,1),COLOR00FFFF;
STICKLINE(DD AND DD STICKLINE(DD AND DD>=15 ANDDD STICKLINE(DD AND DD>=15 ANDDD STICKLINE(DD AND DD>=15 ANDDD

STICKLINE(LL AND LL STICKLINE(龙K>=龙D,龙D,龙K,3,0),COLOR40FFFF;
STICKLINE(龙K<龙D,龙D,龙K,3,0),COLOR00FF00;
DRAWTEXT(准备,-10,'加'),COLORDBDBDB;
DRAWTEXT(准备,-10,'九'),COLOR688EC1;


红:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1);
IF(CROSS(红,2),70,-50),COLOR0000FF;
开花:IF(CROSS(红,2),70,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;
进:IF(CROSS(红,2),70,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
L1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*200-60;
K:SMA(L1,3,1),LINETHICK1,COLOR0000FF;
D:SMA(K,3,1),LINETHICK1,,COLORFF3252;
{DRAWTEXT(CROSS(3.5,到来),100,'S');}
DRAWTEXT(CROSS(D,K)AND K>78,100,'S')
?

标签:

    上一篇:改指标 下一篇:把选股公式改成附图指标

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top