最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将精彩的主图指标改成大智慧的

将精彩的主图指标改成大智慧的

来源:网络 点击: 时间:2019-03-19

编写要求:

解答:

?网友求助:

源码:买:EMA(CLOSE,5),COLORRED,LINETHICK2;A:=(REF(买,1));
卖:EMA(SLOPE(CLOSE,21)*20+CLOSE,42),LINETHICK2;
B:=CROSS(买,卖);
S:=CROSS(卖,买);
DRAWTEXT(B,LOW-0.1,'←买 '),COLORRED,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;G:=95;
DRAWTEXT(CROSS(J,D),L*0.999,'←加仓'),COLOR00FFFF,LINETHICK2;
VAR29:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR2A:=SMA(VAR29,5,1);
VAR2B:=SMA(VAR2A,10,1);
VAR2C:=CROSS(VAR2B,VAR2A);
VAR2D:=VAR2B>80 OR VAR2A>80;
VAR2E:=VAR2C AND VAR2D;
VAR33:=HIGH;
VAR34:=LOW;
逃顶:=STICKLINE(VAR2E,VAR33,VAR34,4,0);
DRAWTEXT(CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),HIGH*1.03,'-落袋为安'),COLORYELLOW;
X6:=REF(CLOSE,1);
X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);DRAWTEXT(X9,HIGH*1.02,'←出货'),COLOR9000F5;


FF:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,FF);
上:(1+7/100)*DD,DOTLINE,COLORMAGENTA;
下:(1-7/100)*DD,DOTLINE,COLORMAGENTA;
中:(上+下)/2,DOTLINE,COLORMAGENTA;


M10:=EMA(C,10);
融:=M10,COLORRED,LINETHICK2;
高:(1+14/100)*DD,DOTLINE,COLORGRAY;
低:(1-14/100)*DD,DOTLINE,COLORGRAY;


RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
中1:SMA(RSV1,5,1),NODRAW,COLORMAGENTA;
CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
短: (EMA(CS,3)-50)*2,NODRAW,COLORLIGRAY;


集中度:=(COST(85)-COST(15))/(COST(85)+COST(15))/2;
平均成本:((COST(85)+COST(15))/2+COST(50))/2,COLORWHITE,LINETHICK2;
IF(集中度<0.06,平均成本,DRAWNULL),COLORFFC0FF,LINETHICK2;


VAR2:=CLOSE*VOL;
VAR3:=EMA(VAR2,3);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top