=0 AND ZJ>=REF(ZJ,1); EE:= ZJ>85; FF:=ZJ 0; STICKLINE" />
最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 把谦虚老师的主图改为大智慧2

把谦虚老师的主图改为大智慧2

来源:网络 点击: 时间:2019-03-17

编写要求:

解答:

?网友求助:

请高手将谦虚老师的《五彩周J主图 》改为大智慧2的指标,谢谢了.不好意思忘了上源码了。
源码:
ZJ:=MA("KDJ.J#WEEK"(9,3,3) ,5);
AAA:=ZJ<0 AND ZJ BB:=ZJ<0 AND ZJ>=REF(ZJ,1);
DD:=ZJ>=0 AND ZJ>=REF(ZJ,1);
EE:= ZJ>85;
FF:=ZJ0;
STICKLINE(AAA,C,O,3,0),COLOR2737FF;
STICKLINE(AAA,H,L,0,0),COLOR2737FF;
STICKLINE(AAA,C,O,1.9,0),COLOR226CFF;
STICKLINE(AAA,C,O,1.0,0),COLOR3EA6FF;
STICKLINE(AAA,C,O,0.2,0),COLOR17FFF6;
STICKLINE(BB,C,O,3,0),COLOR990099;
STICKLINE(BB,H,L,0,0),COLORFF00FF;
STICKLINE(BB,C,O,1.9,0),COLORBB00CC;
STICKLINE(BB,C,O,1.0,0),COLORDD00DD;
STICKLINE(BB,C,O,0.2,0),COLORFF88FF;
STICKLINE(DD,C,O,3,0),COLOR000099;
STICKLINE(DD,H,L,0,0),COLOR0000FF;
STICKLINE(DD,C,O,1.9,0),COLOR0000CC;
STICKLINE(DD,C,O,1.0,0),COLOR0000DD;
STICKLINE(DD,C,O,0.2,0),COLOR7788FF;
STICKLINE(EE,C,O,3,0),COLOR00AAAA;
STICKLINE(EE,H,L,0,0),COLOR00FFFF;
STICKLINE(EE,C,O,1.9,0),COLOR00CCCC;
STICKLINE(EE,C,O,1.0,0),COLOR00DDDD;
STICKLINE(EE,C,O,0.2,0),COLOR00FFFF;
STICKLINE(FF,C,O,3,0),COLOR888800;
STICKLINE(FF,H,L,0,0),COLORFFFF00;
STICKLINE(FF,C,O,1.9,0),COLORCCCC00;
STICKLINE(FF,C,O,1.0,0),COLORDDDD00;
STICKLINE(FF,C,O,0.2,0),COLORFFFF00;
YK:=MA("KDJ.K#MONTH"(9,3,3),20),LINETHICK0;
YD:=MA("KDJ.D#MONTH"(9,3,3),20),LINETHICK0;
YJ:=MA("KDJ.J#MONTH"(9,3,3),20);
ZK:=MA("KDJ.K#WEEK"(9,3,3) ,5),LINETHICK0;
ZD:=MA("KDJ.D#WEEK"(9,3,3) ,5),LINETHICK0;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),LINETHICK0;
D:=SMA(K,3,1),LINETHICK0;
J:=3*K-2*D,LINETHICK0;
RJC:DRAWICON(CROSS(K,D),L*0.98,1);
DRAWTEXT(RJC,L*0.98,'日金叉'),COLOR0000FF;
RSC:DRAWICON(CROSS(D,K),H*1.03,2),;
DRAWTEXT(RSC,H*1.03,'日死叉'),COLORFFFFFF;
ZJC: DRAWICON (CROSS(ZK,ZD), L*0.98,1);
DRAWTEXT(ZJC,L*0.98,'周金叉'),COLORFF00FF;
ZSC: DRAWICON (CROSS(ZD,ZK), H*1.03,2),;
DRAWTEXT(ZSC,H*1.03,'周死叉'),COLOR00FFFF;
YJC: DRAWICON (CROSS(YK,YD), L*0.98,1);
DRAWTEXT(YJC,L*0.98,'月金叉'),COLORFF0000;
YSC: DRAWICON (CROSS(YD,YK), H*1.03,2);
DRAWTEXT(YSC,H*1.03,'月死叉'),COLORADEAEA;
MA10:MA(C,10),COLORRED,LINETHICK1;
IF(MA10 MA20:MA(C,20),COLORFF00FF,LINETHICK1;
IF(MA20 MA55:MA(C,55),COLORFF0000,LINETHICK1;
IF(MA55 TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
最高2:=CONST(HHV(H,NN));
最低2:=CONST(LLV(L,NN));
PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;
RCC1:=最高2*0.9-(最高2-最低2)*PP;
最低3:=MIN(RCC1,最低2);
AA:=最低3;
STICKLINE(AAA,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR3EA6FF;
STICKLINE(BB,AA-0.000*AA,AA-0.040*AA,2.5,0),COLORFF00FF;
STICKLINE(DD,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR0000FF;
STICKLINE(EE,AA-0.000*AA,AA-0.040*AA,2.5,1),COLOR00FFFF;
STICKLINE(FF,AA-0.000*AA,AA-0.040*AA,2.5,1),COLORFFFF00;
DRAWTEXT_FIX(1,0.2,0.86,0,'★★ 橘红色--周J<0--底部警示★★粉色--周J拐头--买入★★红色--周J向上--加仓★★黄色--周J>85--风险提示★★青色--周J下跌--持币★★'),COLOR00FFFF;
?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top