最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将买入无忧中“要涨停”和“极度恐慌”分别做选股

将买入无忧中“要涨停”和“极度恐慌”分别做选股

来源:网络 点击: 时间:2019-02-24

编写要求:

解答:

?网友求助:

指标如下:
{大智慧2}
R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))))*((DATE < 20070110));
VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100)*((DATE < 20070110));
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 20070110));
满仓:=((线 > REF(线,1)) and (线 < 25) and (COUNT((线 > REF(线,1)),5) = 1) and IF((N = 6),(获利盘 < 60),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0));
DRAWTEXT(满仓,LOW*0.98,'满仓'),ColorRED;
轻仓:=IF((获利盘 >= 60) and (线 > REF(线,1)) and (REF(线,1) < 20) and (线 < 40) and (COUNT((线 > REF(线,1)),5) = 1) and (REF(N,1) = 6),1,0);
DRAWTEXT(轻仓,LOW*0.98,'轻仓'),ColorYELLOW;
出击:=CROSS(线,20) and IF((COUNT(CROSS(K,D),3) = 1) and (D < 40),1,(线 > D) or (K > D) and (D < 60)) and IF((N = 6),(获利盘 < 70),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0);
DRAWTEXT(出击,LOW*0.98,'出击'),colorMAGENTA;
进一:=CROSS(线,D) and (D > 30) and (D > REF(D,1)) and (D < 80);
进二:=CROSS(线,获利线) and (D > 30) and (获利线 > 25) and (D > REF(D,1));
低进:=IF(进一 and (D > 获利线),进二,进一);
DRAWTEXT(低进,LOW*0.98,'低进'),ColorRED;
DRAWTEXT(进二,LOW*0.99,'高进'),ColorGRAY;
狂喜:=(CROSS(VAR1,(-2)));
DRAWTEXT(狂喜,(LOW*0.98),'要涨停'),coloryellow;
狂喜过望:=((VAR1 = 0));
恐慌:=(VAR1 < -94);
DRAWTEXT(恐慌,(LOW*0.98),'恐慌'),ColorGREEN;
极度恐慌:=(-40)*(VAR1 = (-100));
DRAWTEXT(极度恐慌,(LOW*0.95),'极度恐慌'),ColorWHITE;
半仓:=(CROSS(VAR1,(-94)) and (COUNT(恐慌,5) > 0) and (N = REF(N,1)) and IF((N = 6),(获利盘 < 60),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0));
DRAWTEXT(半仓,LOW*0.95,'半仓'),ColorWHITE;
加仓:=(CROSS(K,20) and (COUNT(半仓,5) > 0));
DRAWTEXT(加仓,LOW*0.98,'加仓'),ColorRED;
背离:=(COUNT(恐慌,2) > 0) and (CLOSE < REF(CLOSE,1)) and (VAR1 > REF(VAR1,1));
DRAWICON(背离,HIGH*1.02,1),ColorGRAY;
DD:=FINANCE2(35);
SS:=FINANCE2(37);
FF:=FINANCE2(7);
GG:=FINANCE2(3);
HH:=DYNAINFO(39);
IF C>0 AND DISPSTATUS=2 THEN
DRAWTEXTREL(20,30,'总股本:'+NUMTOSTRN(DD,0)+'万股' +' 流通A股:'+NUMTOSTRN(SS,0)+'万股'+' 市盈率:'+NUMTOSTRN(HH,2)+'%'+' 每股收益:'+NUMTOSTRN(GG,3)),COLORbbffff;

MA1:=(LOW+HIGH+CLOSE)/3;
MA2:= MA(MA1,2);
箱顶:HHV(MA2,13),coloryellow,LINETHICK2;
箱底:LLV(MA2,13),colorwhite,LINETHICK2;
五日均价:MA(C,5),colorred,LINETHICK1;
十日均价:MA(C,10),colorwhite,LINETHICK1;
二十日均价:MA(C,20),colorgreen,LINETHICK1;
六十日均价:MA(C,60),coloree66ee,LINETHICK1;
?

将买入无忧中“要涨停”和“极度恐慌”分别做选股

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top