最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 出现“B”时选股修改一个选股公式

出现“B”时选股修改一个选股公式

来源:网络 点击: 时间:2019-02-11

编写要求:

解答:

?网友求助:

TYP:=(HIGH + LOW + CLOSE)/3;
CCI:(TYP-MA(TYP,14))*100/(1.5*AVEDEV(TYP,14)),COLORRED;
涨:CROSS(CCI,0),COLORRED;
强买入信号:CROSS(CCI,100),COLORYELLOW;
回:=CROSS(CCI,120) AND CCI>0,COLORWHITE;
{以下设置副图显示方式}
STICKLINE(涨,0,100,1,0),COLORYELLOW;
STICKLINE(强买入信号,100,200,1,0),COLORFF00FF;
STICKLINE(回,150,50,1,0),COLORWHITE;
DRAWTEXT(回,220,'回'),COLOR00FF00;
STICKLINE(CCI>=100,100,150,1,0),COLORYELLOW;
STICKLINE(CCI>=150,150,200,1,0),COLORRED;
STICKLINE(CCI<=-150,-150,-200,1,0),COLORFF6600;
买入信号信号:=STICKLINE(CROSS(CCI,-120),-200,-150,0.5,0),COLORRED;
STICKLINE(CROSS(CCI,-120),-150,50,0.5,0),COLORRED,LINETHICK1;
DRAWTEXT(CROSS(CCI,-120),-100,' 买入信号'),COLORRED;
CCI高度关注:=IF(REF(CCI,1)<-99 AND CCI >-98,1,0),COLORWHITE;
STICKLINE(CCI高度关注,20,40,0.5,1),LINETHICK3,COLORWHITE;
CCI逃逸:IF(REF(CCI,1)>99 AND CCI <98 ,1,0),COLORGREEN;
STICKLINE(CCI逃逸,180,250,0.5,0),LINETHICK3,COLORGREEN;
买入信号:IF(REF(CCI,1)<-99 AND CCI >REF(CCI,1),1,0),COLORWHITE;
STICKLINE(买入信号,-50,50,0.5,0),COLORFF9900,LINETHICK1;
CCI背:IF(LLV(CCI,2)>LLV(CCI,7) AND LLV(L,2)<=LLV(L,7) AND HHV(H,10)>MA(CLOSE,60),1,0),COLORWHITE;
DRAWTEXT(CCI背,CCI-10,'B'),COLORGREEN;

VAR6:=4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
VAR7:=8;
准备: IF(VAR6<=8,100,0),STICK,COLORGREEN,LINETHICK2;
趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;
见底信号: 10;


DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORFF00FF,LINETHICK1;
CD:=2*(DIFF-DEA),COLORSTICK,LINETHICK1;
低位:IF(DIFF<0,100,0),COLORFFFF00,LINETHICK1;

VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,5,0,4,0),COLOR770077;
STICKLINE(A1,5,0,3,0),COLOR990099;
STICKLINE(A1,5,0,2,0),COLORBB00BB;
STICKLINE(A1,5,0,1,0),COLORDD00DD;
STICKLINE(A1,5,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,5.2,'全仓'),COLORRED;
VAR2:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));
N:=5; N1:=21;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;
VAR2:=8,COLORGREEN,LINETHICK0;
小试牛刀: IF(CROSS(VAR1,VAR2),200,0),STICK,COLORRED;
DRAWICON(小试牛刀>0,200,11);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,-200,'←低进'),COLORFFFF00;


VAR6:=4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
VAR7:=8;
买入: IF(CROSS(VAR6,VAR7),200,0),;


RSV:=(((CLOSE - LLV(LOW,29)) / (HHV(HIGH,29) - LLV(LOW,29))) * 100);
K:=MA(RSV,5);
D:=MA(K,2);
J:=((3 * K) - (2 * D));
顶天立地明天涨:IF((J < 5),200,0),COLORFFFF00;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,200) ,COLOR00CCFF,LINETHICK1;

VAR37:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR38:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR39:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR3A:=(VAR37+2*VAR38+3*VAR39)/6;
VAR3B:=MA(VAR3A,3);
波段金牌建仓区:IF(VAR3B<-6,0,-200);

VAR1E:=((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 100;
VAR2E:=SMA(SMA(VAR1E,3,1),3,1);
VAR3E:=EMA(VAR2E,5);
GZ:=3*VAR2E-2*VAR3E;
见底:if(gz<10,0,-150),colorffff00; 

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top