最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 分时涨停指标中出现笑脸的选股公式

分时涨停指标中出现笑脸的选股公式

来源:网络 点击: 时间:2019-02-24

编写要求:

解答:

?网友求助:

分时涨停指标中出现笑脸的选股公式

分时涨停指标中出现笑脸的选股公式

老师的指标源码:
流通:=FINANCE(7)/10000;
qj1:=CAPITAL/5000; qj2:=CAPITAL/8000; qj3:=CAPITAL/10000; qj4:=CAPITAL/12000; qj5:=CAPITAL/14000; qj6:=CAPITAL/16000; qj7:=CAPITAL/18000; qj8:=CAPITAL/20000;qj9:=ESTDATA(8)/40000;
XS:=IF(CAPITAL=0,qj9,IF(流通<1.0,qj1,IF(流通>=1.0 AND 流通<5.0,qj2,IF(流通>=5.0 AND 流通<10,qj3,IF(流通>=10 AND 流通<20,qj4,IF(流通>=20 AND 流通<40,qj5,IF(流通>=40 AND 流通<60,qj6,IF(流通>=60 AND 流通<=100,qj7,IF(流通>=100,qj8,0)))))))));
XS1:=XS*1.618;
主动买入:=SUM(BUYVOL,0);
主动卖出:=SUM(SELLVOL,0);
大单买:=IF(BUYVOL>XS,BUYVOL,0);
大单卖:=IF(SELLVOL>XS,SELLVOL,0);
小单买:=IF(BUYVOL<=XS,BUYVOL,0);
小单卖:=IF(SELLVOL<=XS,SELLVOL,0);
大单买入:=SUM(大单买,0);
大单卖出:=SUM(大单卖,0);
小单买入:=SUM(小单买,0);
小单卖出:=SUM(小单卖,0);
大单差:=大单买入-大单卖出;
rc:=DYNAINFO(3);
q:=datacount;
hh:=DYNAINFO(5);
LL:=DYNAINFO(6);
f:=max(hh-rc,rc-LL);
ff:=f/rc*100;
q1h:=if(ff<1,0.9898*rc,rc-f*1.02);
q1l:=if(ff<1,0.9798*rc,rc-2*f*1.016);
FILLRGN(1,q1h,q1l),colorblack;
R:=INDEXC;
Rh:=hhv(r,0);
RL:=LLv(r,0);
Rb:=(q1h-q1l)/(RH[q]-RL[q]);
Ry:=(q1h+q1l-rb*(RH[q]+RL[q]))/2;
r*rb+ry,COLOR0000FF;
k1:=hhv(h,0);
k2:=llv(l,0);
k3:=barslast(OPENMINUTES(TIME)<=240);
t1:=barslast(OPENMINUTES(TIME)<=60);
DRAWSL(OPENMINUTES(TIME)>=60,ref(k1,t1),0,k3,2),LINEDOT;
DRAWSL(OPENMINUTES(TIME)>=60,ref(k2,t1),0,k3,2),LINEDOT;
DRAWICON(OPENMINUTES(TIME)>60 and cross(c,ref(k1,t1)+0.001),ref(k1,t1),1);
VARA:=IF(BUYVOL<=REF(ASKVOL(1),1)+REF(ASKVOL(2),1)+REF(ASKVOL(3),1) AND CLOSE>=REF(ASKPRICE(3),1),BUYVOL,0);
上扫单:=SUM(INTPART(IF(VARA>XS AND VARA VARB:=IF(SELLVOL<=REF(BIDVOL(1),1)+REF(BIDVOL(2),1)+REF(BIDVOL(3),1) AND CLOSE<=REF(BIDPRICE(3),1),SELLVOL,0);
下扫单:=SUM(INTPART(IF(VARB>XS AND VARA 总:=(大单买入+大单卖出+小单买入+小单卖出+上扫单+下扫单);
DRAWTEXTEX(DYNAINFO(7),1,20,1050,'■ 大单买入: '+NUMTOSTR(大单买入,0)),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,300,1050,'占:'+NUMTOSTR(FLOOR(大单买入/总*100),0)+' %'),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,20,1100,'■ 大单卖出: '+NUMTOSTR(大单卖出,0)),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,300,1100,'占:'+NUMTOSTR(FLOOR(大单卖出/总*100),0)+' %'),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,1150,'■ 小单买入: '+NUMTOSTR(小单买入,0)),LINETHICK2,colorFF00FF;
DRAWTEXTEX(DYNAINFO(7),1,300,1150,'占:'+NUMTOSTR(FLOOR(小单买入/总*100),0)+' %'),LINETHICK2,colorFF00FF;
DRAWTEXTEX(DYNAINFO(7),1,20,1200,'■ 小单卖出: '+NUMTOSTR(小单卖出,0)),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,300,1200,'占:'+NUMTOSTR(FLOOR(小单卖出/总*100),0)+' %'),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,1250,'■ 上扫大单: '+NUMTOSTR(上扫单,0)),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,300,1250,'占:'+NUMTOSTR(FLOOR(上扫单/总*100),0)+' %'),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,1300,'■ 下扫大单: '+NUMTOSTR(下扫单,0)),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,300,1300,'占:'+NUMTOSTR(FLOOR(下扫单/总*100),0)+' %'),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,1350,'■ 大单量差: '+NUMTOSTR(大单差,0)),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,300,1350,'占:'+NUMTOSTR(大单差/(大单买入+大单卖出)*100,0)+' %'),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,1400,'■ 多空量差: '+NUMTOSTR((主动买入-主动卖出),0)),LINETHICK2,colorFFFF;
DRAWTEXTEX(DYNAINFO(7),1,300,1400,'占:'+NUMTOSTR((主动买入-主动卖出)/总*100,0)+' %'),LINETHICK2,colorFFFF;
//


选股要求:
出笑脸时,换手大于1;量比大于1;外盘大于内盘
?

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top