最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 公式技巧 > 将立竿见影通达信副图改为大智慧格式

将立竿见影通达信副图改为大智慧格式

来源:网络 点击: 时间:2019-03-31

编写要求:

解答:

?网友求助:

请老师将立竿见影通达信副图及选股公式改为大智慧格式,谢谢老师!
{立竿见影通达信副图}
VAR1:(CLOSE-MA(CLOSE,12))/MA(CLOSE,1)*100,COLORGREEN,LINETHICK2;
VAR2:IF((VAR1 > 0),VAR1,0),CIRCLEDOT;
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13),COLORGREEN,LINETHICK2;
VAR10:EMA(0.382*REF(VAR9,2)+0.618*VAR9,6),COLORRED;
DRAWICON(CROSS(VAR9,VAR10-2),VAR10,5);
STICKLINE(VAR2>=0,0,VAR2,8,0),COLORRED;
DRAWICON(CROSS(VAR5,-80),VAR1,25);
立竿见影:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2;
DRAWICON(立竿见影=23,23,1);
E:=CROSS(83,RSI);
STICKLINE( E,70,80,4,0),COLOR00FF00;
DRAWTEXT(E,66,' 逃顶');
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:IF(CROSS(最佳买入,0),61,0),STICK,COLORRED,LINETHICK4;
DRAWTEXT(CROSS(最佳买入,0),62,'最佳买入'),COLOR00FFFF;
STICKLINE(最佳买入选股,0,0.3,7.5,0),COLOR102099;
STICKLINE(最佳买入选股,0,0.3,6,0),COLOR1020AA;
STICKLINE(最佳买入选股,0,0.3,5.5,0),COLOR1020BB;
STICKLINE(最佳买入选股,0,0.3,4,0),COLOR1020CC;
STICKLINE(最佳买入选股,0,0.1,3.5,0),COLOR1020DD;
STICKLINE(最佳买入选股,0,0.1,2,0),COLOR1020EE;
天:80,POINTDOT,COLORBLUE,LINETHICK4;
海:20,POINTDOT,COLORRED,LINETHICK4;
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
EMA3:=EMA(C,3);
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,4,0)COLOR009999;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,3,0)COLOR00BBBB;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,1.5,0)COLOR00DDDD;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,0.6,0)COLOR00FFFF;
DRAWTEXT(TJ1 AND TJ2 AND TJ0 AND TJ3,48,'斋主全仓'),COLORRED;
斋主全仓:IF(CROSS('斋主全仓',0),0.9,0),STICK,COLORRED;
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盘:=3*VARH3-2*VARH4;
AH1:=CROSS(操盘,VARH3) AND VARH3<2.1 AND C>O;
STICKLINE(AH1,50,0,4,0),COLOR770077;
STICKLINE(AH1,50,0,3,0),COLOR990099;
STICKLINE(AH1,50,0,2,0),COLORBB00BB;
STICKLINE(AH1,50,0,1,0),COLORDD00DD;
STICKLINE(AH1,56,0,0.3,0),COLOR00FFFF;
DRAWTEXT(AH1,56,'财神'),COLORRED;

{立竿见影通达信选股}
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
斋主全仓:TJ1 AND TJ2 AND TJ0 AND TJ3;
逃顶:CROSS(83,RSI);
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
红钻:CROSS(VAR5,-80);
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VAR10:=EMA(0.382*REF(VAR9,2)+0.618*VAR9,6);
笑脸:CROSS(VAR9,VAR10-2);
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盘:=3*VARH3-2*VARH4;
财神:CROSS(操盘,VARH3) AND VARH3<2.1 AND C>O;
VAR3:=(CLOSE-LLV(CLOSE,124))/(HHV(CLOSE,124)-LLV(CLOSE,124))*100;
VARA:=(VAR5 OR VAR9) AND VAR4 AND VAR8;
VARB:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
VARC:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VARD:=SMA(VARC,3,2);
VARE:=SMA(VARD,3,2);
VARF:=SMA(VARE,5,1);
底部来临: IF(FILTER(VARA,10)=1,1,0),COLOR00FF00;
止跌: IF(FILTER(VAR10,3)=1,1,0),COLORFFCC66;
牛势股票: REF(VARB,1)>=16 AND REF(VARB,1)/VARB>=1.23 AND CROSS(VARE,VARF),COLORRED;
STICKLINE(牛势股票>0,0.9,1.05,10,0),COLORRED;
DRAWTEXT(底部来临,0.25,'底部买点'),COLOR00FF00;
DRAWTEXT(牛势股票,0.85,'牛势再现'),COLORWHITE;
DRAWTEXT(止跌,0.6,'止跌转牛势'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:CROSS(最佳买入,0);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top