最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股市理论 > 江恩理论 > 飞狐江恩短线指标公式

飞狐江恩短线指标公式

来源:网络 点击: 时间:2018-09-21

VAR1:=(HIGH+LOW+CLOSE)/3;
VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));
VAR3:=(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70));
VAR4:=IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<200,10,0);
VAR5:=IF(VAR2<=-150 AND VAR2>-200 AND VAR3<=-150 AND VAR3>-200,-10,VAR4);
VAR6:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR7:=100-ABS(VAR6);
VAR8:=IF(VAR7<90,VAR7,100);
PJX:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
短期强弱:PJX,colorFFFF;
VAR1A:=IF(PJX>0,PJX,0);
VAR1B:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,VAR5))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR8<100;
VAR1D:=VAR1A<48 AND VAR1B<60 AND VAR8<100;
DRAWTEXT(VAR1D AND COUNT(VAR1D,30)=1,80,'短线反弹'),PXUP2,colorFF;
STICKLINE(VAR1D AND COUNT(VAR1D,30)=1,60,80,5,0),colorFF;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,80,'短线高点'),PXUP2,colorFFCC66;
STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,60,80,5,0),colorFFCC66;
VAR2C:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,0))+30;
VAR2E:=VAR1A<48 AND VAR2C<30 AND VAR8<100;VAR2F:=VAR1A<48 AND VAR2C>30 AND VAR8<100;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,50,'短线反弹2'),PXUP2,colorFF;
STICKLINE(VAR2E AND COUNT(VAR2E,30)=1,30,50,5,0),colorFF;
DRAWTEXT(VAR2F AND COUNT(VAR2F,30)=1,50,'短线高点2'),PXUP2,colorFFCC66;
STICKLINE(VAR2F AND COUNT(VAR2F,30)=1,30,50,5,0),colorFFCC66;
VAR3D:=IF(VAR3<=200 AND VAR2<=150,-15,IF(VAR3>=-200 AND VAR2>=-150,15,VAR5));
VAR3E:=VAR3D>0 AND VAR8<100;VAR3F:=VAR1A<48 AND VAR3D<0 AND VAR8<100;
DRAWTEXT(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,'短线反弹3'),PXUP2,colorFF;
STICKLINE(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,0,5,0),colorFF;
DRAWTEXT(VAR3E AND COUNT(VAR3E,30)=1,20,'短线高点3'),PXUP2,colorFFCC66;
STICKLINE(VAR3E AND COUNT(VAR3E,30)=1,20,0,5,0),colorFFCC66;
强势线:60,colorFF;
VAR9:=IF(VAR7<90,40,30);
分界线:30,colorFFFFFF;STICKLINE(FILTER(VAR1B=45,5),-20,-10,5,0),colorFFFFFF;
DRAWTEXT(FILTER(VAR1B=45,5),0,'强支撑'),PXUP2,colorFFFFFF;
STICKLINE(FILTER(VAR1B=75,5),75,60,5,0),colorFFFFFF;
DRAWTEXT(FILTER(VAR1B=75,5),75,'高压'),PXUP2,colorFFFFFF;
STICKLINE(PJX<=-19,-25,-20,12,0),colorFF00FF;
STICKLINE(PJX>=70,85,80,12,0),colorFF00;
DRAWTEXT(FILTER(VAR5<0,5),30,'★'),PXUP2,colorFF;
DRAWTEXT(FILTER(VAR5>0,5),30,'★'),PXUP2,colorFFCC66;
多空预警:0,colorFFCC66;PARTLINE(VAR9=40 AND VAR2>=0 AND VAR3>=0,多空预警),LINETHICK2,colorFF00;
PARTLINE(VAR9=40 AND VAR2<=0 AND VAR3<=0,多空预警),LINETHICK2,colorFF;

飞狐江恩短线指标公式

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top