最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 套装公式 > 通达信系统评测连续信号过滤公式

通达信系统评测连续信号过滤公式

来源:网络 点击: 时间:2019-02-20

连续信号过滤
代码片段(通达信):
{过滤前的买卖信号}
BUY:= 你的买进信号;
SELL:= 你的卖出信号;
B2:=BARSLAST(BUY);
S2:=BARSLAST(SELL);
{过滤多余买卖信号的条件}
FBUY:=CROSS(S2,B2);
FSELL:=CROSS(B2,S2);

过滤后的买进信号:= BUY AND FBUY;
过滤后的卖出信号:= SELL AND FSELL;

示例代码:
过滤前:C;
{过滤前的买卖信号}
BUY:= C>REF(C,1)*1.05;
SELL:= C B2:=BARSLAST(BUY);
S2:=BARSLAST(SELL);
{过滤多余买卖信号的条件}
FBUY:=CROSS(S2,B2);
FSELL:=CROSS(B2,S2);

BUYNEW:= BUY AND FBUY;
SELLNEW:= SELL AND FSELL;
过滤后: 过滤前+5;
DRAWICON(BUYNEW,过滤后,1);
DRAWICON(SELLNEW,过滤后,2);
DRAWICON(BUY, 过滤前,1);
DRAWICON(SELL, 过滤前,2);

标签:信号

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top