最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信MACD三次背离指标公式

通达信MACD三次背离指标公式

来源:网络 点击: 时间:2019-03-29


DIFIF1:(EMA(CLOSE,12) - EMA(CLOSE,26))*100/EMA(CLOSE,26);
DEAEA1:EMA(DIFIF1,9);
MACD1:=2*(DIFIF1-DEAEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,3,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,3,0),COLORGREEN;
STICKLINE(MACD1 STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIFIF1,COLOR33FF33,LINETHICK2;
DEAEA1,COLORYELLOW,LINETHICK2;
MACD:MACD1,NODRAW,COLORMAGENTA;
强:IF(DIFIF1>=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;
弱:IF(DEAEA1>=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;
DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1+0.1,1);
DRAWICON(CROSS(DEAEA1,DIFIF1),0.4,2);
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1>0,-0.8,'MACD底背'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
DRAWTEXT(B2,-0.6,'KDJ底离'),COLORYELLOW;{KDJ底背离};
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
DRAWTEXT(B3>0,-0.3,'RSI底离'),COLORCYAN;{RSI底背离};
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWTEXT(D1>0,0.4,'MACD顶离'),COLORBLUE;{MACD顶背离}
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
DRAWTEXT(D2>0,0.6,'KDJ顶离'),COLORLIMAGENTA;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
DRAWTEXT(D3>0,0.8,'RSI顶离'),COLORGREEN;{RSI顶背离};
DD:=C=HHV(C,180);
EE:=DEAEA1< REF(DEAEA1,1) AND REF(DEAEA1< REF(DEAEA1,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
上升背离:(CC AND EE)*DEAEA1,COLOR00FFFF;
顶背离:(DD AND EE AND DEAEA1< HHV(DEAEA1,180))*DEAEA1,STICK,LINETHICK3,COLORGREEN;
FF:=C=LLV(C,180);
GG:= DEAEA1> REF(DEAEA1,1) AND REF(DEAEA1> REF(DEAEA1,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
下降背离:(LL AND GG)*DEAEA1,COLORMAGENTA;
底背离:(FF AND GG AND DEAEA1> LLV(DEAEA1,180))*DEAEA1,STICK,LINETHICK3,COLORRED;
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD9:=(DIF-DEA)*2;
AK1:=DIF<0 AND DEA<0;
AK2:=AK1!=REF(AK1,1) AND AK1;
AK3:=COUNT(CROSS(DIF,DEA),BARSLAST(AK2))=1 AND CROSS(DIF,DEA) AND AK1;
AK4:=COUNT(CROSS(DIF,DEA),BARSLAST(AK2))=2 AND CROSS(DIF,DEA) AND AK1;
AK5:=REF(DIF,BARSLAST(AK3))<=REF(DIF,BARSLAST(AK4));
零下二金:AK4 AND AK5,LINETHICK2,COLOR38B0DE;
BC1:=DIF>0 AND DEA>0;
BC2:=BC1!=REF(BC1,1) AND B1;
BC3:=COUNT(CROSS(DIF,DEA),BARSLAST(BC2))=1 AND CROSS(DIF,DEA) AND BC1;
BC4:=COUNT(CROSS(DIF,DEA),BARSLAST(BC2))=2 AND CROSS(DIF,DEA) AND BC1;
BC5:=REF(DIF,BARSLAST(BC3))<=REF(DIF,BARSLAST(BC4));
零上二金:BC4 AND BC5,LINETHICK2;
T:=BARSLAST(CROSS(DIFIF1,DEAEA1) AND DIFIF1<0);
T1:=SUMBARS(T=0,2);
T2:=SUMBARS(T=0,3);
M:=BARSLAST(CROSS(0,MACD1));
M1:=SUMBARS(M=0,2);
M2:=SUMBARS(M=0,3);
DA1:=REF(DIFIF1,BARSLAST(DIFIF1=LLV(DIFIF1,M+1)));
DA2:=REF(DA1,T1-1);
DA3:=REF(DA2,T1-1);
LT:=BARSLAST(L=LLV(L,M+1));
MT:=BARSLAST(DIFIF1=LLV(DIFIF1,M+1));
L1:=REF(L,LT);
L2:=REF(L1,T1-1);
L3:=REF(L2,T1-1);
XG:=T=0 AND L1DA2 AND DA2>DA3;
VAR1:=BACKSET(XG,T2+REF(MT,T2-1));
VAR2:=BACKSET(XG,T1+REF(MT,T1-1));
VAR3:=BACKSET(XG,T+REF(MT,T)+1);
DRAWLINE(CROSS(VAR1=1,0.5),DIFIF1,CROSS(VAR2=1,0.5) AND VAR1=1,DIFIF1,0),COLORYELLOW,LINETHICK2;
DRAWLINE(CROSS(VAR2=1,0.5) AND VAR1=1,DIFIF1,VAR1=1 AND VAR2=1 AND CROSS(VAR3=1,0.5),DIFIF1,0),COLORMAGENTA,LINETHICK2;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top