最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信夏洛特的网主图指标 源码

通达信夏洛特的网主图指标 源码

来源:网络 点击: 时间:2018-08-27
通达信夏洛特的网主图指标 源码

X1:PLOYLINE(C X3:PLOYLINE(C X5:PLOYLINE(C X7:PLOYLINE(C X9:PLOYLINE(C 十:PLOYLINE(C X11:PLOYLINE(C X31:PLOYLINE(C X51:PLOYLINE(C X71:PLOYLINE(C X91:PLOYLINE(C 二十:PLOYLINE(C X12:PLOYLINE(C X32:PLOYLINE(C X52:PLOYLINE(C X72:PLOYLINE(C X92:PLOYLINE(C 三十:PLOYLINE(C X13:PLOYLINE(C X33:PLOYLINE(C X53:PLOYLINE(C X73:PLOYLINE(C X93:PLOYLINE(C 四十:PLOYLINE(C X14:PLOYLINE(C>0,COST(41)),COLOR33CC00;
X34:PLOYLINE(C>0,COST(43)),COLOR33CC00;
X54:PLOYLINE(C>0,COST(45)),COLOR33CC00;
X74:PLOYLINE(C>0,COST(47)),COLOR33CC00;
X94:PLOYLINE(C>0,COST(49)),COLORRED;
COST(50),COLORYELLOW,CIRCLEDOT;
出货成本:COST(99),POINTDOT,LINETHICK4,COLORRED;
市场成本:(COST(25)+COST(75)+ COST(11)+COST(21)+COST(46)+COST(96))/6,POINTDOT,LINETHICK4,COLORWHITE;
主力成本:COST(5),POINTDOT,LINETHICK4,COLORBLUE;
DRAWTEXT(V>=REF(V*1.88,1) AND C>O AND C>REF(C,1),C,'←---突量----------------------------------'),COLORRED;
DRAWTEXT(V>=REF(V*1.88,1) AND C RSV1:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K1:=SMA(RSV1,5,1);
D1:=SMA(K1,5,1);
J:=3*K1-2*D1;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
X8:=REF(K1,1)>80 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X8,C ,O,2,0),COLOR1880FF;
STICKLINE(X8,L ,H,0,0),COLOR1880FF;
STICKLINE(X8,L ,L,20,0),COLOR1880FF;
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,2,0),COLORFF00FF;
DRAWTEXT(LLV(VOL,13)=VOL AND C>=REF(C,1),O,'缩量'),COLORYELLOW;
AA0:=SUMBARS(VOL,CAPITAL);
DRAWTEXT(IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL AA3:=CLOSE > REF(CLOSE, 1) AND REF(CLOSE, 1) > REF(CLOSE, 2) AND REF(CLOSE, 1) < REF(CLOSE, 3) AND IF(REF(CLOSE, 3) < REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) < REF(CLOSE, 5),REF(CLOSE, 1) < REF(CLOSE, 4) OR( REF(CLOSE, 2) < REF(CLOSE, 4) AND REF(CLOSE, 3) >= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) < REF(CLOSE, 6), 1,REF(CLOSE, 6) < REF(CLOSE, 7))));
BB:=CLOSE < REF(CLOSE, 1) AND REF(CLOSE, 1) < REF(CLOSE, 2) AND REF(CLOSE, 1) > REF(CLOSE, 3) AND IF(REF(CLOSE, 3) > REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) > REF(CLOSE, 5),REF(CLOSE, 1) > REF(CLOSE, 4) OR( REF(CLOSE, 2) > REF(CLOSE, 4) AND REF(CLOSE, 3) <= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) > REF(CLOSE, 6), 1,REF(CLOSE, 6) > REF(CLOSE, 7))));
DRAWTEXT(AA3 AND CLOSE>REF(OPEN,2),LOW,'三平底'),COLORFF00FF;
DRAWTEXT(BB AND CLOSE V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,0.8,0),COLORYELLOW;
T12:=V2>=1;
T0:=BARSLAST(T12);
L11:=REF(L,T0);
H1:=REF(H,T0);
STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),H1,H1,4,-1),COLORWHITE;
STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),L11,L11,4,-1),COLORWHITE;
AA:=BARSCOUNT(C);
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),L*1.05,'时间窗'),COLORRED;
RSV0:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top