最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信MACD反身向上顶底背离指标公式

通达信MACD反身向上顶底背离指标公式

来源:网络 点击: 时间:2018-08-25

1,macd反身向上选股:TT=1.00

2,顶背离是画绿线,底背离时划红线。

2,以上公式放牛郎已测试,可以使用,放牛郎不再解答其他问题。



DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:EMA(DIFF,9);

macd:2*(DIFF-DEA), COLORSTICK;

WW:=DEA>REF(DEA,1);

DD:=CROSS(DIFF,REF(DIFF,1));

TT:WW AND DD;

DRAWICON(CROSS(DIFF,DEA),DEA,1);

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,0,0.3,8,0),COLORYELLOW;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.2,8,0),COLORFF80FF;

DRAWICON(二次金叉,DEA*0.9,1) ;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.1,8,0),COLORRED;

DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;

DRAWICON(CROSS(DIFF,DEA),DEA,1);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top