最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信股票周线级别买进和高抛麒麟源码主图指标公式下载

通达信股票周线级别买进和高抛麒麟源码主图指标公式下载

来源:网络 点击: 时间:2018-08-18

  通达信股票周线级别买进和高抛麒麟源码主图指标公式下载

  EMA13:=EMA(C,13),COLORWHITE;

  EMA21:=EMA(C,21),COLORYELLOW;

  EMA34:=EMA(C,34),COLORFF00FF;

  EMA60:=MA(C,60),COLORFFCC66;

  VAR2:=(2*CLOSE+HIGH+LOW)/4;

  VAR3:=IF(YEAR》=2099 AND MONTH》2,0,1);

  VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);

  散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;

  庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;

  DRAWTEXT(CROSS(散户,庄家) AND 散户《30,L-0.05,‘←低吸’),COLORLIRED;

  DRAWTEXT(CROSS(庄家,散户) AND 散户》70,H+0.05,‘←高抛’),COLORGREEN;

  DRAWICON(CROSS(散户,庄家) AND 散户《30,L-0.05,1);

  DRAWICON(CROSS(庄家,散户) AND 散户》70,H+0.05,2);

  VAR9:=CLOSE-REF(CLOSE,5);

  VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);

  VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);

  卖出:=IF(VARA》0 AND CROSS(VARC,VARA),90,100);

  DRAWICON(卖出《0,H+0.05,15); 买线:=EMA(CLOSE,2);

  卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);

  B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;

  S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;

  VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;

  S2:=IF(VC》20 AND FILTER(VC《 REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;

  A0:=(L+H+C*2)/4;

  A1:EMA(A0,14)COLORBLUE,LINETHICK2;

  A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;

  A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;

  A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;

  看多:IF(A1X》=0 AND BARSLAST(CROSS(A1X,0))》0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};

  逃顶:IF(A1X《0 AND BARSLAST(CROSS(0,A1X))》0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};

  买入持股:IF(A1X》=0,A1,DRAWNULL)COLORRED,LINETHICK3;

  卖出空仓:IF(A1X《0 AND A2X《0,A1,DRAWNULL)COLORGREEN,LINETHICK3;

  {彩色K线}

  VARCC1:=(2*C+H+L)/4;

  VARCC2:=MA(VARCC1,30);

  VARCC3:=MA(VARCC1,5);

  STICKLINE(VARCC1》=VARCC2,CLOSE,OPEN,5,0),COLORFF00FF;

  STICKLINE(VARCC1》=VARCC2,HIGH,LOW,0,0),COLORFF00FF;

  STICKLINE(VARCC1《VARCC2,CLOSE,OPEN,5,0),COLORGREEN;

  STICKLINE(VARCC1《VARCC2,HIGH,LOW,0,0),COLORGREEN;

  STICKLINE(VARCC1《VARCC3 AND VARCC3》VARCC2,CLOSE,OPEN,5,0),COLORFF9933;

  STICKLINE(VARCC1《VARCC3 AND VARCC3》VARCC2,HIGH,LOW,0,0),COLORFF9933;

  空:=EMA(C,5);

  均衡:=EMA(空,5),COLORWHITE;

  中轨:=HHV(MA(H,13),13),COLORYELLOW,LINETHICK1;

  趋势:=LLV(MA(H,13),1),COLORRED,LINETHICK1;

  VARAZ:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

  VARBZ:=EMA(0.667*REF(VARAZ,1)+0.333*VARAZ,5);

  VARCZ:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;

  VAR1Z:=(HIGH+LOW+OPEN+2*CLOSE)/5;

  VAR2Z:=REF(VAR1Z,1);

  VAR3Z:=SMA(MAX(VAR1Z-VAR2Z,0),10,1)/SMA(ABS(VAR1Z-VAR2Z),10,1)*100;

  VAR4Z:=FILTER(IF(COUNT(VAR3Z《20,5)》=1 AND COUNT(VAR1Z=LLV(VAR1Z,10),10)》=1 AND

  CLOSE》=OPEN*1.038 AND VOL》MA(VOL,5)*1.2,1,0),5);

  DRAWICON(VAR4Z,LOW,25);

  VAR5Z:=FILTER(均衡》REF(均衡,1)AND 中轨《REF(中轨,1)AND C》REF(C,1),11);

  DRAWTEXT(VAR5Z,LOW*0.985,‘进’),COLORYELLOW;

  DRAWTEXT(VAR5Z,LOW*0.995,‘^’ ),COLORYELLOW;

  {买}

  VARMACD1:=3;

  VARMACD3:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*

  (SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));

  DRAWICON(CROSS(VARMACD3,VARMACD1),L*0.95,25);

  ZA1:=C*2-REF(C,8.5/2);

  ZA2:=REF(C,19/3)*2-C;

  短期对称:=(ZA1+ZA2)/2;

  关键点:=HHV(短期对称,27/2);

  M1:=L*2-REF(H,27/2);

  M2:=REF(H,27/2)*2-L;

  M3:=(M1+M2)/2;

  中期对称:=FORCAST(M3,21);

  趋势判断:=MA(M3,27*2),COLOR0000FF,NODRAW;

  ZA5:=趋势判断-REF(趋势判断,1);

  {通达信版}

  IF(ZA5《0,趋势判断,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;

  IF(ZA5》0,趋势判断,DRAWNULL),COLOR0000FF,POINTDOT,LINETHICK4;

  IF(ZA5=0,趋势判断,DRAWNULL),COLOR00FFFF,POINTDOT,LINETHICK4;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top