最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信股票BS买卖点提示的生命线源码主图指标免费下载

通达信股票BS买卖点提示的生命线源码主图指标免费下载

来源:网络 点击: 时间:2019-05-17

  通达信股票BS买卖点提示的生命线源码主图指标免费下载

  使用说明:股价上穿买入,偏离线上10%抛,线下15%底。

  日均价:=(C*3+H+L+O)/6;

  SA1:=MA(C,5);

  SA:=IF(C》SA1,L,H);

  JUNJ:=SA;

  ED1:=(-2*REF(JUNJ,2)+REF(JUNJ,1)+2*JUNJ),COLORBLUE;

  ED2:=(-0.4*REF(JUNJ,4)-0.4*REF(JUNJ,3)-1.1*REF(JUNJ,2)+0.9*REF(JUNJ,1)+2*JUNJ),COLORBLUE;

  ED3:=(-0.8*REF(JUNJ,4)-0.8*REF(JUNJ,3)-0.2*REF(JUNJ,2)+0.8*REF(JUNJ,1)+2*JUNJ),COLORBLUE;

  JF1:=SMA(SMA(ED1,3,1),3,1),COLOR999900;

  BIAS1 :=(JF1-MA(JF1,5))/MA(JF1,5)*100;

  XAM1:=FLOOR(((JF1-MA(JF1,5))/MA(JF1,5)*100)/5);

  生命线:SMA(SMA((EMA(日均价,ABS(5- XAM1))),3,1),3,1),COLORCYAN;

  T10:=CONST(HHVBARS(V,10));

  EP10:IF(CURRBARSCOUNT《=10+3,CONST(IF(T10=0,C,REF(C,T10))),DRAWNULL),COLORFEFEFE;

  IF(CURRBARSCOUNT=T10+1,EP10,DRAWNULL),CIRCLEDOT,COLORFEFEFE;

  T20→10:=CONST(REF(HHVBARS(V,10),10)+10);

  EP20→10:IF(CURRBARSCOUNT《=20+3 AND CURRBARSCOUNT》=5,CONST(REF(C,T20→10)),DRAWNULL),COLOR009900;

  IF(CURRBARSCOUNT=T20→10+1,EP20→10,DRAWNULL),CIRCLEDOT,COLOR00CC00;

  T30→20:=CONST(REF(HHVBARS(V,10),20)+20);

  EP30→20:IF(CURRBARSCOUNT《=30+3 AND CURRBARSCOUNT》=5,CONST(REF(C,T30→20)),DRAWNULL),COLOR009900;

  IF(CURRBARSCOUNT=T30→20+1,EP30→20,DRAWNULL),CIRCLEDOT,COLOR00CC00;

  T45→30:=CONST(REF(HHVBARS(V,15),30)+30);

  EP45→30:IF(CURRBARSCOUNT《=45+3 AND CURRBARSCOUNT》=5,CONST(REF(C,T45→30)),DRAWNULL),COLOR009900;

  IF(CURRBARSCOUNT=T45→30+1,EP45→30,DRAWNULL),CIRCLEDOT,COLOR00CC00;

  T65→45:=CONST(REF(HHVBARS(V,20),45)+45);

  EP65→45:IF(CURRBARSCOUNT《=65+3 AND CURRBARSCOUNT》=5,CONST(REF(C,T65→45)),DRAWNULL),COLOR009900;

  IF(CURRBARSCOUNT=T65→45+1,EP65→45,DRAWNULL),CIRCLEDOT,COLOR00CC00;

  涨家数:INDEXADV,NODRAW, ;

  跌家数:INDEXDEC,NODRAW,COLORGREEN;

  C3:=REF(C,1);

  涨停:=IF((C-C3)*100/C3》=(10-0.01*100/C3),1,0);

  STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORRED;

  跌停:=IF((C3-C)*100/C3》=(10-0.01*100/C3),1,0);

  STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;

  VAR1:=CLOSE》REF(CLOSE,1) AND CLOSE》REF(CLOSE,2);

  K:=(C+H+L)/3;

  D:=MA(K,4);

  DRAWTEXT(REF(C,1)》D AND C《D AND D》REF(D,1),H*0.95, ‘S’),COLORGREEN;

  DRAWTEXT(REF(C,1)《D AND C》D AND D《REF(D,1),L*0.98 ,‘B’),COLORRED;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top