最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信操盘实战系统主图指标公式

通达信操盘实战系统主图指标公式

来源:网络 点击: 时间:2019-05-18

  通达信操盘实战系统主图指标公式

  趋势线:MA(C,30),DOTLINE COLORFF00CC;

  IF(趋势线》=REF(趋势线,1),趋势线,DRAWNULL),DOTLINE,COLORYELLOW;

  回归斜率线A:EMA(SLOPE(C,21)*20+C,42);

  回归斜率线B:REF(回归斜率线A,2);

  IF(回归斜率线A》REF(回归斜率线A,1),回归斜率线A,DRAWNULL),COLORRED;

  IF(回归斜率线A《REF(回归斜率线A,1),回归斜率线A,DRAWNULL),COLORGREEN;

  IF(回归斜率线B》REF(回归斜率线B,1),回归斜率线B,DRAWNULL),COLORRED;

  IF(回归斜率线B《REF(回归斜率线B,1),回归斜率线B,DRAWNULL),COLORGREEN;

  经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;

  MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))) /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));

  MAHL2:=IF(EMA(C,2)》回归斜率线A AND MAHL1》0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}

  MAHL3:=IF(EMA(C,2)》回归斜率线A AND MAHL1》0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}

  {回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));}

  {C》昨C红K柱+C》O红K柱 C》昨C红K柱 C=昨C是跟白色 24线

  C《昨C蓝K柱+C》O红K柱 C《昨C蓝K柱}

  {STICKLINE(CLOSE》 REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;

  STICKLINE(C《O AND C》REF(C,1),C,O,3,0),COLORFFCC00;}

  {STICKLINE(CLOSE》 REF(CLOSE,1) AND C》O ,OPEN,CLOSE,2.1,0 ),COLOR000099;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;}

  STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;

  STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;

  {STICKLINE(CLOSE《 REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;

  STICKLINE(C《REF(C,1) AND C》O,C,O,3,0),COLORFFCC00;

  STICKLINE(C《REF(C,1) AND C《O ,OPEN,CLOSE,3,0 ),COLOR990000;

  STICKLINE(C《REF(C,1) AND C《O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;

  STICKLINE(CLOSE《 REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;

  STICKLINE(CLOSE《 REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;

  STICKLINE(CLOSE《 REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;}

  {经典KDJ买:IF(CROSS(经典K,经典D),(L-(H-L)/2),DRAWNULL),POINTDOT,LINETHICK6,COLOR0000FF;

  经典KDJ买:IF(CROSS(经典K,经典D),(L-(H-L)/2),DRAWNULL),POINTDOT,LINETHICK6,COLOR0000FF;}

  DRAWICON(CROSS(经典K,经典D),L*0.96,26);

  {高亮红}

  回归斜率买:IF(CROSS(EMA(C,3),回归斜率线A),(L-(H-L)/3),DRAWNULL),POINTDOT,COLOR0000FF;{高亮红}

  回归斜率买_:DRAWICON(CROSS(EMA(C,3),回归斜率线A),L*0.98,1),{买};

  回归斜率卖:IF(CROSS(回归斜率线A,EMA(C,2)),(H+(H-L)/3),DRAWNULL),POINTDOT,COLOR00CF00;{中绿}

  卖:DRAWICON(CROSS(回归斜率线A,EMA(C,2)),H*1.03,2);

  经典KDJ卖:IF(CROSS(经典D,经典K),(H+(H-L)/2),DRAWNULL),CROSSDOT,LINETHICK3,COLOR00CF00;{中绿};

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,9,1);

  D:=SMA(K,9,1);

  J:=3*K-2*D;

  X2:=LLV(J,2)=LLV(J,8);

  {DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X2 AND J《20,LOW*0.99,‘★买’),COLORYELLOW; }

  DRAWICON(CROSS(J,REF(J+0.01,1)) AND X2 AND J《20,LOW*0.99,23);

  VAR6:=REF(C,1);

  VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;

  DRAWTEXT(CROSS(84,VAR7),H*1.01,‘逃顶’),COLORYELLOW ;

  AA:=(REF(H,1)-MAX(REF(C,1),REF(O,1)))/(REF(H,1)-REF(L,1))》0.6 AND (MIN(O,C)-L)/(H-L)》0.6 AND VOL《REF(VOL,1);

  DRAWTEXT(AA,L*0.99,‘揉搓’),COLORRED;

  C3:=REF(C,1);

  跌停:=IF((C3-C)*100/C3》=(10-0.01*100/C3),1,0);

  STICKLINE(跌停,OPEN,CLOSE,3,0),COLORBLUE;

  STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;

  {DRAWTEXT(跌停,H+0.1,‘跌停’),COLORGREEN;}

  涨停:=IF(REF(C,1)*1.095-C《0.01 ,1,0);

  STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;

  STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;

  {DRAWTEXT(涨停,L-0.1,‘板’),COLORYELLOW;}

  超B:=L2_AMO(0,2)/10000.0;

  大B:=L2_AMO(1,2)/10000.0;

  中B:=L2_AMO(2,2)/10000.0;

  小B:=L2_AMO(3,2)/10000.0;

  超S:=L2_AMO(0,3)/10000.0;

  大S:=L2_AMO(1,3)/10000.0;

  中S:=L2_AMO(2,3)/10000.0;

  小S:=L2_AMO(3,3)/10000.0;

  TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

  大宗进:=(超B)+(大B),NODRAW;

  大宗出:=(超S)+(大S),NODRAW;

  非大宗进:=(中B)+(小B),NODRAW;

  非大宗出:=(中S)+(小S),NODRAW;

  DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;

  DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV))-20,30,950,IF(CONST(大宗进》0),RGB(255,0,0),RGB(23,125,255)));

  DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出》0),RGB(23,125,255),RGB(255,0,0)));

  DRAWRECTREL(92,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,122,950,IF(CONST(非大宗进》0),RGB(255,0,0),RGB(23,125,255)));

  DRAWRECTREL(124,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,154,950,IF(CONST(非大宗出》0),RGB(23,125,255),RGB(255,0,0)));

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.015,1,0,‘主力进出’),COLORMAGENTA;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.107,1,0,‘散户进出’),COLORCYAN;

  M1:=EMA(EMA(C,21),3);

  M2:=EMA(EMA(C,34),3);

  TT2:=CROSS(C,M1)AND CROSS(C,M2);

  DRAWTEXT(TT2,L*0.96,‘阳’);

  引导线:EMA(C,3),COLORFF00FF,LINETHICK2;

  阻力线:EMA((1-C/SMA(C,3,1))*C/3+引导线,5),COLORBLUE,LINETHICK2;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top