最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信整合解盘主图指标公式

通达信整合解盘主图指标公式

来源:网络 点击: 时间:2019-02-17

  M1:=5;M2:=13;M3:=34;M4:=55;M5:=89;M6:=144;M7:=233;

  涨停:STICKLINE(C》REF(C,1)*1.099,C,O,3,0),COLORCC00CC;

  跌停:STICKLINE(REF(C,1)*0.909》C,C,O,3,0),COLORGREEN;

  EMA5:EMA(C,M1);

  EMA13:EMA(C,M2);

  EMA21:EMA(C,M5),COLOR5CADAD;

  EMA34:EMA(C,M3);

  EMA55:EMA(C,M4),COLORRED,LINETHICK2;

  EMA144:EMA(C,M6),COLOR20BA22;

  EMA233:EMA(C,M7),COLORBLUE;

  X1:=EMA(EMA(CLOSE,9),9);

  X2:=(X1-REF(X1,1))/REF(X1,1);

  DRAWICON(CROSS(X2,0),L*0.97,1);

  DRAWNUMBER(ISLASTBAR,LOW,BARSLAST(NOT(EMA(C,M1)《REF(EMA(C,M1),1))));

  IF(EMA55《REF(EMA55,1),EMA55,DRAWNULL),COLORGREEN,LINETHICK2;

  倍量:=VOL》=REF(V,1)*1.91 AND C》O;

  缩量:=REF(V,1)》=VOL*1.91 AND C《O;

  STICKLINE(倍量,OPEN,(C+O)*0.5,0.3,0),COLORRED;

  STICKLINE(缩量,OPEN,(C+O)*0.5,0.3,0),COLORBLUE;

  上跳:STICKLINE(LOW》REF(C,1) ,L*0.996,L*0.9925,2,0),COLORRED;

  下跳:STICKLINE(H《REF(C,1) ,H*1.002,H*1.006,2,0),COLORBLUE;

  双线持币:HHV(MA(HIGH,(3)),2),LINETHICK1,COLOR00FF00;

  单线持股:LLV(MA(HIGH,(3)),1),LINETHICK1,COLOR0000FF;

  VAR1:=CLOSE》REF(CLOSE,1) AND CLOSE》REF(CLOSE,2);

  VAR2:=REF(VAR1,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR3:=REF(VAR2,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR4:=REF(VAR3,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR5:=REF(VAR4,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR6:=REF(VAR5,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR7:=REF(VAR6,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR8:=REF(VAR7,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR9:=REF(VAR8,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARA:=REF(VAR9,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VARB:=REF(VARA,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARC:=REF(VARB,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VARD:=CLOSE《REF(CLOSE,1) AND CLOSE《REF(CLOSE,2);

  VARE:=REF(VARD,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARF:=REF(VARE,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR10:=REF(VARF,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR11:=REF(VAR10,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR12:=REF(VAR11,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR13:=REF(VAR12,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR14:=REF(VAR13,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR15:=REF(VAR14,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR16:=REF(VAR15,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR17:=REF(VAR16,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR18:=REF(VAR17,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

  VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

  VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

  VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

  STICKLINE(VAR1A,H*1.010,H*1.006,1,0),COLORGREEN;

  STICKLINE(VAR19,L*0.994,L*0.99,1,0),COLORYELLOW;

  AAA:=CONST(HHV(H,90));

  TT:=240/FROMOPEN;

  比:=TT;

  J12:=(HIGH - ((HIGH - LOW) / 3));

  J23:=(LOW + ((HIGH - LOW) / 3));

  D1:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) 《 0.95 AND REF(OPEN,1)

  《 REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)《0.03 AND

  CLOSE/OPEN》1.05 AND CLOSE》REF(CLOSE,2)),1,0));

  D2:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) 》 1.03 AND REF(OPEN,1)

  》 REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)《0.02

  AND CLOSE/OPEN《0.97 AND CLOSE《REF(CLOSE,2)),1,0));

  D3:=CONST(IF((CLOSE=OPEN AND HIGH/LOW 》1.03),1,0));

  D4:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH),1,0));

  D5:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) 《 0.95 AND REF(OPEN,1)

  《 REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND

  CLOSE/OPEN》1.05 AND CLOSE》REF(CLOSE,2)),1,0));

  D6:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) 》 1.05 AND REF(OPEN,1)

  》 REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND

  CLOSE/OPEN《0.95 AND CLOSE《REF(CLOSE,2)),1,0));

  D7:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW 》

  3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE 》 MA(CLOSE,5)),1,0));

  D8:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW 》

  3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE 《 MA(CLOSE,5)),1,0));

  D9:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW 》

  3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE 《 MA(CLOSE,5)),1,0));

  D10:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW 》

  3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE》MA(CLOSE,5)),1,0));

  D11:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)》1.03 AND CLOSE/OPEN《0.96

  AND CLOSE《REF(OPEN,1)

  AND OPEN》REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)《0.97 AND CLOSE/OPEN》1.04

  AND CLOSE》REF(OPEN,1) AND OPEN《REF(CLOSE,1))),1,0));

  D12:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)》1.03 AND CLOSE/OPEN《0.97

  AND OPEN》REF(CLOSE,1) AND CLOSE《REF(CLOSE,1)),1,0));

  D13:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)《0.97 AND CLOSE/OPEN》1.03

  AND OPEN《REF(CLOSE,1) AND CLOSE》REF(CLOSE,1)),1,0));

  D14:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) 》 0.04

  AND ABS(CLOSE-OPEN)/CLOSE《0.005 AND

  MAX(CLOSE,OPEN) 《 MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)

  》 MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));

  D15:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) 》 0.04

  AND CLOSE=OPEN AND

  CLOSE 《 MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE 》 MIN(REF(CLOSE,1)

  ,REF(OPEN,1))),1,0));

  D16:=CONST(IF((ABS(HIGH-REF(HIGH,1))/HIGH《0.001),1,0));

  D17:=CONST(IF(((ABS(LOW-REF(LOW,1))/LOW《0.001 AND ABS(REF(LOW,1)

  -REF(LOW,2))/REF(LOW,1)《=0.001)),1,0));

  D18:=CONST(IF((CLOSE/OPEN》1.05 AND HIGH/LOW 《

  CLOSE/OPEN+0.018),1,0));

  D19:=CONST(IF((REF(CLOSE,2)》REF(OPEN,2) AND REF(CLOSE,1)

  》REF(OPEN,1) AND CLOSE》OPEN

  AND REF(CLOSE,1)》REF(CLOSE,2) AND CLOSE》REF(CLOSE,1)),1,0));

  D20:=CONST(IF((REF(CLOSE,1)《REF(OPEN,1) AND CLOSE《OPEN

  AND CLOSE/OPEN《0.98),1,0));

  D21:=CONST(IF((REF(CLOSE,2)》REF(OPEN,2) AND (REF(CLOSE,2)

  -REF(OPEN,2))/REF(OPEN,2)》=2/100 AND REF(OPEN,1)》=REF(CLOSE,1)

  AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)《=2/100 AND REF(OPEN,1)

  《=REF(CLOSE,2) AND REF(CLOSE,1)》=REF(OPEN,2) AND C》=OPEN

  AND (CLOSE-OPEN)/OPEN》=2/100 AND CLOSE》=REF(OPEN,1) AND OPEN《=REF(CLOSE,1)

  AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))

  《=1/100),1,0));

  D22:=CONST(IF((REF(CLOSE,2)》REF(OPEN,2) AND REF(CLOSE,1)《REF(OPEN,1)

  AND CLOSE》OPEN),1,0));

  D23:=CONST(IF(((OPEN《EMA(C,20) OR OPEN《EMA(C,40) OR OPEN《

  EMA(C,60)) AND (C》MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)

  》1.2 AND C/REF(C,1)》1.049)),1,0));

  D24:=CONST(IF((REF(CLOSE,4)/REF(OPEN,4)》1.03 AND REF(CLOSE,3)

  《REF(OPEN,3) AND REF(CLOSE,2)《REF(OPEN,2) AND REF(CLOSE,1)《REF(OPEN,1)

  AND REF(LOW,4)《REF(LOW,3) AND REF(LOW,4)《REF(LOW,2) AND REF(LOW,4)

  《REF(LOW,1) AND REF(HIGH,4)》REF(HIGH,3) AND REF(HIGH,4)》REF(HIGH,2)

  AND REF(HIGH,4)》REF(HIGH,1) AND CLOSE/OPEN》1.03 AND CLOSE》REF

  (CLOSE,4)),1,0));

  D25:=CONST(IF(( REF(CLOSE,4)/REF(OPEN,4)《0.97 AND REF(CLOSE,3)

  》REF(OPEN,3) AND REF(CLOSE,2)》REF(OPEN,2) AND REF(CLOSE,1)》REF(OPEN,1)

  AND REF(LOW,4)《REF(LOW,3) AND REF(LOW,4)《REF(LOW,2) AND REF(LOW,4)

  《REF(LOW,1) AND REF(HIGH,4)》REF(HIGH,3) AND REF(HIGH,4)》REF(HIGH,2) AND REF

  (HIGH,4)》REF(HIGH,1) AND CLOSE/OPEN《0.97 AND

  CLOSE《REF(CLOSE,4)),1,0));

  D26:=CONST(IF(HIGH《REF(LOW,1) OR LOW》REF(HIGH,1),1,0));

  D27:=CONST(IF((REF(CLOSE,2)《REF(OPEN,2) AND REF(CLOSE,1)

  《REF(OPEN,1) AND CLOSE《OPEN AND REF(CLOSE,1)《REF(CLOSE,2)

  AND CLOSE《REF(CLOSE,1)),1,0));

  D28:=CONST(IF((LOW=CLOSE AND HIGH!=LOW),1,0));

  D29:=CONST(IF((HIGH=CLOSE AND HIGH!=LOW),1,0));

  D30:=CONST(IF((OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)

  -REF(OPEN,1))《0),1,0));

  D31:=CONST(IF(((MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)》0.667),1,0));

  D32:=CONST(IF(((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)》0.667),1,0));

  D33:=CONST(IF((CLOSE=OPEN AND HIGH!=LOW),1,0));

  D34:=CONST(IF((OPEN/CLOSE 》 1.05 AND HIGH/LOW 《

  OPEN/CLOSE+0.018),1,0));

  D35:=CONST(IF(((REF(CLOSE,1)《REF(OPEN,1) AND CLOSE》OPEN

  AND ABS(CLOSE-REF(CLOSE,1))/CLOSE《0.002) OR (REF(CLOSE,1)》REF(OPEN,1)

  AND CLOSE《OPEN AND ABS(CLOSE-REF(CLOSE,1))

  /CLOSE《0.002)),1,0));

  D36:=CONST(IF((REF(C,1)/REF(O,1)》=1.03 AND O《REF(C,1) AND O

  》REF(O,1) AND C《REF(O,1)),1,0));

  D37:=CONST(V*比》REF(V,1) AND MA(V,5)》REF(MA(V,5),1));

  D38:=CONST(V*比《REF(V,1) AND MA(V,5)》REF(MA(V,5),1));

  D39:=CONST(V*比》REF(V,1)AND MA(V,5)《REF(MA(V,5),1));

  D40:=CONST(V*比《REF(V,1)AND MA(V,5)《REF(MA(V,5),1));

  D41:=CONST((((IF((CLOSE = OPEN),1,0) + IF((CLOSE 》= J12),1,0)) + IF

  ((CLOSE 《= J23),1,0)) 》 1));

  D42:=CONST((((AMOUNT / VOL) / 100) 》 REF(HIGH,1)));

  D43:=CONST((((AMOUNT / VOL) / 100) 《 REF(LOW,1)));

  KS1:=IF(D1=1,0+0.03,0);

  KS2:=IF(D2=1,KS1+0.03,KS1);

  KS3:=IF(D3=1,KS2+0.03,KS2);

  KS4:=IF(D4=1,KS3+0.03,KS3);

  KS5:=IF(D5=1,KS4+0.03,KS4);

  KS6:=IF(D6=1,KS5+0.03,KS5);

  KS7:=IF(D7=1,KS6+0.03,KS6);

  KS8:=IF(D8=1,KS7+0.03,KS7);

  KS9:=IF(D9=1,KS8+0.03,KS8);

  KS10:=IF(D10=1,KS9+0.03,KS9);

  KS11:=IF(D11=1,KS10+0.03,KS10);

  KS12:=IF(D12=1,KS11+0.03,KS11);

  KS13:=IF(D13=1,KS12+0.03,KS12);

  KS14:=IF(D14=1,KS13+0.03,KS13);

  KS15:=IF(D15=1,KS14+0.03,KS14);

  KS16:=IF(D16=1,KS15+0.03,KS15);

  KS17:=IF(D17=1,KS16+0.03,KS16);

  KS18:=IF(D18=1,KS17+0.03,KS17);

  KS19:=IF(D19=1,KS18+0.03,KS18);

  KS20:=IF(D20=1,KS19+0.03,KS19);

  KS21:=IF(D21=1,KS20+0.03,KS20);

  KS22:=IF(D22=1,KS21+0.03,KS21);

  KS23:=IF(D23=1,KS22+0.03,KS22);

  KS24:=IF(D24=1,KS23+0.03,KS23);

  KS25:=IF(D25=1,KS24+0.03,KS24);

  KS26:=IF(D26=1,KS25+0.03,KS25);

  KS27:=IF(D27=1,KS26+0.03,KS26);

  KS28:=IF(D28=1,KS27+0.03,KS27);

  KS29:=IF(D29=1,KS28+0.03,KS28);

  KS30:=IF(D30=1,KS29+0.03,KS29);

  KS31:=IF(D31=1,KS30+0.03,KS30);

  KS32:=IF(D32=1,KS31+0.03,KS31);

  KS33:=IF(D33=1,KS32+0.03,KS32);

  KS34:=IF(D34=1,KS33+0.03,KS33);

  KS35:=IF(D35=1,KS34+0.03,KS34);

  KS36:=IF(D36=1,KS35+0.03,KS35);

  KS37:=IF(D37=1,KS36+0.03,KS36);

  KS38:=IF(D38=1,KS37+0.03,KS37);

  KS39:=IF(D39=1,KS38+0.03,KS38);

  KS40:=IF(D40=1,KS39+0.03,KS39);

  KS41:=IF(D41=1,KS40+0.03,KS40);

  KS42:=IF(D42=1,KS41+0.03,KS41);

  KS43:=IF(D43=1,KS42+0.03,KS42);

  DRAWTEXT_FIX(D1=1,0.26,0.05,0,‘早晨之星,见底回升。’),COLORFF00FF ;

  DRAWTEXT_FIX(D2=1,0.26,0.05,0,‘黄昏之星,见顶回落。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D3=1,0.26,0.05,0,‘长十字,重要的警告信号,原趋势停顿或反转。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D4=1,0.26,0.05,0,‘垂死十字,下跌信号。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D5=1,0.26,0.05,0,‘早晨十字星,上涨信号,见底回升。’),COLORFF00FF ;

  DRAWTEXT_FIX(D6=1,0.26,0.05,0,‘黄昏十字星,趋势停顿或反转,下跌或,见顶回落。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D7=1,0.26,0.05,0,‘射击之星,市场顶部就在眼前,可能见顶回落,可靠性低。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D8=1,0.26,0,0.05,‘倒转锤头构成一个看涨信号,可能见底回升。’),COLORFF00FF ;

  DRAWTEXT_FIX(D9=1,0.26,0.05,0,‘锤头,可能见底回升,如有量配合,信号强烈。’),COLOR0000FF ;

  DRAWTEXT_FIX(D10=1,0.26,0.05,0,‘吊颈,上升行情中见顶回落,顶部出现,见顶信号。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D11=1,0.26,0.05,0,‘穿头破脚,顶部出现,见顶回落信号。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D12=1,0.26,0.05,0,‘乌云盖顶,见顶回落信号。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D13=1,0.23,0.15,0,‘曙光初现,将演化为V型反转或横盘,后市见底回升。’),COLORFF00FF ;

  DRAWTEXT_FIX(D14=1,0.23,0.15,0,‘身怀六甲,底部,是见底回升,顶部,是见顶回落信号。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D15=1,0.26,0.20,0,‘十字胎。’),COLOR00FFFF;

  DRAWTEXT_FIX(D16=1,0.23,0.10,0,‘平顶,行情见顶,股价将反转,但下跌力度较小。’),COLORFFFFFF ;

  DRAWTEXT_FIX(D17=1,0.26,0.05,0,‘平底,行情探低见底,股价行将反转上升,但力度较小。’),COLORFFFFFF ;

  DRAWTEXT_FIX(D18=1,0.23,0.20,0,‘大阳烛,上升中,剧烈地向上攀升。下行中,剧烈地向上反弹。’),COLOR0000FF ;

  DRAWTEXT_FIX(D19=1,0.26,0.05,0,‘三个白武士,每日收盘价上移,表示可能见底回升。’),COLORFFFFFF ;

  DRAWTEXT_FIX(D20=1,0.23,0.10,0,‘双飞乌鸦,行情开始疲软将见顶回落。’),COLORFF0000 ;

  DRAWTEXT_FIX(D21=1,0.26,0,0,‘孕育线,注意股价位置。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D22=1,0.26,0.05,0,‘多方炮,底部可能上涨,中间上涨中继,顶部见顶信号。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D23=1,0.26,0.05,0,‘出水芙蓉,阳线穿过20、40、60日均线,上攻势头初现。’),COLORFF00FF ;

  DRAWTEXT_FIX(D24=1,0.26,0,0,‘上升三部曲,上涨信号。’),COLORFF00FF ;

  DRAWTEXT_FIX(D25=1,0.26,0,0,‘下跌三部曲,下跌信号。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D26=1,0.26,0.15,0,‘跳空缺口,突破盘整,向上涨、向下跌开始。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D27=1,0.26,0.05,0,‘三只乌鸦站枝头,可能见顶回落。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D28=1,0.23,0.10,0,‘光脚阴线,下跌信号。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D29=1,0.26,0.15,0,‘光头阳线,多方积极上攻态势,后市看涨。’),COLOR0000FF ;

  DRAWTEXT_FIX(D30=1,0.26,0.05,0,‘分离,注意看涨分离和看跌分离。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D31=1,0.20,0.15,0,‘长下影,有可能止跌回升,升势末期,须小心。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D32=1,0.23,0.10,0,‘长上影,表明行情上档压力沉重,升势受阻。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D33=1,0.20,0.20,0,‘十字星,重要的警告信号,原趋势停顿或反转。’),COLOR00FFFF ;

  DRAWTEXT_FIX(D34=1,0.26,0.05,0,‘大阴烛,后市向淡,发生逆转。’),COLORFF0000 ;

  DRAWTEXT_FIX(D35=1,0.23,0.15,0,‘好友反攻,跌势已尽,要展开一段反弹行情。’),COLORFF00FF ;

  DRAWTEXT_FIX(D36=1,0.23,0.10,0,‘倾盆大雨,见顶信号。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D37=1,0.26,0,0,‘今日成交量大于昨日,且有继续增大趋势。’),COLORYELLOW ;

  DRAWTEXT_FIX(D38=1,0.26,0,0,‘今日成交量小于昨日,但有放大迹象。’),COLORFFFF00 ;

  DRAWTEXT_FIX(D39=1,0.26,0,0,‘今日成交量大于昨日,但有缩小迹象。’);

  DRAWTEXT_FIX(D40=1,0.26,0,0,‘今日成交量小于昨日,且有缩小迹象。’);

  DRAWTEXT_FIX(D41=1,0.20,0.25,0,‘极端行情,在未来的几日内有85%的机会变更方向。’);

  DRAWTEXT_FIX(D42=1,0.20,0.15,0,‘上涨趋势。’);

  DRAWTEXT_FIX(D43=1,0.20,0.15,0,‘下跌趋势。’);

  AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);

  AZ2:=EMA(AY2,9);

  LT2:=(AY2-AZ2);

  L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;

  ZGD:=HHV(H,80)*0.99;

  ZGD2:=CONST(ZGD);

  ZDD:=LLV(L211,80);

  ZDD2:=CONST(ZDD);

  YYA4:=MA(CLOSE,20);

  YYA5:=(CLOSE 》 MA(CLOSE,5));

  YYA6:=(MA(CLOSE,5) 》 MA(CLOSE,10));

  YYA7:=(CLOSE 》 MA(CLOSE,10));

  YYA8:=(MA(CLOSE,5) 》 MA(CLOSE,20));

  YYA9:=(CLOSE 》 MA(CLOSE,20));

  YYA10:=REF(YYA4,1);

  YYA11:=(YYA4 》 YYA10);

  YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));

  DSLX:=(CLOSE / INDEXC);

  DSLX1:=MA(DSLX,5);

  DSLX2:=MA(DSLX,10);

  YYV1:=MA(VOL,5);

  YYV2:=MA(VOL,10);

  J1:=CONST(IF( YYAVX 》 0,200,100));

  J2:=CONST(IF( YYAVX 》 0,00,100));

  J3:=CONST(IF( YYAVX 》 0,100,100));

  ZGD3:=ZGD2;

  ZDD3:=ZDD2;

  ZGD4:=ZGD2;

  情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 》= YYV2)) AND (DSLX 》= DSLX1)),1,0)),NODRAW;

  情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 《 YYV2)) AND (DSLX 》= DSLX1)),1,0));

  情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 》 YYV2)) AND (DSLX 《 DSLX1)),1,0));

  情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 《= YYV2)) AND (DSLX 《 DSLX1)),1,0));

  情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 》= YYV2)) AND (DSLX 》= DSLX1)),1,0));

  情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 《 YYV2)) AND (DSLX 》= DSLX1)),1,0));

  情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 》= YYV2)) AND (DSLX 《 DSLX1)),1,0));

  情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 《 YYV2)) AND (DSLX 《 DSLX1)),1,0));

  情况9:=CONST(IF(((((YYAVX 》= 1) AND (REF(YYAVX,1) 》 0)) AND (YYV1 》= YYV2)) AND (DSLX 》= DSLX1)),1,0));

  情况10:=CONST(IF(((((YYAVX 》= 1) AND (REF(YYAVX,1) 》 0)) AND (YYV1 《 YYV2)) AND (DSLX 》= DSLX1)),1,0));

  情况11:=CONST(IF(((((YYAVX 》= 1) AND (REF(YYAVX,1) 》 0)) AND (YYV1 》= YYV2)) AND (DSLX 《 DSLX1)),1,0)),NODRAW;

  情况12:=CONST(IF(((((YYAVX 》= 1) AND (REF(YYAVX,1) 》 0)) AND (YYV1 《 YYV2)) AND (DSLX 《 DSLX1)),1,0));

  情况13:=CONST(IF(((((YYAVX 《 1) AND (REF(YYAVX,1) 《 0)) AND (YYV1 》= YYV2)) AND (DSLX 》= DSLX1)),1,0));

  情况14:=CONST(IF(((((YYAVX 《 1) AND (REF(YYAVX,1) 《 0)) AND (YYV1 《 YYV2)) AND (DSLX 》= DSLX1)),1,0));

  情况15:=CONST(IF(((((YYAVX 《 1) AND (REF(YYAVX,1) 《 0)) AND (YYV1 》= YYV2)) AND (DSLX 《 DSLX1)),1,0));

  情况16:=CONST(IF(((((YYAVX 《 1) AND (REF(YYAVX,1) 《 0)) AND (YYV1 《 YYV2)) AND (DSLX 《 DSLX1)),1,0));

  大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 》= YYV2)),1,0));

  大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 《 YYV2)),1,0));

  大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 》= YYV2)),1,0));

  大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 《 YYV2)),1,0));

  大盘5:=CONST(IF((((YYAVX 》= 1) AND (REF(YYAVX,1) 》 0)) AND (YYV1 》= YYV2)),1,0));

  大盘6:=CONST(IF((((YYAVX 》= 1) AND (REF(YYAVX,1) 》 0)) AND (YYV1 《 YYV2)),1,0));

  大盘7:=CONST(IF((((YYAVX 《 1) AND (REF(YYAVX,1) 《 0)) AND (YYV1 》= YYV2)),1,0));

  大盘8:=CONST(IF((((YYAVX 《 1) AND (REF(YYAVX,1) 《 0)) AND (YYV1 《 YYV2)),1,0));

  MFI:=(HIGH-LOW)*1000000/(VOL*比);

  绿灯:=MFI》=REF(MFI,1)AND VOL*比》=REF(VOL,1);

  MMM1:=CONST(绿灯);

  衰退:=MFI《REF(MFI,1)AND VOL*比《REF(VOL,1);

  MMM2:=CONST(衰退);

  伪装:=MFI》=REF(MFI,1)AND VOL*比《REF(VOL,1);

  MMM3:=CONST(伪装);

  蛰伏:=MFI《REF(MFI,1)AND VOL*比》=REF(VOL,1);

  MMM4:=CONST(蛰伏);

  WJ:=(H+L+C)/3;

  V1:=IF(H=L,1,H-MAX(O,C));

  V2:=IF(H=L,1,MAX(C,O)-WJ);

  V3:=IF(H=L,1,MIN(O,C)-L);

  V4:=IF(H=L,1,WJ-MIN(C,O));

  V5:=VOL/IF(H=L,4,H-L);

  V6:=(V1*V5);

  V7:=(V2*V5);

  V8:=(V3*V5);

  V9:=(V4*V5);

  买盘1:=DYNAINFO(23)*比;

  卖盘1:=DYNAINFO(22)*比;

  买盘2:=IF(ISLASTBAR AND C》300,(V9+V8)*TT,(V9+V8));

  卖盘2:=IF(ISLASTBAR AND C》300,(V6+V7)*TT,(V6+V7));

  买盘:=IF(ISLASTBAR AND PERIOD=5 AND C《300,买盘1,买盘2);

  卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C《300,卖盘1,卖盘2);

  量大:=(卖盘+买盘)/REF(VOL,1)》2;

  MMM5:=CONST(量大);

  量缩:=REF(VOL,1)/(卖盘+买盘)》1.5;

  MMM6:=CONST(量缩);

  卖量大:=(卖盘-买盘)/买盘》0.4;

  MMM7:=CONST(卖量大);

  买量大:=(买盘-卖盘)/卖盘》0.4;

  MMM8:=CONST(买量大);

  TS1:=IF(情况1=1,0.06+0.06,0.06); TS2:=IF(情况2=1,TS1+0.06,TS1);

  TS3:=IF(情况3=1,TS2+0.06,TS2); TS4:=IF(情况4=1,TS3+0.06,TS3);

  TS5:=IF(情况5=1,TS4+0.06,TS4); TS6:=IF(情况6=1,TS5+0.06,TS5);

  TS7:=IF(情况7=1,TS6+0.06,TS6); TS8:=IF(情况8=1,TS7+0.06,TS7);

  TS9:=IF(情况9=1,TS8+0.06,TS8); TS10:=IF(情况10=1,TS9+0.06,TS9);

  TS11:=IF(情况11=1,TS10+0.06,TS10); TS12:=IF(情况12=1,TS11+0.06,TS11);

  TS13:=IF(情况13=1,TS12+0.06,TS12); TS14:=IF(情况14=1,TS13+0.06,TS13);

  TS15:=IF(情况15=1,TS14+0.06,TS14); TS16:=IF(情况16=1,TS15+0.06,TS15);

  TS17:=IF(大盘1=1,TS16+0.06,TS16); TS18:=IF(大盘2=1,TS17+0.06,TS17);

  TS19:=IF(大盘3=1,TS18+0.06,TS18); TS20:=IF(大盘4=1,TS19+0.06,TS19);

  TS21:=IF(大盘5=1,TS20+0.06,TS20); TS22:=IF(大盘6=1,TS21+0.06,TS21);

  TS23:=IF(大盘7=1,TS22+0.06,TS22); TS24:=IF(大盘8=1,TS23+0.06,TS23);

  TS25:=IF(MMM1=1,TS24+0.06,TS24);

  TS26:=IF(MMM2=1,TS25+0.06,TS25);

  TS27:=IF(MMM3=1,TS26+0.06,TS26);

  TS28:=IF(MMM4=1,TS27+0.06,TS27);

  TS29:=IF(MMM5=1,TS28+0.03,TS28);

  TS30:=IF(MMM6=1,TS29+0.03,TS29);

  TS31:=IF(MMM7=1,TS30+0.03,TS30);

  TS32:=IF(MMM8=1,TS31+0.03,TS31);

  DRAWTEXT_FIX(情况1=1 ,0.02,0,0,‘量能理想,明显走强,中线参与,仓位控制在70%左右。’),COLORFF00FF;

  DRAWTEXT_FIX(情况2=1 ,0.02,0,0,‘走势趋强,量能不足,短线进场,仓位控制在50%左右。’),COLORFF00FF;

  DRAWTEXT_FIX(情况3=1 ,0.02,0,0,‘量价良好,并无明显走强,短线可进场,仓位50%左右。’),COLORFF00FF;

  DRAWTEXT_FIX(情况4=1 ,0.02,0,0,‘形态尚可,量能不足,未全走强,短入,仓位30%左右。’),COLORFF00FF;

  DRAWTEXT_FIX(情况5=1 ,0.02,0,0,‘形态已变坏,走势尚可,重仓者减大半,清仓者%观望。’),COLOR00FFFF;

  DRAWTEXT_FIX(情况6=1 ,0.02,0,0,‘随大盘下跌,明显缩量,考虑大盘风险,减持或清仓。’),COLOR00FFFF;

  DRAWTEXT_FIX(情况7=1 ,0.02,0,0,‘该股放量下跌,走势明显偏弱,不抢反弹,离场观望。’),COLORFFFFFF;

  DRAWTEXT_FIX(情况8=1 ,0.02,0,0,‘该股缩量下跌,走势偏弱无力,人气散失,离场观望。’),COLORFFFF00;

  DRAWTEXT_FIX(情况9=1 ,0.02,0,0,‘该股形态良好,强势明显,量能充足,可以继续持有。’),COLOR00FFFF;

  DRAWTEXT_FIX(情况10=1,0.02,0,0,‘上行趋势不变,强势依然,量能开始转弱,注意风险。’),COLOR00FFFF;

  DRAWTEXT_FIX(情况11=1,0.02,0,0,‘该股仍然具备上涨潜力,但股性偏弱,可以考虑减仓。’),COLORFFFFFF;

  DRAWTEXT_FIX(情况12=1,0.02,0,0,‘该股走势趋弱,量能明显不足,减大部分筹码或空仓。’),COLORFFFF00;

  DRAWTEXT_FIX(情况13=1,0.02,0,0,‘该股形态不佳,注意成交量变化,但目前不适合参与。’),COLORFFFF00;

  DRAWTEXT_FIX(情况14=1,0.02,0,0,‘该股趋势不明,股价偏弱,注意量能变化,暂不参与。’),COLORFFFF00;

  DRAWTEXT_FIX(情况15=1,0.02,0,0,‘有走强迹象,但量能不足,趋势不明朗,不适合操作。’),COLORFFFF00;

  DRAWTEXT_FIX(情况16=1,0.02,0,0,‘该股走势太弱,主动性买盘弱,没有太大的参与价值。’),COLORFFFFFF;

  DRAWTEXT_FIX(大盘1,0.02,0.05,0,‘总势量能理想,70%仓位, 若最佳买点,否则谨慎介入。’),COLOR00FF00;

  DRAWTEXT_FIX(大盘2,0.02,0.05,0,‘总势趋强,量不足,若前轮下跌,短进50%,量大加仓。’),COLORFF00FF;

  DRAWTEXT_FIX(大盘3,0.02,0.05,0,‘总势形态走坏,重仓者可减去大部分仓位或放空筹码。’),COLORAAAAAA;

  DRAWTEXT_FIX(大盘4,0.02,0.05,0,‘总势缩量调整,注意大盘系统风险,短线可清仓观望。’),COLORFFFFFF;

  DRAWTEXT_FIX(大盘5,0.02,0.05,0,‘总势走势良好,量能理想,可继续持有或加仓强势股。’),COLOR00FFFF;

  DRAWTEXT_FIX(大盘6,0.02,0.05,0,‘总势形态良好,但量能稍显不足,随时准备减仓调仓。’),COLOR00FF00;

  DRAWTEXT_FIX(大盘7,0.02,0.05,0,‘总势趋势不明,注意成交量变化,目前暂不适宜进场。’),COLORFFFFFF;

  DRAWTEXT_FIX(大盘8,0.02,0.05,0,‘总势趋势向下,量能萎缩,短线可杀跌,不适合进场。’),COLORFFFFFF;

  DRAWTEXT_FIX(MMM1,0.02,0.10,0,‘[绿灯]实计交易量增加。MFI促进指数增加。’),COLORFFFFFF;

  DRAWTEXT_FIX(MMM2,0.02,0.10,0,‘[衰退]实计交易量减少。MFI促进指数减少。’),COLORGREEN;

  DRAWTEXT_FIX(MMM3,0.02,0.10,0,‘[伪装]实计交易量减少。MFI促进指数增加。’),COLORGREEN;

  DRAWTEXT_FIX(MMM4,0.02,0.10,0,‘[蛰伏]实计交易量增加。MFI促进指数减少。’),COLORYELLOW;

  DRAWTEXT_FIX(MMM5,0.02,0.15,0,‘★今天比昨天的成交量放大一倍以上。’),COLORGREEN;

  DRAWTEXT_FIX(MMM6,0.02,0.15,0,‘★今天比昨天的成交量缩量一半以上。’),COLORYELLOW;

  DRAWTEXT_FIX(MMM7,0.02,0.20,0,‘☆该股今天卖出量大于买入量40%以上。’),COLORGREEN;

  DRAWTEXT_FIX(MMM8,0.02,0.20,0,‘☆该股今天买入量大于卖出量40%以上。’),COLORYELLOW;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top