最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信金波六矩阵主图指标公式

通达信金波六矩阵主图指标公式

来源:网络 点击: 时间:2018-08-18

  说明: 看懂“A B C”、“Ⅰ Ⅱ Ⅲ”、“① ② ③”的波浪提示,配合120天\60天六矩阵色级方块图,让你有不同的判断空间。

  N:=120;

  K:=BARSLAST(CURRBARSCOUNT=N);

  GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0)); DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0)); KJ:=GD-DD; GD4:=IF(CURRBARSCOUNT《=N/2,GD,DRAWNULL);

  高区:IF(CURRBARSCOUNT《=N,GD,DRAWNULL),COLORRED,LINETHICK2;

  低区:IF(CURRBARSCOUNT《=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2;

  平衡:=IF(CURRBARSCOUNT《=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;

  低:IF(CURRBARSCOUNT《=N/2,DD,DRAWNULL),COLORFFFF00;

  高:IF(CURRBARSCOUNT《=N/2,GD,DRAWNULL),COLOR00FFFF;

  支撑:IF(CURRBARSCOUNT《=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;

  强势: IF(CURRBARSCOUNT《=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;

  突破:IF(CURRBARSCOUNT《=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;

  警示:IF(CURRBARSCOUNT《=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;

  压力:IF(CURRBARSCOUNT《=N/2,DD+KJ*0.809,DRAWNULL),COLOR00FF00;

  低涨:IF(CURRBARSCOUNT《=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;

  天数:BARSLAST(L=DD),COLORCYAN,NODRAW;

  顶点:IF(CURRBARSCOUNT《=N/2, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT;

  低点:IF(CURRBARSCOUNT《=N/2, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT;

  STICKLINE(CCI》=200 AND H》=顶点,O,C,2,0),COLORBLUE;

  STICKLINE(CCI《=100 AND L《=低点,O,C,2,0),COLORYELLOW;

  DRAWBAND(高区,RGB(120,20,0),平衡,RGB(0,0,0));

  DRAWBAND(平衡,RGB(80,0,100),低区,RGB(0,0,0));

  DRAWBAND(高,RGB(100,100,0),压力,RGB(0,0,0));

  DRAWBAND(压力,RGB(0,80,0),警示,RGB(0,0,0));

  DRAWBAND(警示,RGB(220,120,0),突破,RGB(0,0,0));

  DRAWBAND(突破,RGB(120,0,120),强势,RGB(0,0,0));

  DRAWBAND(强势,RGB(120, 0,0),支撑,RGB(0,0,0));

  DRAWBAND(支撑,RGB(80,80,80),低,RGB(0,0,0));

  STICKLINE(CURRBARSCOUNT=N,GD,DD,0,0),COLORGREEN;

  STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080;

  STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;

  STICKLINE(CURRBARSCOUNT《=N/2,支撑,支撑,2,0),COLORFF00FF;

  STICKLINE(CURRBARSCOUNT《=N/2,强势,强势,2,0),COLORFF00FF;

  STICKLINE(CURRBARSCOUNT《=N/2,突破,突破,2,0),COLORABABAB;

  STICKLINE(CURRBARSCOUNT《=N/2,警示,警示,2,0),COLOR00FFFF;

  STICKLINE(CURRBARSCOUNT《=N/2,压力,压力,2,0),COLOR00FFFF;

  DRAWTEXT(CURRBARSCOUNT=10,压力,压力-0.809),COLOR00FFFF;

  DRAWTEXT(CURRBARSCOUNT=10,警示,警示-0.618),COLOR00FFFF;

  DRAWTEXT(CURRBARSCOUNT=10,突破,突破-0.500),COLORFFFFFF;

  DRAWTEXT(CURRBARSCOUNT=10,强势,强势-0.382),COLOR00FFFF;

  DRAWTEXT(CURRBARSCOUNT=10,支撑,支撑-0.191),COLOR00FFFF;

  DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,【风险区】--高抛避险),COLOR00FFFF;

  DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,【警示区】--逢高减仓),COLOR0000FF;

  DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.45,【突破区】--主力拉升),COLORFFFFFF;

  DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,【拉升区】--强势畜锐),COLORFFFF80;

  DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/3,【关注区】--逢低买入),COLOR00FFFF;

  DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,【低吸区】--大胆买入),COLOR00FF00;

  DRAWTEXT(CURRBARSCOUNT=N/2+40,GD-KJ*0.25,【拉升区】),COLORRED;

  DRAWTEXT(CURRBARSCOUNT=N/2+40,DD+KJ*0.25,【持股区】),COLORYELLOW;

  第一防线:REFDATE(低,DATE),POINTDOT,COLORYELLOW,LINETHICK4;

  第二防线:REFDATE(支撑,DATE),POINTDOT,COLORWHITE,LINETHICK4;

  DRAWKLINE(H,O,L,C);

  AHC1:=CLOSE*VOL;

  AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);

  上轨:=1.06*AHC22,COLOR40FF00,LINETHICK1;

  下轨:=AHC22*0.94;

  ZT:=REF(C,1)*1.1-C《0.01 AND H=C;

  启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;

  DRAWTEXT(启爆,L,启爆),COLORCYAN;

  STICKLINE(启爆,C,O,3,1),COLORWHITE;

  STICKLINE(启爆,C,O,1,0),COLORGREEN;

  N1:=5;

  SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100》100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);

  AA10:MA(CLOSE,3),COLOR0000FF;

  AA12:MA(CLOSE,5),COLOR0000FF;

  BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);

  BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);

  MA13:=MA(CLOSE,13);

  DRAWBAND(AA10,RGB(255,255,6),AA12,RGB(256,150,60));

  趋势:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000077;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000099;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR0000AA;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;

  STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR777777;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR999999;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORAAAAAA;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;

  X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

  EMA8:=EMA(C,8);DRAWTEXT(FILTER(BB13》1 AND EMA(X1,13)》REF(EMA(X1,8),1),10),

  EMA8,∠45上升),COLORWHITE;

  压力线:MA(REF(HHV(C,33),1),2),COLORFFFF80,LINETHICK3;

  支撑线:MA(REF(LLV(C,33),1),2),COLOR0000FF,LINETHICK3;

  AA1:=AMOUNT/V;BB1:=L《AA1*0.9;

  CC1:=(C-REF(C,1))/REF(C,1)*100》1.2;

  DD1:=L《MA(C,5)*0.921;

  EE1:=V《MA(V,5)*1.5;

  FF1:=BB1 AND CC1 AND DD1 AND EE1;DRAWTEXT(FF1,(LOW* 0.99),鼠),COLOR4080FF;

  A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

  黑马线:=EMA(A51,5);

  A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

  趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));

  DRAWTEXT(CROSS(趋势线,0)AND 黑马线《40,(HIGH* 0.97),▲大马),COLORYELLOW;

  LC:=REF(CLOSE,1);

  RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

  FF:=EMA(CLOSE,3);

  MA15:=EMA(CLOSE,21);

  STICKLINE(CROSS(88,RSI),O,C,0.3,0),COLOR113311;

  VAR2:=LLV(LOW,27);

  VAR3:=HHV(HIGH,34);

  VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;

  注意买:=IF((VAR4《10),80,100);

  RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

  KD:=SMA(RSV,3,1);

  D:=SMA(KD,3,1);

  J:=3*KD-2*D;

  超跌:=IF(J《0,10,0);

  BDDD:=LLV(J,2)=LLV(J,8);

  买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J《20,30,0);

  DRAWICON(买入 AND 注意买=100 AND 超跌=0,LOW*0.97,23);

  MTM:=C-REF(C,1);

  DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

  买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX《0,2) AND CROSS(DX,MA(DX,2)),1,0);

  DRAWTEXT(FILTER(买=1,5),LOW-0.08,拉),COLOR0000FF;

  GET:ZIG(3,N1),COLORYELLOW,LINETHICK2;

  PL5:=ZIG(3,5);

  EN1:=ZIG(3,5)》REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)《=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)《=REF(ZIG(3,5),3);

  EX1:=ZIG(3,5)《REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)》=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)》=REF(ZIG(3,5),3);

  PL10:=ZIG(3,10);

  EN2:=ZIG(3,10)》REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)《=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)《=REF(ZIG(3,10),3);

  EX2:=ZIG(3,10)《REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)》=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)》=REF(ZIG(3,10),3);

  PL20:=ZIG(3,20);

  EN3:=ZIG(3,20)》REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)《=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)《=REF(ZIG(3,20),3);

  EX3:=ZIG(3,20)《REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)》=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)》=REF(ZIG(3,20),3);

  PL40:=ZIG(3,40);

  走强1:=BARSLAST(PL5《REF(PL5,1));

  走弱1:=BARSLAST(PL5》REF(PL5,1));

  走强2:=BARSLAST(PL10《REF(PL10,1));

  走弱2:=BARSLAST(PL10》REF(PL10,1));

  走强3:=BARSLAST(PL20《REF(PL20,1));

  走弱3:=BARSLAST(PL20》REF(PL20,1));

  ZTJZ5:=IF(PL10》REF(PL10,1),COUNT(EN1,走强2),0);

  ZTJD5:=IF(PL10》REF(PL10,1),COUNT(EX1,走强2),0);

  DTJZ5:=IF(PL10《REF(PL10,1),COUNT(EN1,走弱2),0);

  DTJD5:=IF(PL10《REF(PL10,1),COUNT(EX1,走弱2),0);

  ZTJZ10:=IF(PL20》REF(PL20,1),COUNT(EN2,走强3),0);

  ZTJD10:=IF(PL20》REF(PL20,1),COUNT(EX2,走强3),0);

  DTJZ10:=IF(PL20《REF(PL20,1),COUNT(EN2,走弱3),0);

  DTJD10:=IF(PL20《REF(PL20,1),COUNT(EX2,走弱3),0);

  DRAWTEXT(EN1 AND DTJZ5=1,L*0.96,(A)),COLORFFFF00;

  DRAWTEXT(EX1 AND DTJD5=2,H*1.02,(B)),COLORFF00FF;

  DRAWTEXT(EN2 AND ZTJZ5=1,L*0.96,(C)),COLOR0000FF;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJD5=1,H*1.03,⑴),COLOR0000FF;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=2,L*0.98,⑵),COLOR0000FF;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJZ5=2,H*1.03,⑶),COLOR0000FF;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=3,L*0.98,⑷),COLOR0000FF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.03,⑸),COLOR0000FF;

  DRAWTEXT(EN2 AND DTJZ10=1,L*0.95,Ⅰ),COLORFF00FF;

  DRAWTEXT(EX2 AND DTJD10=2,H*1.05,Ⅱ),COLORFFFF00;

  DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,Ⅲ),COLOR0000FF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.03,①),

  LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=2,L*0.97,②),

  LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)

  AND EX2,H*1.03,③),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=3,L*0.97,④),

  LINETHICK3,COLOR00FFFF;

  A1:=REF(C,1);

  A2:=CLOSE;

  A3:=(A2-A1)/A1*100;

  AAA11:=(A3-REF(A3,1));

  AA2:=9.8;

  选股1:=CROSS(AAA11,AA2);

  A11:=REF(V,1);

  A12:=DVOL;

  A13:=A12/A11;

  AA3:=(A13-REF(A13,1));

  AA4:=500;

  选股2:=CROSS(AA3,AA4);

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=2,L*0.99,↖↖●强势),LINETHICK8,COLORFFFF00;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top