最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信V型反转主图指标公式

通达信V型反转主图指标公式

来源:网络 点击: 时间:2019-02-16

  Z1:=STRCAT(HYBLOCK, );

  Z2:=STRCAT(Z1,DYBLOCK);

  Z3:=STRCAT(Z2, );

  DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;

  DRAWTEXT_FIX(ISLASTBAR,0.001,0.050,0,GNBLOCK),COLORCYAN;;

  ZT:=REF(C,1)*1.1-C《0.01 AND H=C; AA:=MA((2*CLOSE+HIGH+LOW)/4,5);

  通1:=AA*102/100;

  通2:=AA*(200-102)/100;

  CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

  DD:=DMA(CLOSE,CC);

  上:(1+7/100)*DD,DOTLINE,COLORGREEN;

  下:(1-7/100)*DD,DOTLINE,COLORGREEN;

  中:(上+下)/2,DOTLINE,COLORGREEN;

  IF((上 《= REF(上,1)),上,DRAWNULL),COLORGREEN,DOTLINE;

  IF((上 》 REF(上,1)),上,DRAWNULL),COLORRED,DOTLINE;

  IF((中 《= REF(中,1)),中,DRAWNULL),COLORGREEN,DOTLINE;

  IF((中 》 REF(中,1)),中,DRAWNULL),COLORRED,DOTLINE;

  IF((下 《= REF(下,1)),下,DRAWNULL),COLORGREEN,DOTLINE;

  IF((下 》 REF(下,1)),下,DRAWNULL),COLORRED,DOTLINE;

  顶:=(1+14/100)*DD,LINETHICK2,COLORBLACK;

  底:=(1-14/100)*DD,LINETHICK2,COLORBLACK;

  触底:=REF(L,1)《底 AND ZT ;

  DRAWTEXT(触底,L,反转),COLORCYAN;

  STICKLINE(触底,C,O,3,1),COLORYELLOW;

  STICKLINE(触底,C,O,1,0),COLORRED;

  DF:=(C-REF(C,1))/REF(C,1)*100《-5;

  DF4:=(C-O)/O*100《-4;

  AAAA:=BARSLAST(DF);

  突破箱体:=CROSS(C,REF(C,AAAA));

  箱顶:DRAWLINE(DF,O,REF(DF,1),REF(O,1),1),COLORMAGENTA,LINETHICK2;

  箱顶1:DRAWLINE(DF4,O,REF(DF4,1),REF(O,1),1),COLORMAGENTA,LINETHICK2;

  JRH:=HHV(C,2);

  JRL:=LLV(C,2);

  MA3:=MA(CLOSE,3);

  YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;

  VAR1:=(CLOSE》REF(CLOSE,1) AND CLOSE》REF(CLOSE,2));

  VAR2:=(REF(VAR1,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR3:=(REF(VAR2,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR4:=(REF(VAR3,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR5:=(REF(VAR4,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR6:=(REF(VAR5,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR7:=(REF(VAR6,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR8:=(REF(VAR7,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR9:=(REF(VAR8,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VARA:=(REF(VAR9,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VARB:=(REF(VARA,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VARC:=(REF(VARB,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VARD:=(CLOSE《REF(CLOSE,1) AND CLOSE《REF(CLOSE,2));

  VARE:=(REF(VARD,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VARF:=(REF(VARE,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR10:=(REF(VARF,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR11:=(REF(VAR10,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR12:=(REF(VAR11,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR13:=(REF(VAR12,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR14:=(REF(VAR13,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR15:=(REF(VAR14,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR16:=(REF(VAR15,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR17:=(REF(VAR16,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2));

  VAR18:=(REF(VAR17,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2));

  VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

  VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);

  红色持股:=VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

  卖出:=IF(红色持股,JRL,DRAWNULL);

  明离场价:=卖出,COLORFF99FF,NODRAW;

  今离场价:REF(卖出,1)COLOR0000FF,NODRAW;

  青色观望:=VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;

  进:=IF(青色观望,JRH,DRAWNULL);

  短买:=VAR19,COLOR33AACC,NODRAW;

  品红离场:=VAR1A,COLORFF99FF,NODRAW;

  急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100《-14,COLORFFFFFF,NODRAW;

  STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;

  STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;

  STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;

  STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;

  STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;

  STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;

  STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;

  STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;

  STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;

  STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;

  CO:=(C-O);

  STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;

  STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;

  STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;

  STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;

  STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;

  STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555;

  STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;

  STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;

  STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;

  STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;

  STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;

  STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;

  STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;

  STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;

  STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;

  EX5:EXPMA(C,5)COLORWHITE,LINETHICK2;

  EX13:EXPMA(C,13)COLORCYAN,LINETHICK2;

  启爆:=CROSS(C,上) OR CROSS(C,中) AND ZT;

  DRAWTEXT(启爆,L,启爆),COLORCYAN;

  STICKLINE(启爆,C,O,3,1),COLORWHITE;

  STICKLINE(启爆,C,O,1,0),COLORGREEN;

  买点:=REF(下,2)》REF(下,1) AND 下》REF(下,1);

  DRAWTEXT(买点,L*0.98,↖买点)COLORRED;

  乖离涨停1:=H》上 AND ZT AND CROSS(C,上);

  STICKLINE(乖离涨停1,C,O,3,1),COLORYELLOW;

  乖离涨停2:=O》上 AND ZT;

  STICKLINE(乖离涨停2,C,O,3,1),COLORCYAN;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top