最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信最新波浪主图指标公式

通达信最新波浪主图指标公式

来源:网络 点击: 时间:2018-08-13

  N1:=6;

  重心:(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;

  SJ:=WMA((重心-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);

  ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);

  DRAWTEXT(CROSS(SJ,ZJ) AND SJ《30,L-0.1,←低吸),COLOR00FF00;

  DRAWTEXT(CROSS(ZJ,SJ) AND SJ》70,H+0.1,←高抛),COLOR0077FF;

  A1:=EMA(C,14)COLORWHITE,LINETHICK1;

  A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;

  突破:REF(EMA(C,14),1),NODRAW;

  距离:(C-突破)/突破*100,NODRAW;

  出击:IF(A1X》=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK1;

  休假:IF(A1X《0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK1;

  涨幅:IF(A1X》=0,(C-出击)/出击*100,DRAWNULL)NODRAW;

  跌幅:IF(A1X《0,(C-休假)/休假*100,DRAWNULL)NODRAW;

  ♂10%:IF(H》=出击*1.1,出击*1.1,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;

  ♂20%:IF(H》=出击*1.2,出击*1.2,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;

  ♂30%:IF(H》=出击*1.3,出击*1.3,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;

  ♀Ⅰ:IF(L《休假*0.9,休假*0.9,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;

  ♀Ⅱ:IF(L《休假*0.8,休假*0.8,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;

  ♀Ⅲ:IF(L《休假*0.7,休假*0.7,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;

  STICKLINE(CROSS(A1X,0),C,O,2,0)COLORYELLOW;

  STICKLINE(CROSS(0,A1X),C,O,2,0)COLORGREEN;

  STICKLINE(CROSS(A1X,0)OR CROSS(0,A1X),REF(EMA(C,14),1),REF(EMA(C,14),1)*0.998,2,0)COLORWHITE;

  STICKLINE(ISLASTBAR,REF(EMA(C,14),1),REF(EMA(C,14),1)*0.998,5,0)COLORWHITE;

  A11:DRAWLINE(HIGH》=HHV(HIGH,5),HIGH,LOW《=LLV(LOW,5),LOW,0);

  B1:DRAWLINE(LOW《=LLV(LOW,5),LOW,HIGH》=HHV(HIGH,5),HIGH,0);

  A2:DRAWLINE(HIGH》=HHV(HIGH,13),HIGH,LOW《=LLV(LOW,13),LOW,0),COLORCYAN;

  B2:DRAWLINE(LOW《=LLV(LOW,13),LOW,HIGH》=HHV(HIGH,13),HIGH,0);

  A3:DRAWLINE(HIGH》=HHV(HIGH,34),HIGH,LOW《=LLV(LOW,34),LOW,0);

  B3:DRAWLINE(LOW《=LLV(LOW,34),LOW,HIGH》=HHV(HIGH,34),HIGH,0);

  A4:DRAWLINE(HIGH》=HHV(HIGH,55),HIGH,LOW《=LLV(LOW,55),LOW,0);

  B4:DRAWLINE(LOW《=LLV(LOW,55),LOW,HIGH》=HHV(HIGH,55),HIGH,0);

  MTM:=C-REF(C,1);

  ZLGJ:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);

  买1:=IF(LLV(ZLGJ,2)=LLV(ZLGJ,7) AND COUNT(ZLGJ《0,2) AND CROSS(ZLGJ,MA(ZLGJ,2)),1,0);

  卖1:=IF(HHV(ZLGJ,2)=HHV(ZLGJ,7) AND COUNT(ZLGJ》50,2) AND CROSS(MA(ZLGJ,2),ZLGJ),1,0);

  DRAWICON(FILTER(买1=1,5),LOW*0.99,7),COLORRED;

  STICKLINE(FILTER(买1=1,5),C,O,1,0),COLORRED;

  DRAWICON(FILTER(卖1=1,1),H*1.01,8),COLOR00FF00;

  STICKLINE(FILTER(卖1=1,1),C,O,1,0),COLOR00FF00;

  RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  BDGD:=HHV(J,2)=HHV(J,8) AND J》80;

  注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);

  DRAWTEXT(注意 AND 卖1《1,HIGH*1.01,J),COLOR00FF00,LINETHICK3;

  STICKLINE(注意 AND 卖1《1,O,CLOSE,1,0),COLORYELLOW,LINETHICK2;

  时间窗口01:=FILTER(IF(HHVBARS(HIGH,5),0,H),5),COLORFFFF00;

  DRAWTEXT(时间窗口01,HIGH*0.99,5);

  时间窗口02:=FILTER(IF(LLVBARS(LOW,5),0,L),5),COLOR00FFFF;

  DRAWTEXT(时间窗口02,LOW*0.99,5);

  时间窗口1:=FILTER(IF(HHVBARS(HIGH,13),0,1),13),COLOR00FF00;

  DRAWTEXT(时间窗口1,HIGH*0.99,13);

  时间窗口2:=FILTER(IF(LLVBARS(LOW,13),0,1),13),COLOR0000FF;

  DRAWTEXT(时间窗口2,LOW*0.99,13);

  时间窗口3:=FILTER(IF(HHVBARS(HIGH,34),0,2),34),COLOR55FF55;

  DRAWTEXT(时间窗口3,HIGH*0.99,34);

  时间窗口4:=FILTER(IF(LLVBARS(LOW,34),0,2),34),COLOR5555FF;

  DRAWTEXT(时间窗口4,LOW*0.99,34);

  时间窗口5:=FILTER(IF(HHVBARS(HIGH,55),0,30),55),COLOR99FF99;

  DRAWTEXT(时间窗口5,HIGH*0.99,55);

  时间窗口6:=FILTER(IF(LLVBARS(LOW,55),0,30),55),COLORDD00FF;

  DRAWTEXT(时间窗口6,LOW*0.99,55);

  时间窗口7:=FILTER(IF(HHVBARS(HIGH,89),0,40),89),COLORDDFFDD;

  DRAWTEXT(时间窗口7,HIGH*0.99,89);

  时间窗口8:=FILTER(IF(LLVBARS(LOW,89),0,40),89),COLOR0055FF;

  DRAWTEXT(时间窗口8,LOW*0.99,89);

  时间窗口9:=FILTER(IF(HHVBARS(HIGH,144),0,50),144),COLORDDFF00;

  DRAWTEXT(时间窗口9,HIGH*0.99,144);

  时间窗口10:=FILTER(IF(LLVBARS(LOW,144),0,50),144),COLOR9955FF;

  DRAWTEXT(时间窗口10,LOW*0.99,144);

  时间窗口11:=FILTER(IF(HHVBARS(HIGH,233),0,60),233),COLORDDFFFF;

  DRAWTEXT(时间窗口11,HIGH*0.99,233);

  时间窗口12:=FILTER(IF(LLVBARS(LOW,233),0,60),233),COLORFF55FF;

  DRAWTEXT(时间窗口12,LOW*0.99,233);

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top