最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信财神趋势主图指标公式

通达信财神趋势主图指标公式

来源:网络 点击: 时间:2019-03-16

  中线:MA(CLOSE,21);

  上线:中线+2*STD(CLOSE,21) COLORGREEN;

  下线:中线-2*STD(CLOSE,21) COLORRED;

  局部低点预选A:=BACKSET(LLV(L,5)《REF(LLV(L,4),1),4);

  局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);

  局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);

  局部高点预选A:=BACKSET(HHV(H,5)》REF(HHV(H,4),1),4);

  局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);

  局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);

  局部极点A:=局部低点预选C+局部高点预选C;

  AAAA:IF(局部低点预选C=-1,L,IF(局部高点预选C=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;

  缺口判断:=IF(L》REF(H,1),1,IF(H《REF(L,1),-1,0));

  距前高天:=BARSLAST(局部高点预选C=1);

  距前低天:=BARSLAST(局部低点预选C=-1);

  小值周期:=LOWRANGE(L);

  大值周期:=TOPRANGE(H);

  低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)》REF(距前低天,1) AND LLV(L,距前高天+1)《REF(LLV(L,距前高天+1),1),-1,0);

  低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)《=REF(距前低天,1) AND (距前高天》=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)《REF(LLV(L,距前低天+1),1)),-1,0);

  低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L《REF(H,距前高天+1),-1,0);

  预判:=IF((距前低天《4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);

  判断:=IF(局部高点预选C=1 AND REF(距前低天,1)《=REF(距前高天,1) AND 预判=1 AND 大值周期》REF(小值周期,距前低天+1) AND 大值周期》REF(小值周期,距前低天) AND 大值周期》REF(大值周期,距前高天),1,0);

  高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)》REF(距前高天,1) AND HHV(H,距前低天+1)》REF(HHV(H,距前低天+1),1),1,0);

  高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)《=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天》=4 OR HHV(缺口判断,距前低天)=1),1,0);

  高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H》REF(L,距前低天+1),1,0);

  预判A:=IF((距前高天《4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);

  判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)《=REF(距前低天,1) AND 预判A=1 AND 小值周期》REF(大值周期,距前高天+1) AND 小值周期》REF(大值周期,距前高天) AND 小值周期》REF(小值周期,距前低天),-1,0);

  低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)》REF(距前低天,1) AND LLV(L,距前高天+1)《REF(LLV(L,距前高天+1),1),-1,0);

  低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)《=REF(距前低天,1) AND (距前高天》=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);

  低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L《REF(H,距前高天+1),-1,0);

  AAAD:=IF(高保留=1 AND 低保留=-1 AND H》REF(H,REF(距前高天,1)+2),1,IF(高保留=1 AND 低保留=-1 AND L《REF(L,REF(距前低天,1)+2),-1,0));

  极点保留:=IF(AAAD=0,高保留+低保留,AAAD);

  局部极点:=IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;

  DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0)COLORBLUE;

  DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0)COLORBLUE;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top