最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信顶底抄大底指标公式

通达信顶底抄大底指标公式

来源:网络 点击: 时间:2019-05-19

  VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VAR2:=2*ABS(VAR1);

  VAR3:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));

  VAR4:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));

  VAR5:=(HIGH+LOW+CLOSE)/3;

  VAR6:=(VAR5-MA(VAR5,10))/(0.015*AVEDEV(VAR5,10));

  VAR7:=(VAR5-MA(VAR5,30))/(0.015*AVEDEV(VAR5,30));

  VAR8:=IF(VAR6》=150 AND VAR6《200 AND VAR7》=150 AND VAR7《200,10,0);

  VAR9:=IF(VAR6《=-150 AND VAR6》-200 AND VAR7《=-150 AND VAR7》-200,-10,VAR8);

  VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  VARB:=100-ABS(VARA);

  VARC:=3*SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);

  VARD:=3*SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);

  VARE:=REF(LOW,1)*0.9;

  VARF:=LOW*0.9;

  VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

  VAR11:=EMA(VAR10,30);

  VAR12:=VAR11-CLOSE;

  VAR13:=REF(CLOSE,1);

  VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;

  VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;

  VAR16:=BARSCOUNT(CLOSE);

  VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

  VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;

  VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

  VAR1A:=(SMA(VAR19,4,1)-50)*2;

  VAR1B:=SMA(VAR1A,3,1);

  VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

  VAR1D:=SMA(VAR1C,4,1);

  VAR1E:=SMA(VAR1D,3,1);

  VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

  VAR20:=IF(VAR17《=25 AND VAR18《-95 AND VAR1F》20 AND VAR1B《-30 AND VAR1E《30 AND VAR12》=-0.25 AND VAR14《22 AND VAR15《28 AND VAR16》50,80,0);

  大趋势:=VAR3 ;

  顶线:=IF(VARB《90,VARB,100);

  多方:=IF(VAR1》0,VAR1,0);

  空方:=0-IF(VAR1《0,VAR2,0) ;

  抄底:(VAR20 AND PWINNER(5,CLOSE)《1.1)*10,STICK,LINETHICK3 ;

  顶底:IF(VAR7》=200 AND VAR6》=150 OR CROSS(65,多方),15,IF(VAR7《=-200 AND VAR6《=-150,-15,VAR9)),COLORFF972F;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top