最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信股道选股指标公式

通达信股道选股指标公式

来源:网络 点击: 时间:2019-02-26

  通达信股道选股指标公式FF:=EMA(CLOSE,3);

  MA15:=EMA(CLOSE,21);

  TTJ:=CROSS(FF,MA15);

  TYP:= (HIGH + LOW + CLOSE)/3;

  CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));

  差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;

  CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));

  差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;

  CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));

  差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;

  CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));

  差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;

  CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));

  差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;

  CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;

  AAA:=(3*C+H+L+O)/6;

  VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)

  +4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

  VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;

  VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;

  VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;

  VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;

  VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;

  短线:=VAR1;

  中线:=VAR6;

  下跌:=IF(VAR1=VAR6,VAR6, DRAWNULL);

  TJ1:=CCI1》差值4;

  立桩量:=FILTER(TJ1,0);

  TJ2:=IF(BARSLAST(立桩量)=1 ,1,0);

  成立1:=TJ2=1;

  条件成立1:=FILTER(成立1,5);

  TJ011:= CCI1《-差值4 ;

  立桩量2:=FILTER(TJ011,0);

  TJ022:=IF(BARSLAST(立桩量2)=1 AND CLOSE》REF(HIGH,1),1,

  IF(BARSLAST(立桩量2)=2 AND CLOSE》REF(HIGH,2),1,

  IF(BARSLAST(立桩量2)=3 AND CLOSE》REF(HIGH,3),1,0)));

  TJ:=IF(BARSLAST(立桩量2)=1 AND CLOSE》REF(LOW,1),1,0);

  成立2:=TJ=1;

  条件成立2:=FILTER(成立2,5);

  TJ111:=(ABS(CCI1)》CCI AND ABS( 差值1)》 ABS(差值5))

  OR (VOL=HHV(VOL,10) AND VOL》2*REF(VOL,1) AND CLOSE》VAR1);

  立桩量3:=FILTER(TJ111,5);

  TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE》REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE》REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE》REF(LOW,3),1,0)));

  成立:=TJ3=1;

  条件成立:=FILTER(成立,5);

  上:=EMA(C,3),COLORBLUE,LINETHICK1;

  中:=EMA(C,5),COLORWHITE,LINETHICK1;

  下:=EMA(中,5),COLOR00FF00,LINETHICK1;

  QQ:= C《中;

  MM:=上》REF(上,1) AND REF(上,1)《REF(上,2) ;

  V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

  V2:=(1-7/100)*(DMA(CLOSE,V1));

  V3:=(1+7/100)*(DMA(CLOSE,V1));

  V5:=MA((LOW+HIGH+CLOSE)/3,5);

  MA1:=MEMA(CLOSE,5);

  MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;

  MA3:=IF(MA2》0,MA2,MA2);

  MA5:=MA(CLOSE,5),COLOR888899;

  MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;

  VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)》=REF(C,2) OR REF(C,1)》=REF(C,3))

  OR REF(C,1)=HHV(C,4) AND CLOSE》=REF(C,2) OR REF(C,2)=HHV(C,4) AND

  REF(C,3)=LLV(C,4) AND C》=REF(C,1) OR REF(C,3)=HHV(C,4) AND

  C》=REF(C,1) AND C》=REF(C,2);

  {收盘价=4日内收盘价的最高值 AND 昨收》=2日前的收盘价}

  VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);

  {收盘价=4日内收盘价的最高值 AND 昨收=4日内收盘价的最低值}

  VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)《REF(C,2) OR REF(C,1)《REF(C,3)) OR

  REF(C,1)=LLV(C,4) AND C《REF(C,2) OR REF(C,2)=LLV(C,4) AND

  REF(C,1)=HHV(C,4) AND C《REF(C,1) OR REF(C,3)=LLV(C,4) AND

  C《REF(C,1) AND C《REF(C,2);

  {收盘价=4日内收盘价的最低值 AND (昨收《2日前的收盘价}

  VAR04:=REF(C,1)=LLV(C,4) AND C》=REF(C,2) OR REF(C,2)=LLV(C,4) AND

  REF(C,1)《=REF(C,3) AND REF(C,2)《REF(C,4) AND C》=REF(C,1);

  {昨收=4日内收盘价的最低值 AND 收盘价》=2日前的收盘价}

  VAR05:=REF(C,1)=HHV(C,4) AND C《REF(C,2) OR (REF(C,2)=HHV(C,4) AND

  REF(C,1)》REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)》REF(C,2)) AND

  REF(C,2)》=REF(C,4) AND C《REF(C,1);

  {昨收=4日内收盘价的最高值 AND 收盘价《2日前的收盘价}

  VAR06:=V5》REF(V5,1) AND REF(V5,1)《REF(V5,2);

  {今日V5向上形成拐点}

  VAR07:=LOW《HHV(V5,13) AND HIGH》HHV(V5,13) AND CLOSE》REF(C,1) AND CLOSE》OPEN;

  VAR08:=VAR07 AND COUNT(VAR06,2);

  VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);

  VAR10:=EMA(MA(C,13),13);

  VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09《0,2) AND

  CROSS(VAR09,MA(VAR09,2)))=1,5);

  VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09》50,2) AND

  CROSS(MA(VAR09,2),VAR09))=1,1);

  VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;

  VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);

  VAR15:=MA(C,18)》=REF(MA(C,18),3) AND CROSS(C,MA(C,18));

  VAR16:=VAR08 AND NOT(REF(VAR08,1));

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  金叉:=CROSS(J,D);

  死叉:=CROSS(D,J);

  买1:=(VAR14 OR VAR15) AND VAR11;

  买2:=(VAR14 OR VAR15) AND VAR04;

  买3:=(VAR14 OR VAR15) AND VAR02;

  买4:=(VAR02 AND VAR11) OR (VAR04 AND VAR11);

  买5:=(金叉 AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);

  TTJ0:=VAR16;

  TTJ1:=买1 OR 买2 OR 买3 OR 买4 OR 买5 AND MM;

  XG0:=TTJ AND TTJ0;

  XG1:=TTJ AND TTJ1;

  TTJ3:=条件成立 AND 下跌!= VAR6;

  XG3:=TTJ0 AND TTJ3;

  XG11:=XG0 OR XG1 OR XG3;

  PL5:=ZIG(3,5);

  EN1:=ZIG(3,5)》REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)《=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)《=REF(ZIG(3,5),3);

  EX1:=ZIG(3,5)《REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)》=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)》=REF(ZIG(3,5),3);

  PL10:=ZIG(3,10);

  EN2:=ZIG(3,10)》REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)《=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)《=REF(ZIG(3,10),3);

  EX2:=ZIG(3,10)《REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)》=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)》=REF(ZIG(3,10),3);

  PL20:=ZIG(3,20);

  EN3:=ZIG(3,20)》REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)《=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)《=REF(ZIG(3,20),3);

  EX3:=ZIG(3,20)《REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)》=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)》=REF(ZIG(3,20),3);

  PL40:=ZIG(3,40);

  走强1:=BARSLAST(PL5《REF(PL5,1));

  走弱1:=BARSLAST(PL5》REF(PL5,1));

  走强2:=BARSLAST(PL10《REF(PL10,1));

  走弱2:=BARSLAST(PL10》REF(PL10,1));

  走强3:=BARSLAST(PL20《REF(PL20,1));

  走弱3:=BARSLAST(PL20》REF(PL20,1));

  ZTJZ5:=IF(PL10》REF(PL10,1),COUNT(EN1,走强2),0);

  ZTJD5:=IF(PL10》REF(PL10,1),COUNT(EX1,走强2),0);

  DTJZ5:=IF(PL10《REF(PL10,1),COUNT(EN1,走弱2),0);

  DTJD5:=IF(PL10《REF(PL10,1),COUNT(EX1,走弱2),0);

  ZTJZ10:=IF(PL20》REF(PL20,1),COUNT(EN2,走强3),0);

  ZTJD10:=IF(PL20》REF(PL20,1),COUNT(EX2,走强3),0);

  DTJZ10:=IF(PL20《REF(PL20,1),COUNT(EN2,走弱3),0);

  DTJD10:=IF(PL20《REF(PL20,1),COUNT(EX2,走弱3),0);

  TJ11:=EN2 AND ZTJZ5=1;

  TJ22:=EN1 AND PL10》REF(PL10,1) AND ZTJZ5=2;

  TJ33:=EN2 AND DTJZ10=1;

  TJ44:=EN3 AND ZTJZ10=1;

  TJ55:=EN2 AND PL20》REF(PL20,1) AND ZTJZ10=2;

  XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;

  XG:=XG11 OR XG22;

  W18:EXIST(XG,1)

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top