最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信双向黄金分割主图指标公式

通达信双向黄金分割主图指标公式

来源:网络 点击: 时间:2019-05-17

  通达信双向黄金分割主图指标公式N:=6000;

  高:=REFDATE(HHV(H,N),DATE);

  低:=REFDATE(LLV(L,N),DATE);

  H1:=高-(高-低)*0.191;

  H2:=高-(高-低)*0.382;

  H3:=高-(高-低)*0.5;

  H4:=高-(高-低)*0.618;

  H5:=高-(高-低)*0.809;

  H6:=高-(高-低)*0.764;

  H7:=高-(高-低)*0.236;

  STICKLINE(CURRBARSCOUNT=8,高,高,0,1),COLORGREEN;

  STICKLINE(CURRBARSCOUNT=8,H1,H1,0,1),COLORCYAN;

  STICKLINE(CURRBARSCOUNT=8,H2,H2,0,1),COLORCCCCCC;

  DRAWTEXT(CURRBARSCOUNT=10,高,‘ 1.000’),COLORGREEN;

  DRAWTEXT(CURRBARSCOUNT=10,H1,‘0.809’),COLORCYAN;

  DRAWTEXT(CURRBARSCOUNT=10,H2,‘ 0.618’),COLORFFFFFF;

  DRAWTEXT(CURRBARSCOUNT=10,H3,‘ 0.500’),COLORYELLOW;

  DRAWTEXT(CURRBARSCOUNT=10,H4,‘ 0.382’),COLORLIRED;

  DRAWTEXT(CURRBARSCOUNT=10,H6,‘ 0.236’),COLORGREEN;

  DRAWTEXT(CURRBARSCOUNT=10,H5,‘ 0.191’),COLORMAGENTA;

  DRAWTEXT(CURRBARSCOUNT=10,H7,‘ 0.764’),COLORRED;

  DRAWTEXT(CURRBARSCOUNT=10,低,‘ 0.000’),COLORRED;

  STICKLINE(CURRBARSCOUNT=8,H3,H3,0,1),COLORYELLOW;

  STICKLINE(CURRBARSCOUNT=8,H4,H4,0,1),COLORLIRED;

  STICKLINE(CURRBARSCOUNT=8,H6,H6,0,1),COLORGREEN;

  STICKLINE(CURRBARSCOUNT=8,H5,H5,0,1),COLORMAGENTA;

  STICKLINE(CURRBARSCOUNT=8,低,低,0,1),COLORRED;

  STICKLINE(CURRBARSCOUNT=8,H7,H7,0,1),COLORRED;

  DRAWTEXT(CURRBARSCOUNT=50,高*0.99,CON2STR(高,2)),COLORGREEN;

  DRAWTEXT(CURRBARSCOUNT=50,H1,CON2STR(H1,2)),COLORCYAN;

  DRAWTEXT(CURRBARSCOUNT=50,H2,CON2STR(H2,2)),COLORFFFFFF;

  DRAWTEXT(CURRBARSCOUNT=50,H3,CON2STR(H3,2)),COLORYELLOW;

  DRAWTEXT(CURRBARSCOUNT=50,H6,CON2STR(H6,2)),COLORGREEN;

  DRAWTEXT(CURRBARSCOUNT=50,H4,CON2STR(H4,2)),COLORLIRED;

  DRAWTEXT(CURRBARSCOUNT=50,H5,CON2STR(H5,2)),COLORMAGENTA;

  DRAWTEXT(CURRBARSCOUNT=50,H7,CON2STR(H7,2)),COLORRED;

  DRAWTEXT(CURRBARSCOUNT=50,低*1.01,CON2STR(低,2)),COLORRED;

  HDAY:=800;LDAY:=800;调点:=3;角度:=100;

  CURR:=CURRBARSCOUNT;

  TCH:=CONST(FINDHIGH(H,0,HDAY*10,1));

  GTT:=CONST(BARSLAST(TCH=H))+1;

  SX跌H:=CONST(IF(GTT=1,H,REF(H,GTT-1)));

  BCL:=CONST(FINDLOW(L,0,LDAY*10,1));

  DTT:=CONST(BARSLAST(BCL=L))+1;

  SX涨L:=CONST(IF(DTT=1,L,REF(L,DTT-1)));

  涨点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(L=SX涨L)+1));

  跌点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(H=SX跌H)+1));

  最低:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,涨点,跌点)));

  L斜率:=角度/IF(C《300,1000,10);

  最高:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,跌点,涨点)));

  H斜率:=角度/IF(C《300,1000,10);

  IM68:=((SX跌H-SX涨L)/6-(SX跌H-SX涨L)/8);

  GH跌X:=SX跌H+(SX跌H-SX涨L)/8;

  DL涨X:=SX涨L-(SX跌H-SX涨L)/8;

  GTHT:=IF(DTT》GTT,DTT,GTT);

  {黄金分割}

  X000:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.000,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X000)*1.001,STRCAT(‘ 0.000 ’,CON2STR(X000,2))),COLORF5CCEB;

  X191:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.191,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X191)*1.001,STRCAT(‘ 0.191 ’,CON2STR(X191,2))),COLORF5CCEB;

  X236:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.236,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X236)*1.001,STRCAT(‘ 0.236 ’,CON2STR(X236,2))),COLORF5CCEB;

  X382:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.382,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X382)*1.001,STRCAT(‘ 0.382 ’,CON2STR(X382,2))),COLORF5CCEB;

  X500:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.500,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X500)*1.001,STRCAT(‘ 0.500 ’,CON2STR(X500,2))),COLORF5CCEB;

  X618:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.618,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X618)*1.001,STRCAT(‘ 0.618 ’,CON2STR(X618,2))),COLORF5CCEB;

  X764:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.764,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X764)*1.001,STRCAT(‘ 0.764 ’,CON2STR(X764,2))),COLORF5CCEB;

  X809:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*0.809,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X809)*1.001,STRCAT(‘ 0.809 ’,CON2STR(X809,2))),COLORF5CCEB;

  X1:IF(CURR《=GTHT,SX跌H-(SX跌H-SX涨L)*1.000,DRAWNULL),DOTLINE,COLOR556600;

  DRAWTEXT(CURR=GTHT,(X1)*1.001,STRCAT(‘ 1.000. ’,CON2STR(X1,2))),COLORF5CCEB;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top