最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信价值1000的主图指标公式

通达信价值1000的主图指标公式

来源:网络 点击: 时间:2019-05-11

  通达信价值1000的主图指标公式V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

  V2:=(1-7/100)*(DMA(CLOSE,V1));

  V3:=(1+7/100)*(DMA(CLOSE,V1));

  V5:=MA((LOW+HIGH+CLOSE)/3,5);

  支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;

  阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;

  VAR1:=CLOSE》REF(CLOSE,1) AND CLOSE》REF(CLOSE,2);

  VAR2:=REF(VAR1,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR3:=REF(VAR2,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR4:=REF(VAR3,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR5:=REF(VAR4,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR6:=REF(VAR5,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR7:=REF(VAR6,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR8:=REF(VAR7,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR9:=REF(VAR8,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARA:=REF(VAR9,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VARB:=REF(VARA,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARC:=REF(VARB,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VARD:=CLOSE《REF(CLOSE,1) AND CLOSE《REF(CLOSE,2);

  VARE:=REF(VARD,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARF:=REF(VARE,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR10:=REF(VARF,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR11:=REF(VAR10,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR12:=REF(VAR11,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR13:=REF(VAR12,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR14:=REF(VAR13,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR15:=REF(VAR14,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR16:=REF(VAR15,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR17:=REF(VAR16,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR18:=REF(VAR17,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

  VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

  STICKLINE(VAR19,L,L*0.98,3,0),COLORYELLOW;

  VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

  VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

  STICKLINE(VAR1A,H*1.01,H,3,0),COLOR00FF00{98FD};

  MA3:MA(C,3);

  MA5:MA(C,5),COLORWHITE;

  MA10:=MA(C,10),NODRAW;

  MA30:MA(C,34),NODRAW;

  五日乖离率:=(C-MA5)/MA5*100;

  BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

  IF(BB5》30 AND MA5》REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORRED;

  BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

  IF(BB5《0 AND MA5《REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORGREEN;

  DD5:=MA5《REF(MA5,1);

  IF(DD5,MA5,DRAWNULL),COLOR00FF00;

  X:=(3*C+L+O+H)/6;

  多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)

  +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)

  +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+

  REF(X,20))/210,COLORFF00FF,LINETHICK1;

  {用法:黄托底买进,绿压顶买出。}

  DD:=多空线《REF(多空线,1);

  IF(DD,多空线,DRAWNULL),COLORBLUE,LINETHICK2;

  A:=(MA5》多空线);

  IF(A,多空线,DRAWNULL),COLORYELLOW,POINTDOT;

  A1:=(MA5《多空线);

  IF(A1,多空线,DRAWNULL),COLORWHITE;

  A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);

  A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;

  A5:=EMA(CLOSE,12)-EMA(CLOSE,26);

  A6:=EMA(A5,9);

  A7:=(A5《-0.1 AND A5》A6);

  财神:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;

  CYS:=(EMA((CLOSE-V2)/V2,1)*100);

  AA:=CYS;

  MIDD:=MA(CYS,20);

  CC:=MIDD+0.85*STD(CYS,10);

  TM6:=AA》CC;

  IF(TM6,MA5,DRAWNULL),COLORRED,LINETHICK1;

  A0:=(L+H+C*2)/4;

  工作:=EMA(A0,14)COLORYELLOW,LINETHICK1;

  度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;

  A1X:=(工作-REF(工作,1))/REF(工作,1)*100;

  A2X:=(度假-REF(度假,1))/REF(度假,1)*100;

  G:=BARSLAST(CROSS(A1X,0));

  {KDJ}

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  金叉:=CROSS(J,D);

  死叉:=CROSS(D,J);

  买1:=(VAR14 OR VAR15) AND VAR11;

  买2:=(VAR14 OR VAR15) AND VAR4;

  买3:=(VAR14 OR VAR15) AND VAR2;

  买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);

  买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);

  {涨停}

  STICKLINE(CLOSE》REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;

  {跌停}

  STICKLINE(CLOSE《REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;

  {蓝}

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;

  {红}

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,3,0),COLOR000099;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;

  {绿}

  STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;

  STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;

  STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;

  STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;

  {灰}

  STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;

  STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;

  STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;

  STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;

  STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;

  STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000099;

  DRAWICON(VAR16,LOW-0.02,7);

  DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);

  DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);

  STICKLINE(CROSS(A1X,0),C,O,1,0)COLORFFFFFF;

  STICKLINE(CROSS(0,A1X),C,O,1,0)COLORGREEN;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top