最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信12年主图指标公式

通达信12年主图指标公式

来源:网络 点击: 时间:2019-05-21

  通达信12年主图指标公式AA:=C《3;

  MM:=3》REF(3,1) AND REF(3,1)《REF(3,2) ;

  超买:MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2;

  超卖:MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2;

  趋线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42);

  获利%:WINNER(CLOSE)*100,NODRAW;

  V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

  V2:=(1-7/100)*(DMA(CLOSE,V1));

  V3:=(1+7/100)*(DMA(CLOSE,V1));

  V5:=MA((LOW+HIGH+CLOSE)/3,5);

  VAR1:=CLOSE=HHV(C,4) AND (REF(C,1)》=REF(C,2) OR REF(C,1)》=REF(C,3))

  OR REF(C,1)=HHV(C,4) AND CLOSE》=REF(C,2) OR REF(C,2)=HHV(C,4) AND

  REF(C,3)=LLV(C,4) AND C》=REF(C,1) OR REF(C,3)=HHV(C,4) AND

  C》=REF(C,1) AND C》=REF(C,2);

  {收盘价=4日内收盘价的最高值 AND 昨收》=2日前的收盘价}

  VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);

  {收盘价=4日内收盘价的最高值 AND 昨收=4日内收盘价的最低值}

  VAR3:=CLOSE=LLV(C,4) AND (REF(C,1)《REF(C,2) OR REF(C,1)《REF(C,3)) OR

  REF(C,1)=LLV(C,4) AND C《REF(C,2) OR REF(C,2)=LLV(C,4) AND

  REF(C,1)=HHV(C,4) AND C《REF(C,1) OR REF(C,3)=LLV(C,4) AND

  C《REF(C,1) AND C《REF(C,2);

  {收盘价=4日内收盘价的最低值 AND (昨收《2日前的收盘价}

  VAR4:=REF(C,1)=LLV(C,4) AND C》=REF(C,2) OR REF(C,2)=LLV(C,4) AND

  REF(C,1)《=REF(C,3) AND REF(C,2)《REF(C,4) AND C》=REF(C,1);

  {昨收=4日内收盘价的最低值 AND 收盘价》=2日前的收盘价}

  VAR5:=REF(C,1)=HHV(C,4) AND C《REF(C,2) OR (REF(C,2)=HHV(C,4) AND

  REF(C,1)》REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)》REF(C,2)) AND

  REF(C,2)》=REF(C,4) AND C《REF(C,1);

  {昨收=4日内收盘价的最高值 AND 收盘价《2日前的收盘价}

  VAR6:=V5》REF(V5,1) AND REF(V5,1)《REF(V5,2);

  {今日V5向上形成拐点}

  VAR7:=LOW《HHV(V5,13) AND HIGH》HHV(V5,13) AND CLOSE》REF(C,1) AND CLOSE》OPEN;

  VAR8:=VAR7 AND COUNT(VAR6,2);

  VAR9:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);

  VAR10:=EMA(MA(C,13),13);

  VAR11:=FILTER((LLV(VAR9,2)=LLV(VAR9,7) AND COUNT(VAR9《0,2) AND

  CROSS(VAR9,MA(VAR9,2)))=1,5);

  VAR12:=FILTER((HHV(VAR9,2)=HHV(VAR9,7) AND COUNT(VAR9》50,2) AND

  CROSS(MA(VAR9,2),VAR9))=1,1);

  VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;

  VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);

  VAR15:=MA(C,18)》=REF(MA(C,18),3) AND CROSS(C,MA(C,18));

  VAR16:=VAR8 AND NOT(REF(VAR8,1));

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  金叉:=CROSS(J,D);

  死叉:=CROSS(D,J);

  买1:=(VAR14 OR VAR15) AND VAR11;

  买2:=(VAR14 OR VAR15) AND VAR4;

  买3:=(VAR14 OR VAR15) AND VAR2;

  买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);

  买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);

  STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;

  STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000066;

  DRAWICON(VAR16,LOW-0.02,15);

  DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5 AND MM,LOW-0.05,15);

  DRAWICON(死叉 OR CROSS(50,VAR9) AND AA AND K》50,HIGH+0.01,2);

  X1:=(C+L+H)/3;

  BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;

  EMA3:=EMA(C,3);

  DRAWTEXT(FILTER(BB5》1 AND EMA(X1,7)》REF(EMA(X1,7),1),10),

  LOW*0.99,‘★∠45’),COLORFFFFFF;

  VAR81:=1;

  VAR82:=((((2*CLOSE)+HIGH)+LOW) / 4);

  低金叉进:=20;

  高死叉出:=90;

  VAR84:=LLV(LOW,5);

  VAR85:=HHV(HIGH,4);

  C1:=(EMA((((VAR82-VAR84)/(VAR85-VAR84))*100),4)*VAR81);

  C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR81);

  条件1:=CROSS(C1,C2) AND C1《40;

  条件0:=CROSS(C2,C1) AND C1》90;

  TJ1:=CROSS(C1,C2);

  TJ2:=CROSS(C2,C1);

  TJ3:=CROSS(C1,C2) AND REF(C1,1)《20;

  TJ4:=CROSS(C2,C1) AND REF(C1,1)》80;

  DRAWTEXT(条件0,H*1.02,‘S’),COLORBLUE;

  DRAWTEXT(TJ3 AND MM,L*0.98,‘底’);

  DRAWTEXT(TJ4 AND AA,H*1.02,‘逃’);

  STICKLINE((C-REF(C,1))/REF(C,1)》0.095,C,O,2,0),COLORYELLOW;

  水平面:=EMA(CLOSE,89);

  AAA:=(3*C+H+L+O)/6;

  短趋:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

  中趋:=(LLV(短趋,2)+LLV(短趋,4)+LLV(短趋,6))/3;

  TTJ1:=VOL=HHV(VOL,10) AND VOL》2*REF(VOL,1) AND CLOSE》短趋;

  立桩量:=FILTER(TTJ1,5);

  TTJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE》REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE》REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE》REF(HIGH,3),1,0)));

  突破:=TTJ2=1;

  TTJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE》REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE》REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE》REF(LOW,3),1,0)));

  三天:=TTJ3=1;

  成立:=三天 AND 突破;

  条件:=FILTER(成立,3);

  DRAWTEXT(条件,L*0.93,‘★’),COLOR00FFFF;

  VAR90:=((((HHV((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)

  -EMA(DCLOSE,26)),9)))*2),4)《0) AND ((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-

  (EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2)》REF((((EMA(DCLOSE,12)

  -EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),1)))

  AND (REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-

  EMA(DCLOSE,26)),9)))*2),1)《REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-

  (EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2))) AND (REF((((EMA(DCLOSE,12)

  -EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2)

  《REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,

  26)),9)))*2),3)));

  DRAWTEXT(VAR90 AND MM,L*0.98,‘买’),COLORRED;

  DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C》=REF(C,1) AND C》O,L*0.98,‘↑↑’),COLORMAGENTA;

  低点:=REF(LLV(L,250),3)

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top