最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信股票公式:自动数波浪

通达信股票公式:自动数波浪

来源:网络 点击: 时间:2019-02-16

  通达信股票公式有哪些?通达信股票公式有多少种?下面股票知识网为您介绍通达信股票公式。

  W5:=COST(5);

  W10:=COST(10);{5-20反弹买入区}

  W50:=COST(50);{20-50整理区}

  W90:=COST(90);{50-80安全持股区}

  W99:=COST(99);{80-100主升风险卖出区}

  粘合度:=(W90-W10)/W10*100;

  HR:=HHV(HIGH,55);

  HRY:=LLV(LOW,55);

  HRY11:=HR*HRY;

  HRY33:SQRT(HRY11),COLORGREEN,LINETHICK1;

  IF(C》HRY33 AND HRY33 》=REF(HRY33 ,1), HRY33 ,DRAWNULL),LINETHICK1,COLORRED;

  H38:=HHV(HIGH,3);

  HR38:=LLV(LOW,3);

  HRY38:=H38*HR38;

  HRYZS5:SQRT(HRY38),COLOR00FF00,LINETHICK1;

  H13:=HHV(HIGH,8);

  HR13:=LLV(LOW,8);

  HRY13:=H13*HR13;

  HRYZS13:SQRT(HRY13),COLORFF0000,LINETHICK1;

  DRAWBAND(HRYZS5,RGB(200,50,55),HRYZS13,RGB(0,100,50));

  B:=EMA(C,2);

  S:=EMA(SLOPE(C,21)*20+C,42);

  BUY:=CROSS(B,S) AND C《LLV(L,55)*1.193;

  SEL:=CROSS(S,B) AND C》LLV(L,55)*1.3;

  DRAWICON(BUY,L*0.98,6);

  DRAWICON(SEL,H*1.03,7);

  GET:=ZIG(3,3);

  PL5:=ZIG(3,5);

  EN1:=ZIG(3,5)》REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)《=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)《=REF(ZIG(3,5),3);

  EX1:=ZIG(3,5)《REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)》=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)》=REF(ZIG(3,5),3);

  PL10:=ZIG(3,10);

  EN2:=ZIG(3,10)》REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)《=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)《=REF(ZIG(3,10),3);

  EX2:=ZIG(3,10)《REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)》=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)》=REF(ZIG(3,10),3);

  PL20:=ZIG(3,20);

  EN3:=ZIG(3,20)》REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)《=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)《=REF(ZIG(3,20),3);

  EX3:=ZIG(3,20)《REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)》=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)》=REF(ZIG(3,20),3);

  PL40:=ZIG(3,40);

  走强1:=BARSLAST(PL5《REF(PL5,1));

  走弱1:=BARSLAST(PL5》REF(PL5,1));

  走强2:=BARSLAST(PL10《REF(PL10,1));

  走弱2:=BARSLAST(PL10》REF(PL10,1));

  走强3:=BARSLAST(PL20《REF(PL20,1));

  走弱3:=BARSLAST(PL20》REF(PL20,1));

  ZTJZ5:=IF(PL10》REF(PL10,1),COUNT(EN1,走强2),0);

  ZTJD5:=IF(PL10》REF(PL10,1),COUNT(EX1,走强2),0);

  DTJZ5:=IF(PL10《REF(PL10,1),COUNT(EN1,走弱2),0);

  DTJD5:=IF(PL10《REF(PL10,1),COUNT(EX1,走弱2),0);

  ZTJZ10:=IF(PL20》REF(PL20,1),COUNT(EN2,走强3),0);

  ZTJD10:=IF(PL20》REF(PL20,1),COUNT(EX2,走强3),0);

  DTJZ10:=IF(PL20《REF(PL20,1),COUNT(EN2,走弱3),0);

  DTJD10:=IF(PL20《REF(PL20,1),COUNT(EX2,走弱3),0);

  DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,‘【A】’),COLOR00FFFF;

  DRAWTEXT(EX1 AND DTJD5=2,H*1.02,‘【B】’),COLOR00FF00;

  DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,‘【C】’),COLOR0000FF;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJD5=1,H*1.02,‘⑴’),COLORFF0000;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=2,L*0.98,‘⑵’),COLOR0000FF;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJZ5=2,H*1.02,‘⑶’),COLOR00FF00;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=3,L*0.98,‘⑷’),COLORFF00FF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.02,‘⑸’),COLOR00FF00;

  DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,‘〖Ⅰ〗’),COLORFF00FF;

  DRAWTEXT(EX2 AND DTJD10=2,H*1.05,‘〖Ⅱ〗’),COLOR00FF00;

  DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,‘〖Ⅲ〗’),COLOR0000FF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.03,‘①’),LINETHICK3,COLORFFFF00;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=2,L*0.95,‘②’),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)

  AND EX2,H*1.03,‘③’),LINETHICK3,COLOR00FF00;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=3,L*0.95,‘④’),LINETHICK3,COLOR00FFFF;

  P1:=5;

  P2:=10;

  P3:=20;

  P4:=30;

  P5:=60;

  P6:=120;

  P7:=240;

  P8:=340;

  N:=4;

  WX:=MA(CLOSE,0);

  M1:=MA(CLOSE,P1);

  M2:=(MA(CLOSE,P2) * IF((N 《 2),WX,1));

  M3:=(MA(CLOSE,P3) * IF((N 《 3),WX,1));

  M4:=(MA(CLOSE,P4) * IF((N 《 4),WX,1));

  M5:=(MA(CLOSE,P5) * IF((N 《 5),WX,1));

  M6:=(MA(CLOSE,P6) * IF((N 《 6),WX,1));

  M7:=(MA(CLOSE,P7) * IF((N 《 7),WX,1));

  M8:=(MA(CLOSE,P8) * IF((N 《 8),WX,1));

  C1:=REF(CLOSE,1);

  C2:=HHV(C1,2);

  C3:=LLV(C1,1);

  ET:=HHV(C1,2);

  ET1:=REF(ET,1);

  XB:=LLV(C1,1);

  XB1:=REF(XB,1);

  M:=BARSLAST(((CLOSE 《 XB) AND (C1 》= XB1)));

  M11:=REF(M,1);

  N9:=BARSLAST(((CLOSE 》 ET) AND (C1 《= ET1)));

  N1:=REF(N9,1);

  M21:=(BARSLAST((((M - N9) 》 0) AND (M11 《= N1))) + 1);

  N2:=(BARSLAST((((N9 - M) 》 0) AND (N1 《= M11))) + 1);

  ET2:=HHV(ET,M21);

  XB2:=LLV(XB,N2);

  A:=IF((((M - N9) 》 0) AND (M11 《= N1)),1,IF((((N9 - M) 》 0) AND (N1 《= M11)),0,2));

  H1:=IF(((M - N9) 》 0),CLOSE,ET2);

  H2:=IF((A = 1),CLOSE,C2);

  H3:=IF(((M - N9) 《 0),CLOSE,XB2);

  H4:=IF((A = 1),CLOSE,XB2);

  H5:=IF((((M - N9) 》 0) OR (A = 1)),CLOSE,H3);

  H6:=REF(H5,1);

  H7:=REF(H5,2);

  H8:=(H5 》 H6);

  H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) 《 REF(H4,2))) AND (H5 》 REF(H5,2)));

  H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2)));

  W:=((H8 OR H9) OR H10);

  T9:=((H5 《 H6) AND (H5 《 REF(H5,2)));

  T10:=((H4 = REF(H4,1)) AND (H5 《 REF(H5,2)));

  T11:=((H3 》 REF(H3,1)) AND (H5 《 REF(H5,1)));

  T12:=((H5 = REF(H5,1)) AND (H3 = H4));

  T13:=((H2 = REF(H2,1)) AND (H2 = H5));

  TW:=((((T9 OR T10) OR T11) OR T12) OR T13);

  PK:=((AMOUNT * (((OPEN + CLOSE) + HIGH) + LOW)) / 4);

  PK1:=IF((VOL 》 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4));

  BBP:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);

  DRAWTEXT((ISLASTBAR AND (BBP 》= 96.5)),(H5 * 1.033),‘明见短高,龙头除外’),COLOR00FF00;

  DRAWTEXT((ISLASTBAR AND (BBP 《 1)),((H5 + H4) / 1.96),‘明见短低,跌停除外’),COLOR0000FF;

  DRAWTEXT(((ISLASTBAR AND W) AND (BBP 《 96.5)),(H5 * 1.033),‘看涨’),COLOR0015FF;

  DRAWTEXT(((ISLASTBAR AND TW) AND (BBP 》 1)),((H5 + H4) / 2),‘看跌’),COLOR00FF00;

  DM:=CROSS((4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)

  -3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1)),8);

  DRAWTEXT(DM,L*0.98,‘★上轿!’),COLORBROWN;

  CBFB:=COSTEX(C,REF(C,1));

  JL:=IF(C》CBFB,V,0);

  CL:=IF(C《CBFB,V,0);

  JLH:=SUM(JL,4);

  CLH:=SUM(CL,4);

  LHB:=CLH/JLH;

  TJ16:=IF(HHV(LHB,5)》4 AND CROSS(2,LHB) AND C》=O,1,0);

  DRAWICON(TJ16,L*0.96,9);

  JLHS:=SUM(JL,4);

  CLHS:=SUM(CL,4);

  LHS:=JLHS/CLHS;

  TJS1:=IF(HHV(LHS,5)》4 AND CROSS(2,LHS) AND C《O,1,0);

  DRAWICON(TJS1,H*1.0096,19);

  更多通达信股票公式知识请关注股票知识网

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top